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BASIC FUNCTIONALIT Y 

(ALL MODELS)

The following chapters describe the basic functional-
ity provided by all models of the data logger blueberry 
NDL 485. The research model offers additional function, 
like creation of realtime diagrams and FTP data trans-
fer. These extented functionality is described in part 
EXTENDED FUNCTIONALITY.

Introduction
The blueberry NDL 485 is a modular data logger and 
control system. It features digital and analogue meas-
urement inputs for the connection of sensors providing 
pulses, voltage or current signals. A serial RS485 bus 
interface allows the connection of sonic anemometers 
and the extension of the measurement system with 
blueberry INPUT Modules. The digital outputs control 
external devices and they trigger alarms. The blueberry 
NDL 485 is integrated into the Internet via GSM/GPRS or 
DSL. It sends measured data automatically via E-Mail and 
FTP. The Ethernet port and the integrated web interface 
provide fast data transmission to a PC or a LAN and easy 
access via a web browser. 

Getting Started

Scope of Delivery

The following components are supplied with the data 
logger blueberry NDL 485:

• Data logger in an aluminium top-hat rail housing

• RS485 data cable with 5 pin M12x1 connector

• Crosspatch Ethernet cable for local data connection

• Manual

RS485 port + excitation
pin 1 = n.c.
pin 2 = EXC (+)
pin 3 = GND
pin 4 = RS485+
pin 5 = RS485–

BUSY indicator
flashes every 2 seconds in 
normal operation

EXC indicator
indication of 
sensor excitation 
voltage

RS232
serial port for connection 
to a modem or to the 
blueberry GSM module

LAN
Ethernet port for connec-
tion to a PC, a router or a 
PC network

POWER + GND
power supply connection 

POWER = (+), GND = (–)

EXC
switched sensor excitation 

voltage
(also available at RS485 

connector) 

DIN1 .. DIN6
digital measurement inputs

AIN1 .. AIN6
analogue measurement inputs

DOUT1 .. DOUT4
switching outputs

� �

��
�
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6. You should now see a screen similar to the image be-
low.

7. Connect sensors or test signals to the terminals at 
DIN1 .. DIN6 and AIN1 .. AIN6. Enter the measure-
ment functions according to chapter Measurement 
Setup of this manual.

Installation

Please proceed as follows to install and to test the  
NDL 485 data logger:

1. Install the NDL 485 on a top-hat rail. 

2. Connect a power source of 5..24 VDC to the POWER 
and GND terminals of the terminal strip. The BUSY 
indicator LED starts flickering or is steadily alight. 
The boot process takes approx. 2 minutes. The data 
logger is fully operating when the BUSY LED flashes 
in regular intervals of 2 seconds.

3. Plug the crosspatch cable into the LAN connec-
tion at the front plate of the NDL 485. Connect the 
crosspatch cable to the Ethernet interface of a PC or 
notebook.

4. Adapt the network settings of the PC to the IP ad-
dress and the gateway of the NDL 485. The network 
parameters are indicated on a label at the bottom of 
the housing of the data logger.

5. Start your Internet browser, enter the IP address 
of the data logger into the address field and type 
<enter>. Enter the access code into the login dialog:

 user:   admin
password:  ****   (=admin password)

Web Interface of the NDL 485
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Example: wiring of RS485 bus
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We recommend to install the NDL 485 in a shelter box 
with overvoltage protection modules for all terminals. 
The following image shows a typical measurement sys-
tem with the NDL 485 data logger, one INPUT module 

Shelter Box 0903-44-OP485 with overvoltage protection, solar power supply, data logger, blueberry INPUT module and blueberry GSM module

(20 measurement inputs in total) and the GSM module 
that integrates the data logger into the Internet via 
GPRS. A solar power supply and a set of overvoltage pro-
tection modules complete the system.
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Data Display

Displaying Actual Measured Values

The left part of the screen displays in a table all actual 
measured values. When the data logger is connected lo-
cally these values are automatically updated. At remote 
connections, please click on Refresh Data View below 
the data table in order to update the display. Measured 
values are displayed as floating point numbers with 
the significant number of characters after the decimal 
point.

Web Interface

Introduction

The user surface of the data logger blueberry NDL 485 
is a web interface. Configuration of the data logger, 
display and download of measured data requires a web 
browser (e.g., Internet Explorer, Opera, Mozilla). The 
data logger is connected to the PC locally via Ethernet or 
via remote data transmission (DSL, GSM, GPRS).

Start the browser, enter the IP address of the data logger 
into the address field and type <enter>. Enter the access 
code into the login dialog. The NDL 485 provides two 
user levels: 

The user guest is allowed to display actual measured 
values and configuration settings and to download 
measured data. He cannot delete any data or change 
configuration settings. He is only allowed to set date 
and time. 

The user admin has all rights. In addition to the guest 
rights he is allowed to delete measured data and to 
change the configuration.

Realtime Display of Actual Measured Values

Login Dialogue
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Data Transfer

Downloading Measured Data

The NDL 485 contains two ring buffer data memories; 
one for the statistics, one for the samples. Actual data 
overwrite the oldest data lines which makes the deletion 
of the memory unnecessary. 

Select Archive in order to display a list of all stored 
statistics files. The NDL 485 creates one statistics file 
per day. These files contain time series of the statisti-
cal evaluations of the samples. The file name contains 
the index of the actual measurement, the date and the 
tag stat for ‚statistics‘. The data logger increments the 
index every time the configuration is changed or the 
data logger reboots. 

 Example:  000024_2004-03-19_stat.csv

Select HighRes in order to display a list of all stored 
samples files. The NDL 485 creates one CSV file per hour. 
These files contain time series of all measured samples. 
The file name contains the index of the actual measure-
ment, date and time, and the tag meas for ‚measure-
ment‘.

 Example:  000024_2004-03-19_15_meas.csv

Download of measured data works like a download from 
an Internet site: click with the right mouse button on a 
file, select Save file as... from the pulldown menu, enter 
the destination path and click OK. 

CSV files can be imported into data analysis software like 
WAsP or WindPRO. Double-clicking on the CSV file opens 
it directly in MS-Excel.

Data Format

The NDL 485 stores measured data as comma separated 
ASCII files (CSV). Each data file contains a header which 
indicates information about the data logger and the 
measurement configuration: serial number of the data 
logger, index of the measurement, measurement func-
tions and parameter settings. The header is followed 
by an empty line and a line with column headers. The 
measured data lines have the format: date, time, pe-
riod, measured values. Decimal delimiter is a dot (e.g., 
2.564).

Archive: statistics data files

Download of Measured Data
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Statistics data file in an ASCII editor

Statistics data file in MS Excel
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Transmitting Measured Data 

via E-Mail

The NDL 485 sends measured data automatically via 
e-mail every day at 0:00. The CSV data file of the previ-
ous day is attached to the e-mail. If several files have 
been created since last e-mailing (e.g., because of con-
figuration changes or rebooting of the data logger) all 
closed files are send. Each file is attached to a separate 
e-mail. Please first setup the Internet integration via 
GPRS or DSL.

To setup the e-mail data transfer select  
Setup > FTP/Mail. 

Enter the URL of your mail server (SMTP server) in the 
field Mail Server. If your mail server requires authoriza-
tion enter the user name and password. Enter the mail 
addresses in the field Recipient(s). Separate more than 
one mail address by space characters. 

Select yes at Test Mail Transfer now.

Click OK to save the settings. If the Test Mail option is 
active the NDL485 now sends a test mail to all recipi-
ents. A message displays the result of the test mailing. 
Please check whether the mail has been sent without 
errors. Otherwise, please check the correctness of your 
settings.

Site Description
(Documentation)
The NDL 485 saves information about the measurement. 
They are stored in the header of each CSV data file for 
proper documentation of the measurement process.

To enter the information about the measurement select
Setup > Site Description.

Documentation of the measurement includes the follow-
ing information:

Name    Name of the measurement site

Description  Description of the measurement loca-
tion and its environment. Please enter 
here orography, roughness, obstacles 
and other elements having an impact 
on the measurement result.

Geographical Position Enter here latitude, longitude 
and elevation of the measurement 
site.

Setup: E-Mail Data Transmission

Setup > Site Description (Documentation of the Measurement)



Data Logger  blueberry NDL 485 Wilmers Messtechnik GmbH 

- 12 -

Data Logger  blueberry NDL 485 Wilmers Messtechnik GmbH 

- 13 -

Other Information  Use these universal input fields 
to enter all supplementary informa-
tion about the measurement: 
e.g., geographical coordinate system, 
mast type, mast dimensions, type, se-
rial numbers and calibration numbers 
of the sensors, dimensions and align-
ment of sensor mounting booms
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Selecting always on switches the ex-
citation voltage continuously on. The 
blueberry INPUT Module requires this 
setting as it needs a warm-up time of 
approx. 5 seconds.

Setting Measurement Functions

To add a new measurement function enter a function 
name in the field Name, check the required statistical 
evaluations and enter the measurement function. Type 
<enter> to transmit the settings to the data logger. 

Function Names

Variable names may principally contain umlauts (ä, ö, 
ü) and special characters like comma (,) and period (.). 
If function names are used as variables in further meas-
urement functions the first part of the function name 
may however only contain the following characters: 
A..Z, a..z, 0..9, _. The second part, i.e. the part after the 
first space character is used as axis label for realtime 
diagrams. We recommend to use the following syntax for 
function names: Value (unit).

Setup > Measurement: Measurement Parameters and Measurement Functions

Measurement Setup

Setting Measurement Parameters

To define measurement parameters or sensor character-
istics select Setup > Measurement:

Measure Period Measure period is the time interval in 
which the data logger records actual 
measured values (samples) from all 
sensors. 

Statisic Interval Statistic interval is the time interval 
in which the data logger performs a 
statistical evaluation of the samples 
and stores the results in the memory. 
The variables a1..an correspond to 
the first to nth value of the data line 
sent by the first sensor. The variables 
b1..bn correspond to the values sent 
by the second sensor and so further.

Excitation  defines how long the sensor excitation 
voltage (EXC) is switched on before 
the NDL 485 sends a poll command. 
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sin Sine function. The angle must be defined in de-
grees. 

 Example: Vector Component
 vWind (m/s)  = 0.04752 * b8 + 0.224 * (b8>0)

dirWind (°)  = (360 * (a1-a2)/a1) % 360
vEast (m/s)  = vWind * sin (dirWind)

 The multiplication of the wind speed with the 
sine of the wind direction results in the eastern 
component of the total wind speed vector.

cos Cosine function. The angle must be defined in 
degrees. 

 Example: Vector Component
 vWind (m/s)  = 0.04752 * b8 + 0.224 * (b8>0)

dirWind (°)  = (360 * (a1-a2)/a1) % 360
vNorth (m/s)  = vWind * cos (dirWind)

 The multiplication of the wind speed with the 
sine of the wind direction results in the north-
ern component of the total wind speed vector.

ln Natural logarithm   

 Example: log = ln c7

Boolean Operators

> Comparison superior to. The result is 1, if the 
condition is true, otherwise it is 0.  

 Example: Calibrated Cup Anemometer
 ws30m (m/s)= 0.04827 * c2 + 0.19 * (c2 > 0)

 This function suppresses the wind speed offset 
when the frequency is 0. Otherwise, even at to-
tal calm the data logger would indicate a wind 
speed of 0.19 m/s.

< Comparison inferior to. The result is 1, if the con-
dition is true, otherwise it is 0.  

 Example: Status from Threshold Value 
 Temperature (Celsius) = 20 * a4 - 40

Frost = Temperature < 0

 The comparison with a threshold value creates 
the status signal 1 = frost / 0 = no frost.

Example:
vWind80m (m/s) = 0.04727 * b10 + 0.264 * (b10>0)

The first part of the function name can be used as 
variable vWind80m in further measurement functions. 
The diagram title for this function is vWind80m, the y 
axis label is (m/s).

Maximum length of the measurement function including 
function name and statistics options is 1023 characters 
or 64 elements. Each variable or operator counts as one 
element. Please use the following elements to built the 
measurement function:

Arithmetic Operators

+ Addition

– Subtraction or minus sign. If a – is used to char-
acterize a negative number at the beginning of a 
measurement function or after another operator 
the number must be put into parenthesis.

 Example: Negative Numbers
 HumAir (%RF)  = (–25) + 62.5 * a5

vSonic (m/s)   = e2 else (–9999)

* Multiplication

/ Division

^ Exponent, real number

 Example: Length of a Vector
 uSonic (m/s)= d2

vSonic (m/s)= d3
wsHorizontal (m/s)=(uSonic^2 + vSonic^2)^0.5

 This function converts the u and v components 
of a sonic anemometer to horizontal wind speed. 

% Modulo division. This operator provides the 
positive residue of a division. Unlike the general 
modulo operator defined for integer numbers, 
the NDL 485 modulo operator is based on real 
(floating point) numbers for parameters and for 
the result. The second parameter of the % func-
tion must be positive (a % b with b>0).

 Example: Wind Direction 
 winddirection (°) = (360 * b1 / b0 + 268) % 360

 The measured wind direction value with an off-
set correction of 268 degrees is projected into 
the range of 0..360°.
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if This operator checks whether a value is not 0 or 
nan. The if operator is typically combined with 
the else operator.

 Example: Output Limitation
 Hum (%RH) = 100*a4 if (100*a4<=100) else 100

 In case of condensation, some thermo hy-
gro sensors show measured values above 
100 %RH. This function limits the output of 
relative humidity to 100 %RH. 

 Example: Validity Check
 vCup (m/s)  = 0.253 * b8 + 0.22 * (b8>0) 

vValid (m/s)  = vCup if ((vCup>=0)*(vCup<90))

 This function defines a range of 0 to 90 m/s for 
valid wind speed values. The result of vValid is 
vCup if vCup is within this range, otherwise it is 
nan.

else replaces a value if the value is nan.

 Example: Filtering of invalid Samples
 uSonic (m/s) = d2 else #uSonic else 0

 If the sonic anemometer returns an invalid val-
ue, the data logger will keep the previous value. 
If the previous value is also invalid the result is 
set to 0.

 Example: Marking of invalid Samples
 relHum (%RH) = 100*a2 else (–9999)

 Invalid samples (nan) are stored as –9999.

Combining boolean Results:

The multiplication operator * corresponds to the logical 
AND operator. The addition operator + corresponds to 
the non exclusive OR operator. 

Example: AND, non exclusive and exclusive OR
AND  = (a2>=0) * (a2<=100)  
OR  = (a2<0) + (a5<0) 
XOR  = ((a2<0) + (a5<0)) == 1

== Comparison equal. The result is 1, if the condition 
is true, otherwise it is 0.  

 Example: 
 identic = (0.2 * a2) == 1.2

 This function compares a measured value with a 
constant. 

!= Comparison not equal. The result is 1, if the con-
dition is true, otherwise it is 0.  

 Example: 
 differentStatus (1=different) = c1 != c2 

with third poll command:  DIN

 This function compares the status of digital 
inputs DIN1 and DIN2. 

>= Comparison superior or equal. The result is 1, if 
the condition is true, otherwise it is 0.  

 Example: 
 condensation = Humidity >= 100.1

 Relative humidity of more than 100 %RH is con-
sidered as condensation.

<= Comparison inferior or equal. The result is 1, if 
the condition is true, otherwise it is 0.  

 Example: 
 DOUT1 (Heating) = Temperature <= 10.5

 A heating is switched on through switching out-
put DOUT1 at temperatures of or below 10.5 °C.

! NOT operator. This operator inverts the logical 
level of a boolean value.

 Example: 
 DOUT2 = ! a1 

with first poll command:  DIN

 Switching output DOUT2 is set active if the sta-
tus signal at digital input DIN1 is low.

valid This operator checks whether a value is a valid 
number. The result is 0, if the value is nan, other-
wise it is 1.  

 Examples: Validity Check
 checkValue (1=Ok) = valid (2.45 * a1)  

error (1=invalid)   = ! valid (2.45 * a1)
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Rounding Operators

abs provides the unsigned floating point value of a 
signed value.

 Example: 
 alwaysPositive = abs (125 * g7 –75)

int removes the decimal part of the floating point 
value.

 Example: 
 intValue = int (–2.45 * d2 + 100)

round rounds the floating point value to the nearest 
integer (up or down).

 Example: Display without Decimals 
 LowResDir (deg) = round((360 * a2/a1) % 360)

 This function displays the wind direction with-
out decimals.

 Example: Fixed Number of Decimals
 Radiation = 0.01 * round(100 * (2.645*a2–25))

 The floating point function result is reduced to 
2 decimals.

Other Operators

( ) Parantheses structure the function elements and 
determine the calculation sequence. 

# provides the previous value of the measurement 
function. 

 Example: Cumulative Rainfall
 actualRain (mm) = 0.1 * b3 

cumulRain (mm) =  
    (#cumulRain + (actualRain   else   0))

else actualRain else 0

 These two functions record actual and cumula-
tive rainfall. cumulRain adds the actual rainfall 
to the previous cumulative rainfall. When the 
measurement starts #cumulRain is invalid 
because no previous value exists. The result is 
then replaced by actualRain. If this value is also 
invalid the result is set to 0. The else operator 
defines the starting value and prevents the 
cumulative value from being reset in case of an 
invalid value of actualRain.

 Example: Low Pass Filter
 noisy  = 62.5 * a6 – 55

damped  = (0.1 * noisy + 0.9 * #damped) else noisy

 This function implements a low pass filter that 
smooths a noisy value. damped provides a 
damped value of the actual measurement value 
provided by noisy.

Low pass filtering of noisy data

Actual and cumulative rainfall
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Operator Summary

The following table lists examples of results based on 
the operators with different parameters.

Results for: a = ...

   –2.7183 0 +2.7183 nan

a else b –2.7183 0 2.7183 b

b if a b nan b nan

b if a else c b c b c

valid a 1 1 1 0

! a 0 1 0 0

a > 0 0 0 1 nan

a < 0 1 0 0 nan

a == 0 0 1 0 nan

a != 0 1 0 1 nan

a >= 0 0 1 1 nan

a <= 0 1 1 0 nan

a % 1 0.2817 0 0.7183 nan

a % 0.01 0.0017 0 0.0083 nan

a–(a%0.01) –2.72 0 2.71 nan

abs a 2.7183 0 2.7183 nan

int a –2 0 2 nan

round a –3 0 3 nan

ln a nan nan 1.0000 nan

Variables

Variables  The variables a1..an correspond to the 
first to nth value inside the data line sent 
by the first sensor. The blueberry INPUT 
module supplies the voltages of all inputs 
in Volt as well as the frequency in Hertz 
and the counted pulses. In addition to 
the variables, other function names can 
be used inside a measurement function. 
They must be defined former to the func-
tion in which they are used as a variable. 
A # character in front of a function name 
provides the measurement value of the 
previous measurement.

 Example: Temperature Gradient
 Temp (°C)   = 100 * a3 – 30
 deltaTemp (°C)  = (Temp – #Temp) else 0

 deltaTemp provides the temperature 
gradient.

Predefined Variables (Time Info)

The following predefined variables provide time infor-
mation.

PERIOD provides the actual measurement period 
in seconds. 

 Example: Integration over Time
 flow (m3/s)  = 125 * b2 

volume (m3)  = flow * PERIOD  

 The function volume uses PERIOD to 
convert actual flow into a volume.

TIME provides the time in seconds since 
1.1.1970 00:00:00. 

DAYTIME provides the time in 
seconds since 00:00:00 of the current day. 

 Example: Flashing Light
 DOUT3 (flash) = ! (DAYTIME % 10)  

 This function flashes a signal lamp every 
10 seconds.

Setup > Measurement: measurement functions and variables

a1 .. a8
b1 .. b12
c1
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sent by the NDL 485 to the serial 
port. Some sensors (e.g., R.M.Young 
sonic anemometers) require character 
delays. The blueberry INPUT Module is 
polled with a character delay of 0.

Poll Pause  defines the delay between the last 
character of a data line received by the 
NDL 485 and the sending of the next 
poll command. The blueberry INPUT 
Module requires a poll pause of 50 ms. 
The poll pause is required because the 
RS 485 bus allows only one component 
(sensor, INPUT Module or data logger) 
at a time to transmit data. All other 
components work in receiver mode. 
The poll pause allows to switch from 
transmitter to receiver mode.

Timeout  defines the maximum time the 
NDL 485 waits for the answer to a poll 
command. If the polled component 
does not answer the poll command 
will be repeated once or several times 
depending on the value set for Retry. 
If no data was received the meas-
ured values are stored as nan („not a 
number“).

Poll Command Enter the poll command into the field 
Poll Command and click OK to save the 
setting into the data logger. 

Setup > Measurement: RS485 Data Polling

YEAR provides the actual calendar year as 4 
digit integer (e.g., 2007). 

MONTH provides the actual calendar month as 
integer (January = 1 .. December = 12). 

 Example: Season dependent Factors
 factor = 0.26*(MONTH<4) + 

0.22*(MONTH==4) + 0.25*(MONTH>4)

 This function selects a factor depend-
ing on the month. Some algorithms for 
determination of potential evaporation 
(e.g., HAUDE) use empirical factors that 
vary with the season of the year.

DAY provides the actual calender day as 
integer (1 .. 31). 

HOUR provides the actual hour as integer 
(0 .. 23). 

MINUTE provides the actual minute as integer 
(0 .. 59).

SECOND provides the actual second as integer 
(0 .. 59). 

WEEKDAY provides the day of the week as integer 
(Monday = 1 .. Sunday = 7).

YEARDAY provides the day of the year as integer 
(1st January = 1).

Click OK to save the settings into the data logger. As the 
measurement functions represent virtual channels they 
are independent of the number of hardware inputs of the 
data logging system. The user can define an unlimited 
number of measurement functions.

Setting up Data Polling

The  NDL 485 sends poll commands through the RS 485 
serial port and to the internal measurement interfaces. 
Each poll command provides a set of return values that 
are used as variables in the measurement functions. 
Please set the poll parameters as follows:

Baudrate  Select from the Baudrate list the baud 
rate of the serial port. The blueberry 
INPUT Module requires a baud rate of 
19200.

Character Delay Select from the Character Delay list 
the delay between the characters 
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The following poll commands provide measured values 
from the NDL 485 data logger itself:

Command: digital
Results:

Index Value Unit

1 Counter of DIN1 -

2 Frequency of DIN1 Hz

3 Counter of DIN2 -

4 Frequency of DIN2 Hz

5 Counter of DIN3 -

6 Frequency of DIN3 Hz

7 Counter of DIN4 -

8 Frequency of DIN4 Hz

9 Counter of DIN5 -

10 Frequency of DIN5 Hz

11 Counter of DIN6 -

12 Frequency of DIN6 Hz

Command: DIN
Results:

Index Value Unit

1 Status of DIN1 (1 = HI, 0 = LO) -

2 Status of DIN2 (1 = HI, 0 = LO) -

3 Status of DIN3 (1 = HI, 0 = LO) -

4 Status of DIN4 (1 = HI, 0 = LO) -

5 Status of DIN5 (1 = HI, 0 = LO) -

6 Status of DIN6 (1 = HI, 0 = LO) -

Command: analog
Results:

Index Value Unit

1 Voltage of AIN1 V

2 Voltage of AIN2 V

3 Voltage of AIN3 V

4 Voltage of AIN4 V

5 Voltage of AIN5 V

6 Voltage of AIN6 V

7 Voltage of EXC V

8 Voltage of power supply V

The following poll command provides measured values 
from the blueberry INPUT Module: 

Command: #AA\r    (with AA = 01..99 = poll address)

Results: 
(serial numbers from 4001, firmware version 4.2)

Index Value Unit

1 Voltage of IN1 V

2 Voltage of IN2 V

3 Voltage of IN3 V

4 Voltage of IN4 V

5 Voltage of IN5 V

6 Voltage of IN6 V

7 Voltage of IN7 V

8 Voltage of IN8 V

9 Counter of IN1 -

10 Counter of IN2 -

11 Counter of IN3 -

12 Counter of IN4 -

13 Counter of IN5 -

14 Counter of IN6 -

15 Counter of IN7 -

16 Counter of IN8 -

17 Frequency of IN1 Hz

18 Frequency of IN2 Hz

19 Frequency of IN3 Hz

20 Frequency of IN4 Hz
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Example: Reset Timer for GSM Modem

DOUT2 (1=Modem On) = !((HOUR==3) * (MINUTE<1))

DOUT2 switches a GSM modem off for one minute every 
day at 3:00 a.m.

Example: Timer for GSM Modem

DOUT2 (1=Modem On) = (HOUR>=11) * (HOUR<14)

DOUT2 switches a GSM modem on every day from 11:00 
to 14:00.

Example: Timer for GSM Modem

DOUT2 (1=Modem On) = (HOUR==8) + (HOUR==15)

DOUT2 switches a GSM modem on every day from 
8:00 to 9:00 and from 15:00 to 16:00.

Example: Flashing Light 

DOUT3 (Signal) = SECOND%2

DOUT3 flashes a lamp every 2 seconds.

Example: Wind Speed from a specific Sector

WS (m/s)    = 0.254 * b12 + 0.213 * (b12>0)
WD (deg)    = (360 * b1/b2 + 127) % 360
DOUT4 (Storm)  = (WS>15) * (WD>90) * (WD<180)

DOUT4 triggers a storm alarm for wind speeds WS 
above 15 m/s and wind directions WD from the sector 
between east and south. The multiplication operator 
* provides the logical AND combination of all three 
conditions.

Example: Switching Output with Hysteresis

T (°C)    = 100 * a4 - 40
DOUT1 (Heating) = (T<0) + (#DOUT1 * (T<4)) else 0

DOUT1 controls a heating with a hysteresis. Tempera-
tures below 0 °C switch the heating on. Temperatures 
above 4 °C switch the heating off.

21 Frequency of IN5 Hz

22 Frequency of IN6 Hz

23 Frequency of IN7 Hz

24 Frequency of IN8 Hz

25 Barometric pressure 
(only partNo.0151-P, else 0.00)

hPa

26 Onboard temperature
(only partNo.0151-P, else 0.0)

°C

27 Voltage of power supply V

28 Voltage of CC1
(constant current supply)

V

29 Voltage of CC2
(constant current supply)

V

Data Format Select the data format from the list: 
decimal reads the received data values 
as decimal floating point numbers. 
hex reads the received data values as 
hexadecimal values and converts them 
into decimal integer values 
(e.g., 8A ð 138).

Click OK to save all settings into the data logger.

Setting the Digital Outputs

The blueberry NDL485 provides 4 digital outputs. They 
are used to control peripheric devices or sensors. Digital 
outputs can be triggered depending on measured values 
or depending on time. 

To set the digital outputs select Setup > Measurement. 
Define a measurement function and use DOUT1, DOUT2, 
DOUT3 or DOUT4 as function name to switch the respec-
tive output. The output is LO if the result of the meas-
urement function is 0, otherwise it is HI. The DOUTn tag 
must not be followed directly by another character. If 
you want to add additional text to the function name 
please insert a blank character after the DOUTn tag.

Example: Heating Control

DOUT1 (1=Heater ON) = TempAir < 4

DOUT1 activates a heater at ambient air temperatures 
below 4 °C.
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Testing Poll Commands

Poll commands can be entered manually in order to test 
the response of the data logger, a sensor or an INPUT 
Module.

Select Setup > Measurement. Scroll down to RS485 
Setup and click on (test) in the Poll Commands section. 
This opens a new browser window with a text terminal. 
Please set the RS485 interface parameters appropriate 
to the device to poll. Enter the poll command into the 
Send field and click on OK. The NDL485 will now record 
all answers of the polled device during the time period 
defined by Timeout and display it in the lower part of the 
window.

Manual polling can be used to test whether a sensor 
provides proper data. It can also be used to read out the 
configuration of a sensor (e.g., a sonic anemometer) or 
of the blueberry INPUT Module or to change parameters 
in these devices. The following pictures show the test-
ing of the analogue inputs of the data logger NDL485 
and the use with the controller of the WindPowerPack 
generator system.

Setup > Measurement > Test poll commands

Test poll commands for WindPowerPack controller

Test poll commands for analogue inputs of NDL485



Data Logger  blueberry NDL 485 Wilmers Messtechnik GmbH 

- 22 -

Data Logger  blueberry NDL 485 Wilmers Messtechnik GmbH 

- 23 -

N O T E S
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Setting Date and Time
If the NDL 485 is connected to the Internet the data 
logger updates its internal realtime clock automatically 
from an Internet time server. The NDL 485 adjustes the 
clock to the time zone set by the user. 

Select Setup > Date & Time to set the parameters for re-
altime clock synchronization. Select the time related to 
UTC. Select the region where the data logger is installed. 
The NDL 485 uses the time server the closest to its site 
in order to provide maximum accuracy. Optionally, select 
a time server. If you do not define a specific time server 
the NDL 485 automatically selects a suitable server from 
a pool of time servers. Click OK to accept the settings.

If the data logger is not connected to the Internet, se-
lect Adjust Clock to set the realtime clock manually. 

Select the settings from the Time and Date lists and click 
OK. 

Setup > Network: LAN and local PC Connection

Setup > Date and Time: automatical synchronization via Internet

Network Interface

Setting the Network Parameters

The NDL 485 can be connected locally to a PC via cross-
patch cable and it can be integrated into a PC network 
(LAN) by means of a standard Ethernet cable. The IP 
address of the data logger has to be adapted to the net-
work.

Select Setup > Network. 

Assign an IP address to the data logger. 

Enter the subnet mask required for your network type. 
If you are unsure about the subnet mask leave this 
field empty. In this case, the default subnet mask 
255.255.255.0 is used. 

Enter the gateway and name server (DNS) of your LAN 
and click OK. The data logger uses the gateway to built 
up a connection to the Internet in order to send data via 
e-mail or FTP and to synchronize the internal realtime 
clock from the Internet.

Setup > Date and Time: manual adjustment of realtime clock
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Internet Integration
The NDL 485 is integrated into the Internet by means of 
a DSL router or in remote sites by means of the blueberry 
GSM Module. The GSM Module offers remote data trans-
mission and realtime access via cellular phone networks 
(900 MHz, 1800 MHz and 1900 MHz). Two operation 
modes are available:

In GSM mode, the data logger is called from a PC by 
means of a telephone modem, similar to the dial-in con-
nection to an Internet provider. This mode offers direct 
access to the web server of the NDL 485. In GSM mode, 
the telephone costs depend on the connection time.

The GPRS mode offers full integration of the NDL 485 
into the Internet. The data logger connects itself au-
tomatically to the Internet providing realtime access 
from any Internet access point. Two password levels 
protect the data logger against unauthorized access. 
As GPRS does not use fixed IP addresses a dynamic DNS  
server (e.g., dyndns.org) manages the dynamic IP ad-
dress. It provides access via a named URL. The name of 
the server used by the NDL 485 to access the Internet 
is called Access Point Name (APN). Private APNs pro-
vide outgoing data transmission from the data logger 

to the Internet, e.g., via FTP or e-mail. However, they 
block access from outside into the data logger. Public 
APNs provide both access types. Dynamic DNS requires 
a public APN! Please make sure that your GSM provider 
offers a public APN. Public APNs are offered among oth-
ers by T-Mobile (Germany), TIM (Italy), Telenor (Norway), 
WARID (Pakistan). In GPRS mode, the telephone costs 
depend on the volume of transmitted data.

Please prepare the following information for the GSM/
GPRS setup of the NDL 485:

1. The data number of the SIM card. Please make sure 
that you are really using the data number. Usually, 
SIM cards have separate numbers for voice, fax and 
asynchronous data transmission. We recommend 
to use SIM cards without voice function. Pure data 
cards are cheaper than voice cards.

2. The PIN of the SIM card. You must disable the PIN 
request before use because the NDL 485 is not able 
to enter the PIN. Please insert the SIM card into your 
mobile phone, enter the PIN and disable the PIN re-
quest. 

3. The APN. Please make sure that you have got a public 
APN.

Setting up the GPRS Connection

Select Setup > GPRS to setup a GPRS connection. Select 
yes at Activate GPRS and enter the APN and optionally 
the user name and password at GPRS Internet Connec-
tion. Please ask your GSM provider for these data. A list 
of international APNs is available in the Internet at

Setup > GPRS/Modem: GPRS Internet Connection
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3. Define a user name, a password and enter your e-mail 
address.

 Scroll down and activate I agree to AUP and I will 
only create one (1) free account. Click on Create Ac-
count.

4. A message confirms the creation of your account.

5. You will now receive an e-mail with a confirmation 
for the DynDNS account. This takes typically a few 
minutes. Open the e-mail and follow the stated link.

http://www.quickim.com/support/gprs-settings.html.

When the NDL 485 operates in GPRS mode it will switch 
to GSM mode every day between 20:00 and 21:00. During 
this time the data logger is accessible via dial-in connec-
tion.

Please enter the host name of the data logger in sec-
tion Dynamic DNS Service. Please enter the access 
code to your dyndns.org account in the fields Username 
and Password. The host name must be registered at 
http://www.dyndns.org before. Please refer to the fol-
lowing chapter for further details.

Click OK to save the settings.

Remote Access via Internet

GPRS networks use dynamic IP addresses. Every time the 
NDL 485 connects to the Internet it gets a new IP address 
from the Internet service provider. If we want to access 
the data logger via Internet we need to know this IP ad-
dress. Dynamic DNS manages dynamic IP addresses and 
provides access to them. The user defines a host name for 
his measurement station (e.g., station-103.dyndns.org). 
When the NDL 485 connects to the Internet it sends its 
actual IP address to the DynDNS server. The DynDNS 
server translates the IP address to the host name of the 
data logger. This provides us access to the measurement 
station without knowing its IP address.

Creating a DynDNS Access

Please proceed as follows to create your account and a 
host at DynDNS:

1. Open your Internet browser and visit the web site 
http://www.dyndns.org.

2. Select Create Account.
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 You have now created your account. The next steps 
create a DynDNS host.

6. Select Login.

7. Enter your access code (user name and password) and 
click Login.

8. Select My Services.

9. Select Add New Hostname.

10. Enter a host name and click Use auto-detected IP 
address. Click Create Host.

11. A message confirms the creation of the new host.

This host can now be used with the NDL 485 (see Setting 
up the GPRS connection). If you want to create further 
hosts, please click Add New Hostname and repeat step 
10.
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1. Connect your mobile device to the Internet and start 
the Internet browser. 

2. Enter the DynDNS host name of your measurement 
station into the address field and add /compact to the 
host name. (e.g., station-103.dyndns.org/compact). 
Do not add www to the host name!

3. Click Connect.

4. Enter user name and password of the data logger into 
the login dialog.

The functionality of the mobile access depends on the 
browser of your mobile device. Some mobile browsers 
might not be able of downloading measured data files. 

Accessing the NDL485 via Internet

Please proceed as follows to access your NDL 485 from 
the Internet:

Start your Internet browser, enter the DyDNS 
host name of your measurement station (e.g., 
station-103.dyndns.org) into the address field and hit 

<enter>. Do not add www to the host name!

The remote Internet access provides the same function-
ality as the local access via Ethernet. The user can dis-
play and download data and diagrams and he can change 
the configuration.

Accessing the NDL 485 from a Mobile Phone

The NDL 485 provides a special web interface adapted to 
small displays of pocket PCs, MDAs and mobile phones. 

Please proceed as follows to access your NDL 485 from 
an Internet capable mobile device :

Internet access via DynDNS from a mobile phone

Internet access to an NDL 485 research via DynDNS from a desktop PC
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Opera offers a powerful free browser for mobile phones. 
Please refer to http://www.operamini.com for further 
details.

Remote Access via GSM

GPRS provides the most flexible and powerful remote 
access to the NDL 485. It requires a public APN. For GSM 
providers that do not offer a public APN, the blueberry 
GSM Module provides remote connection to the NDL 485 
via PPP. This operation mode is similar to a dial-in con-
nection to an Internet server. It requires a PC with ana-
logue telephone modem. 

Setting up the GSM Connection

Please proceed as follows in order to configure your Win-
dows PC for a GSM remote connection:

1. Select Start > Settings > Network and Dial-In 
Connections > New Connection.  A wizard will lead 

you through the configuration process.

2. Click Next.

3. Select Establish an Internet Connection and click 
Next.

4. Select Manual Connection and click on Next.

5. Select Modem Connection and click Next.
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data transmission. Please make sure to use the data 
number. Click Next.

9. Click Next without entering the access code in the 
dialogue.

10. Click Next to finish the configuration.

This chapter describes the configuration process under 
MS Windows XP. Similar wizards assist you at the con-
figuration under Windows 2000, Mac OS or Linux.

Accessing the NDL 485 via GSM

Please proceed as follows in order to establish a remote 
connection to the NDL 485 via GSM:

1. Select Start > Settings > Network and Dial-In 
Connections > blueberry-ndl485 where blueberry-
ndl485 is the name of your remote connection.

6. A list displays all modems available on your PC. Se-
lect the modem to be used for remote data transmis-
sion and click Next.

7. Enter a name for the remote connection, e.g., the 

name of the measurement site and click Next.

8. Enter the telephone number of the GSM modem. 

GSM SIM cards have separate numbers for fax and 

Dial-in Connection under Windows XP
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Password Protection
Two password levels protect the NDL 485 against unau-
thorized access:

The user guest is allowed to view actual measured data 
and configuration settings and to download measured 
data. He is allowed to set date and time. The user guest 
is not allowed to delete measured data or to change any 
configuration settings.

The user admin has all rights. He is allowed to delete 
measured data and to change configuration settings.

Setting the User Password

Login as user admin and select Setup > Password. Enter 
the new password for user guest and click OK. 

The password for the user admin cannot be changed.

2. Click on Dial without entering the access code. A dia-
logue diplays the progress while connecting. When 
the connection has been established the dialogue 
box changes into an icon in the lower right corner of 
the task bar.  

3. Once the connection is established, please start your 
Internet browser, enter the IP address 10.1.1.1 into 
the address field of the browser and hit the <enter> 
key. Please note that this IP address is the same for 
all NDL 485 units. It is independent of the IP address 
set at Local Network Settings.

4. Enter the user name and password for the NDL 485 
and click OK.

5. In GSM mode, the web interface provides all func-

tions that are available at local or at GPRS connec-
tion.

6. To disconnect the GSM connection click on the con-
nection icon with the right mouse botton and select 
Disconnect from the popup menu.

Login Dialogue

Web Interface in GSM Mode

Windows Task Bar: Disconnect GSM Connection

Setup > Password: User password
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Rebooting the NDL 485
The NDL 485 can be rebooted in two ways: by interrup-
tion of the power supply and via the web interface. In 
order to reboot the NDL 485 via the web interface please 
proceed as follows:

1. Start the web browser and login to the NDL 485 as 
user admin.

2. Select Help > About > Maintenance.

3. Click on Reboot in order to start the update process. 

4. Wait 2 minutes until the data logger is up again.

Help Function
The help function the NDL 485 provides system informa-
tion about the data logger as well as an online manual.

Select Setup > Help > About. The dialog indicates in-
formation about type and firmware version of the data 
logger.

Select Help > Manual to view a short manual of the 
NDL 485.

Help > About: Data Logger System Information

Help > Manual: Online Manual
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FTP Access
Some operations, like deleting measured data and ap-
plying a firmware update require an FTP access to the 
NDL 485. The following describes the establishment of 
an FTP access by means of the free FTP client FileZilla. 

Installing FileZilla

The FTP client FileZilla can be downloaded free of charge 
from the Internet at the following site:

 http://sourceforge.net/projects/filezilla

In order to install FileZilla and to configure it for the 
NDL 485 please proceed as follows:

1. Download the software from the above stated web-
site and install it according to the instructions of the 
supplier.

2. Start FileZilla.

3. Select File > Server Mangement.

4. Select New Server and enter a name for the data 
logger.

5. Enter the IP address of the NDL 485  into the Host 
field.

6. Select the logon type normal.

7. Enter the user name admin and the admin password 
of your NDL 485 .

8. Click on Save to save the settings.

9. Click on Connect to built up the connection to the 
NDL 485. The right part of the screen displays the 
file system of the NDL 485. You can use the FTP client 
like a file explorer to delete measured data files from 
the NDL 485 and to move files from the NDL 485 to 
your local computer or from your computer to the 
NDL 485.

Deleting Measured Data
The NDL 485 saves measured data in a ring buffer. The 
oldest data lines are automatically overwritten when the 
data memory is full. Usually, deleting of measured data is 
only necessary at the beginning of a new measurement, 
e.g., if the data logger is moved to another site. In order 
to delete measured data please proceed as follows:

1. Establish an FTP connection to the NDL 485.
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5. Click with the right mouse button on the firmware 
update file (e.g., Ndl485-2-0-11.install) and select 
Upload. Now, FTP transfers this file to your NDL 485. 

6. Please wait until the transfer is sucessfully complet-
ed. The uploaded file is now visible in the /tmp folder 
of the NDL 485.

7. Start the web browser and login to the NDL 485 as 
user admin.

8. Select Help > About > Maintenance.

9. Click on Update in order to start the update process. 

2. Double click on archive to change to the archive 
directory. 

3. Mark all files to be deleted and press <Del>.

If only data files (*.csv) are deleted the measurement 
index continues with the actual value. In order to reset 
the index please delete the file index.

Updating the Firmware
The firmware of the NDL 485 can be updated via local 
Ethernet connection or remotely via GSM, GPRS or DSL. 
In order to update the firmware of the NDL 485 please 
proceed as follows:

1. Establish an FTP connection to the NDL 485.

2. Double click on .. to change to the root directory. 

3. Open the folder /tmp.

4. Change on the local computer to the folder that con-
tains the firmware update file.
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Adapting the PC Network 
Settings
When the  NDL 485 is connected to a PC or a LAN the 
network settings of the PC must comply to those of the 
data logger.  

In order to change the network settings of the PC please 
proceed as follows:

1. Right click on the network icon in the task bar and 
select Open Network Settings.

2. Double click on LAN Connection.

10. Please follow the instructions displayed on the 
screen. The update process will take approx. 5 
minutes. The NDL 485 will restart automatically 
after the update is completed. Regular flashing of 
the BUSY LED at the data logger indicates that the 
NDL 485 is up again. 

IMPORTANT NOTE: 
The NDL 485 must never be disconnected from the power 
supply during update process! Interruption of the update 
process can block the operation of the NDL 485.

Please restart the web browser and login to the 
NDL 485.

In order to check whether the update was successfull 
please select Help > About. Check whether the indicated 
firmware version corresponds to the update you went to 
apply.
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3. Select Internet Protocol (TCP/IP) from the list and 
click on Properties.

4. Activate Use the following IP Address. Enter the IP 
address, subnet mask and gateway according to the 
settings in the NDL 485. The NDL 485 has two IP 
addresses: one is the fixed IP adress 192.168.111.1. 
This IP address cannot be changed. The second IP 
address can be changed by the user. Please refer to 
the label on the data logger for its default settings.
The last entry of the IP address must be different 
from the setting of the data logger. All other settings 
must be set identical to the data logger.

 Example:
Data logger:  192.168.0.31 
PC:     192.168.0.104 

5. Click Ok to accept the settings.

EXTENDED FUNCTIONALIT Y 

(RESEARCH MODEL)

The following chapters describe the extended function-
ality provided by the data logger blueberry NDL 485 
research. Please refer also to the part Technical Data 
for differences between the models basic (partNo. 0102) 
and research (partNo. 0103).

The main features of the blueberry NDL 485 research 
are:

• Higher sampling rate (10 Hz)

• Median function for statistics

• Larger data memory (128 MB standard, expandable  
to up to 1 GB)

• Generation of realtime diagrams

• Automatical data transfer via FTP

Displaying Diagrams
The NDL 485 research generates time series plots of ac-
tual measured values and displays them as diagrams. The 
user defines which measurement channels are plottet 
and in which order the diagrams are displayed. The texts 
for title and y label of the diagram axes are taken from 
the name of the measurement function: the first part of 
the function name is used as diagram title, the second 
part is used as y axis label. First and second part must be 
separated by a space character. We recommend to write 
function names as Value (unit).

Example: 
relFeuchte (%rF) = 100 * a4

The diagram titel for this function is relFeuchte, the y 
axis label is (%rF).

Select Diagrams to display the diagrams.

To define the diagram options select Setup > Diagrams.

Enter the index of the channels to be plottet. The index 
corresponds to the line number in the table of measured 
values. Separate more than one entry by space charac-
ters. Click OK to save the settings.
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Shorttime Diagrams

Shorttime diagrams display a time series of the samples. 
Please enter the width of the diagrams in pixels or enter 
disabled if you do not want to display shortime diagrams.

Statistics Diagrams

Statistics diagrams display a time series of the statistics. 
Please enter the width of the diagrams in pixels or enter 
disabled if you do not want to display statistics diagrams.

Please enter the length of the time axis of the statistics 
diagrams in the field Time Range.

Diagrams are displayed in alphabetical order. Please add 
the appropriate number of 0 characters in order to deter-
mine the display order.

Example: 
entered items:  1  5  20  12 
=> display order:  1  12  20  5

Example: 
entered items:  001  005  020  12 
=> display order:  1  5  20  12

Realtime Data Diagrams

Shorttime and Statistics Diagrams

Setup for Realtime Data Diagrams
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Transmitting Measured 
Data via FTP
The NDL 485 (only partNo. 0103) sends measured data 
automatically via FTP to a website or to a data file server. 
Please first setup the Internet integration via DSL or 
GPRS. 

Select Setup > FTP/Mail. 

Enter the URL of your FTP server in the field FTP Server. 
Enter the destination folder and access code and click OK 
to save the settings.

Setup: FTP Data Transmission (only partNo. 0103)
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Technical Specifications

Model NDL 485 basic NDL 485 research
PartNo. 0102 0103

Measuring Inputs
Digital inputs 6 6

Analogue inputs 6 6

Additional inputs via INPUT modules
(8 x AIN/DIN per module)

Serial inputs RS485, half-duplex, optional RS232

Digital Measuring Inputs (DIN1 .. DIN6)
Measuring range frequency 0 .. 2,000 Hz

counter 0 .. 2,000 Hz
status HI / LO

Resolution 0.01 Hz

Accuracy frequency ± 0.1%
counter ± 1 pulse

Signal level HI = >2.5 V
LO = <0.7 V

or potential free switch closure

Input impedance >20 kΩ

Analogue Measuring Inputs (AIN1 .. AIN6)
Measuring range 0 .. 10 V

Resolution 16 Bit (0.2 mV)

Accuracy ± 0.1% of reading ± 1 mV

Input impedance >1 MΩ

Measuring Functions NDL 485 basic NDL 485 research

Measuring interval 1 s .. 24 h 0.1 s .. 24 h

Statistic interval 1 s .. 24 h 0.1 s .. 24 h

Statistic funcions mean value 
(arithmetic + vector),

standard deviation
(arithmetic + vector),

minimum, maximum, sum

mean value 
(arithmetic + vector),

standard deviation
(arithmetic + vector),

minimum, maximum, sum, median

Data memory for 
statistic time series

32 MB
non-volatile ring buffer

128 MB, expandable to up to 1 GB,
non-volatile ring buffer

Data memory for 
samples

32 MB
non-volatile ring buffer

ANNEX
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Communication NDL 485 basic NDL 485 research

Data interface RS232 interface,
1,200 .. 115,200 baud,

RS485 interface, half-duplex, 
1,200 .. 115,200 baud,

Ethernet interface (LAN), 10 MBit/s,
optional MODBUS-TCP protocol

Remote data transfer GSM, GPRS, DSL, ISDN router

Automatical data 
transmission

via eMail via eMail and FTP

Internet integration via GPRS or DSL

User interface web interface, Internet browser

Graphical data 
display

- realtime diagrams of measured values, 
optional custom specific graphical display

Display -

Power Supply
External 
power supply

5 .. 24 VDC

Internal 
power supply

-

Power consumption typ. 600 mW (50 mA @ 12 V)

Sensor excitation EXC 5..24 VDC switched, max. 500 mA

Switching outputs
DOUT1 .. DOUT4

4 switching outputs, max. 300 mA,
HI = supply voltage, LO = 0 V, 

time or event triggered

Mechanic and Operation Conditions
Casing 65 x 105 x 127 mm, IP20

top-hat rail housing, anodized aluminium

Connections screw terminals, connectors

Temperature range –40..+70 °C
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CE Compliancy Declaration
Based on test report no. EMV-08/8117-1 of 22.07.2008

Manufacturer:  Wilmers Messtechnik GmbH
Hammer Steindamm 35
D-22089 Hamburg / Germany

Product:    Data logger blueberry NDL 485

Part numbers:   0102 (basic)
0103 (research)

Applied standards: 
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C

calibration  13
Casing  38
CC1  21
CC2  21
Character Delay  19
column headers  10
comma separated ASCII files  10
compact  26
Comparison  15, 16
comparison  15, 16
Connections  38
constant current supply  21
coordinate system  13
cos  15
Cosine function  15
counted pulses  18
counter  20
crosspatch cable  6, 22
crosspatch Ethernet cable  5
CSV data file  12
CSV file  10

D

damped value  17
data format  10, 21
data memories  10
Data memory  37
Date  22
DAY  19
DAYTIME  18
decimal  21
Decimal delimiter  10
delete measured data  29
Deleting Measured Data  31
diagrams  34
diagram titel  15
dial-in  27
dial-in connection  23
digital (poll command)  20
digital measurement inputs  20
digital outputs  21
DIN1  20
disconnect  29
division  15
Documentation  12
documentation  12
DOUT1 .. DOUT4  21
download of measured data  10, 35
DSL  12
Dynamic DNS  23
Dynamic DNS Service  24
dynamic IP address  23, 24

Index

Symbols

!=  16
! (NOT operator)  16
#AA\r (poll command)  20
# (last value operator)  17
% (modulo operator)  15
( )  17
<  15
<=  16
==  16
>  15
>=  16
^  15
0102  (NDL485 version)  37
0103  (NDL485 version)  37
10.1.1.1 (IP address)  29
192.168.111.1 (fixed IP address)  34

A

abs  17
Accuracy  37
actual measured values  8
addition  15
address  20
admin  29
AIN1  20
alignment  13
analogue measurement inputs  20
analog (poll command)  20
AND (operator)  16, 21
APN (GPRS Access Point Name)  23

B

Barometric pressure  21
basic (NDL485 version)  37
Baudrate  19
baud rate  19
blueberry GSM Module  27
blueberry INPUT Module  5, 20
Boolean Operators  15
boolean operators  15, 21
browse  27
browser  29
BUSY indicator  5
BUSY LED  6, 33
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dyndns.org  23, 24
DynDNS Account  24
DynDNS host  25

E

e-mail  12
e-mail address  12
elevation  12
else  16
Ethernet  22
EXC  5, 14, 20
Excitation  14
excitation voltage  14
EXC indicator  5
Exponent  15
exponent  15

F

FileZilla  31
Filtering of Invalid Samples  16
firmware update  32
firmware version  30, 33
fixed IP adress  34
flashing light  18, 21
floating point numbers  8
frequency  18, 20
FTP/Mail  12
FTP client  31
FTP data transfer  36
FTP Server  36
function name  14

G

gateway  34
geographical coordinate system  13
Geographical Position  12
GPRS  23
GPRS connection  29
GPRS Internet Connection  23
GPRS mode  23
gradient  18
GSM mode  23, 29
GSM Module  23, 27
GSM provider  23
guest  29

H

half-duplex  37
Help  30
Help > About  33

Help > About > Maintenance  32
Help > Manual  30
help function  30
hex  21
hexadecimal values  21
HOUR  19
hysteresis  21

I

if  16
IN1  20
index  32
Input impedance  37
input impedance  37
INPUT Module  5, 18, 19, 20
int  17
integration  18
Internet  22, 23, 26
Internet access  26
Internet integration  12, 36
Internet server  27
IP address  22, 23, 29, 34

L

LAN  22
latitude  12
ln  15
logarithm  15
login  6, 8
login dialog  26
longitude  12

M

M12x1 connector  5
mail addresses  12
Mail Server  12
Maintenance  32
Manual  30
manual  30
Marking of Invalid Samples  16
mast type  13
MDA  26
measurement function  14
measurement functions  19
measurement inputs  20
measurement process  12
measurement site  12
measure period  14
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MINUTE  19
mobile access  26
mobile browser  26
mobile device  26
Mobile Phone  26
mobile phone  26, 27
MODBUS  38
modem  27
modulo division  15
MONTH  19
mounting booms  13
multiplication  15

N

Name of the measurement site  12
nan (not a number)  16, 19
Natural logarithm  15
NDL 485 basic  37
NDL 485 research  37
Network  22
network  22
network settings  33
NOT operator  16

O

obstacles  12
Onboard temperature  21
online manual  30
Opera  27
operamini  27
orography  12
OR (operator)  16

P

Password  24
password  23, 29
PC network (LAN)  22
PC Network Settings  33
PERIOD  18
period  10
pocket PC  26
poll address  20
Poll Command  19
poll command  19
poll pause  19
Power consumption  38
Power Supply  38
power supply  20, 21
PPP  27
pressure sensor  21
previous measurement  18

previous value  17
public APN  23
pulses  18

R

realtime access  23
realtime clock  22
realtime diagrams  14
Rebooting  30
Remote Access  24
Remote Access via Internet  24
remote connection  27, 28
remote data transmission  23
research  (NDL485 version)  37
Resolution  37
Retry  19
ring buffer  37
roughness  12
round  17
Rounding Operators  17
RS232  5
RS485  37
RS485, half-duplex  37
RS485 bus  19
RS485 bus wiring  6

S

SECOND  19
sensors  13
sensor characteristics  14
sensor mounting booms  13
Serial inputs  37
serial number  10
serial numbers  13
Shorttime Diagrams  35
Signal level  37
sin  15
Sine function  15
Site Description  12
sonic anemometers  5, 19
statistical evaluations  14
Statistics Diagrams  35
statistics files  10
statistic interval  14
status HI / LO  37
subnet mask  34
subtraction  15
switching output  16
Switching outputs  38
synchronization  22
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T

TCP/IP  34
Technical Data  32
Temperature range  38
TIME  18
Time  22
timer  21
Time Info  18
time series plots  34
time server  22
time zone  22

U

Update  32
Updating the Firmware  32
Username  24
user admin  29
user guest  29
User Password  29
UTC  22

V

valid  16
Validity Check  16
validity check  16
variables  14, 18
vector  15
virtual channels  19
Voltage  20

W

web interface  8, 26, 29
web server  23
WEEKDAY  19
wind speed vector  15
wiring of RS485 bus  6

Y

YEAR  19
YEARDAY  19
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