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BASIC FUNCTIONALITY
(ALL MODELS)

The following chapters describe the basic functional-
ity provided by all models of the data logger blueberry
NDL 485. The research model offers additional function,
like creation of realtime diagrams and FTP data trans-
fer. These extented functionality is described in part
EXTENDED FUNCTIONALITY.

Introduction

The blueberry NDL 485 is a modular data logger and
control system. It features digital and analogue meas-
urement inputs for the connection of sensors providing
pulses, voltage or current signals. A serial RS485 bus
interface allows the connection of sonic anemometers
and the extension of the measurement system with
blueberry INPUT Modules. The digital outputs control
external devices and they trigger alarms. The blueberry
NDL 485 isintegrated into the Internet via GSM/GPRS or
DSL. It sends measured data automatically via E-Mail and
FTP. The Ethernet port and the integrated web interface
provide fast data transmission to a PC or a LAN and easy
access via a web browser.

POWER + GND
power supply connection
POWER = (+), GND = (-)

=

EXC

switched sensor excitation
voltage

(also available at RS485
connector)

DIN1 .. DIN6
digital measurementinputs

AIN1 .. AIN6
analogue measurementinputs

DOUT1.. DOUT4
switching outputs

s000300c0cecesosnse|

Getting Started

Scope of Delivery

The following components are supplied with the data
logger blueberry NDL 485:

* Data loggerin an aluminium top-hat rail housing
* RS485 data cable with 5 pin M12x1 connector
» Crosspatch Ethernet cable for local data connection

e Manual

EXCindicator
indication of
sensor excitation
voltage

A R ..

e NI 485

@| BUSY indicator
———— flashes every 2 seconds in
normal operation

RS232

serial port for connection
to a modem or to the
blueberry GSM module

LAN

Ethernet port for connec-
tiontoa PC, arouterora
PC network

RS48

RS485 port + excitation
pin 1=n.c.

pin 2 =EXC (+)

pin 3=GND

pin 4 =RS485+

pin 5=RS485-

Swilmers
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Power Supply
12VDC
GND

POW
GND
EXC
DIN1
DIN2
DIN3
DIN4
DIN5
DIN6
AIN1
AIN2
AIN3
AIN4
AIN5
AIN6
DOUT1
DOUT2
DOUT3

DOUT4
(G

NDL485

c e
EXC BUSY

RS232

LAN .

Barometric Pressure Sensor
RMY 61204V

PWR

2D Sonic Anemometer
RMY 85000

|A1 |B1 |A2|B2|TX|RX|SDI|

[+ |- [ec|  [va]ve[pee

RS485+

2 1
RS485 @
3]2

/

RS485-

Example: wiring of RS485 bus

Installation

Please proceed as follows to install and to test the

NDL 485 data logger:

1. Installthe NDL 485 on a top-hat rail.

6. You should now see a screen similar to the image be-

low.

A wilmers Messtechnik - Netwarkied Data Lagger NDLABS - Microsoft lmernat Expl... [2][8]f%]

. Connect a power source of 5..24 VDC to the POWER
and GND terminals of the terminal strip. The BUSY
indicator LED starts flickering or is steadily alight.
The boot process takes approx. 2 minutes. The data
logger is fully operating when the BUSY LED flashes
in regularintervals of 2 seconds.

. Plug the crosspatch cable into the LAN connec-
tion at the front plate of the NDL 485. Connect the
crosspatch cable to the Ethernet interface of a PC or
notebook.

. Adapt the network settings of the PC to the IP ad-
dress and the gateway of the NDL 485. The network
parameters are indicated on a label at the bottom of
the housing of the data logger.

. Start your Internet browser, enter the IP address
of the data logger into the address field and type
<enter>. Enter the access code into the login dialog:

admin

*kkk

user:

password: (=admin password)

Daks Bmawheben desihi Feuwbe Ednas 7 ir

Quos- O 4 [ & J

o | ) Wi 1e8.0. 5

Suchen

Setup

Q00007 2006-06-02 stat cow
06-02 stat c5v 1EB
006 D602 _stat cov 1KBE

Archive HighRes
02,06,2006

Date: 34606

Q0005 D

Digital
Inputs
Digital
Outpuls
wvidna {m/s)
va0b (m/s)
Wil (/s
W30 (mfs)
vl (m/s)
Dir7 8 (%)
DirZ8e)
Temp?d (°C)
Templs (“C)
rHumis %
RH)

pharo (hira)
uSupply (V)
ucc1 (V)
uCCZ2 (V)

18 2s(3s4

1e{20(38l4s

1.390333
1.09065
1.30403
0.87633
06016
203,842
210,571
20,85
20,48

46.1
1026.55
13,6624

3.029
3,024

Indest genezated Fr Jun 2 144333 2006

B et

Bres [esnassises]

Web Interface of the NDL 485

Connect sensors or test signals to the terminals at
DIN1 .. DIN6 and AIN1 .. AIN6. Enter the measure-
ment functions according to chapter Measurement
Setup of this manual.
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We recommend to install the NDL 485 in a shelter box (20 measurement inputs in total) and the GSM module
with overvoltage protection modules for all terminals. that integrates the data logger into the Internet via
The following image shows a typical measurement sys- GPRS. A solar power supply and a set of overvoltage pro-
tem with the NDL 485 data logger, one INPUT module tection modules complete the system.

0903-84-0P48
wind Med
sensor Co
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Shelter Box 0903-44-0P485 with overvoltage protection, solar power supply, data logger, blueberry INPUT module and blueberry GSM module
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Web Interface

Introduction

The user surface of the data logger blueberry NDL 485
is a web interface. Configuration of the data logger,
display and download of measured data requires a web
browser (e.g., Internet Explorer, Opera, Mozilla). The
data loggeris connected to the PC locally via Ethernet or
via remote data transmission (DSL, GSM, GPRS).

Start the browser, enter the IP address of the data logger
into the address field and type <enter>. Enter the access
code into the login dialog. The NDL 485 provides two
user levels:

The user guest is allowed to display actual measured
values and configuration settings and to download
measured data. He cannot delete any data or change
configuration settings. He is only allowed to set date
and time.

The user admin has all rights. In addition to the guest
rights he is allowed to delete measured data and to
change the configuration.

Yerbindung zu 10.1.1.1 herstellen E|g|
= "
i

MDL485-2681029345

Benutzername; ﬁ quest bt
—_ 4]

Kenrmwart: | snone|

[ kenmwort speichern

[ K ] [ Abbrechen

Login Dialogue

Data Display

Displaying Actual Measured Values

The left part of the screen displays in a table all actual
measured values. When the data logger is connected lo-
cally these values are automatically updated. At remote
connections, please click on Refresh Data View below
the data table in order to update the display. Measured
values are displayed as floating point numbers with
the significant number of characters after the decimal
point.

Tdwilmers Messtechnik - Networked Data

Datei  Bearbeiten  Ansicht  Lesezeichen  Extras
= 2 | [ htepeglg
Diagrams i

Date: 02.06.2006 13:15:48
Digital Inputs (1524|3040
Digital Gutputs |1@|20 (36 |1e
Temp (°C) 20.56
rHumidity (20RH) 43,13
pBaro (hPa) 1026.13
vSonic (m/s) 4. 76698
dirsonic (¢) 117.227
vSupply (V) 12.0855
Freql {Hz) 0
densityAir (kg/

m3) 1.21709

Realtime Display of Actual Measured Values
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Data Transfer

Downloading Measured Data

The NDL 485 contains two ring buffer data memories;
one for the statistics, one for the samples. Actual data
overwrite the oldest data lines which makes the deletion
of the memory unnecessary.

Select Archive in order to display a list of all stored
statistics files. The NDL 485 creates one statistics file
per day. These files contain time series of the statisti-
cal evaluations of the samples. The file name contains
the index of the actual measurement, the date and the
tag stat for ,statistics’. The data logger increments the
index every time the configuration is changed or the
data logger reboots.

Example: 000024_2004-03-19_stat.csv

3 wilmers Messtechnik - Nerworbed Data Logger NDLABS - Microsoft Imerner Expl... [= |[8]f%]
Dats  Sawbelen frsch Favwien Bars 7 ir

G awos - « (& @

] b iy e 5=

Suchen

Setup

OO0 006 6.0
JalEal il

Archive HighRBes
02,06,2006

Date: o e
14:46:06 2006 D602

Drigital
Tnputs
Digital
Qutpurs
wB0a {m/s)
Wil (m/'s)
vl (mys)
V30 (mys)
w10 {my's)
Dir78 (2}
Dir2e+)
Temp78 (°C)
TempOs (50)
rHum0s (Y
RH)

1203040 0000042006

6L
06001

1# 2838 4s

1.39333
109065
1.30403
0.87633
0.8016
203,842
210,571
20,85
200,48

6.1
1026,55
13.6624

3.029
3.024

pBaro ChPa)
uSupphy (V)
ulCl (V)
uCC2 (V)

@ Intsrest

Hrom

Archive: statistics data files

Select HighRes in order to display a list of all stored
samples files. The NDL 485 creates one CSV file per hour.
These files contain time series of all measured samples.
The file name contains the index of the actual measure-
ment, date and time, and the tag meas for ,measure-
ment’.

Example: 000024_2004-03-19_15_meas.csv

Download of measured data works like a download from
an Internet site: click with the right mouse button on a
file, select Save file as... from the pulldown menu, enter
the destination path and click OK.

HighRes Setup
L Archive
A 000153 2005-12-29_stat.csv
3OS onise 20051220 stetcsy
rg7oq 0151 30051239 staicsy
000150 2005-12-29_stat.csv
9285 000149 2005-12-29_stat.csv
000145 _2005-12-29_stat csv
18.74 000148 J005.12.29 =
-9063 000142 300512729 std O TO" ”
n7.74 = s In neuem Fenster &ffnen

000141 _2005-12-29_sta
o 000140 _2005-12-29_sta

Z ichiern unter. ..
Ziel drucken

11.9 000132 3005-12-29_stal
06.41 000138 J005-12-29_sta
000137 2005-12-20 st Verknipfung kopieren
D6.99 000136 _2005-12-29_sta
000134 _2005-12-2%_sta
15.49 Zu Favoriten hinzufigen. ..

000135 2005-12-28 sta

o 000135 3005-12-27 sta  Eigenschaften

0 000134 2005-12-26_stat.csv

Download of Measured Data

CSV files can be imported into data analysis software like
WAsP or WindPRO. Double-clicking on the CSV file opens
it directly in MS-Excel.

Data Format

The NDL 485 stores measured data as comma separated
ASCII files (CSV). Each data file contains a header which
indicates information about the data logger and the
measurement configuration: serial number of the data
logger, index of the measurement, measurement func-
tions and parameter settings. The header is followed
by an empty line and a line with column headers. The
measured data lines have the format: date, time, pe-
riod, measured values. Decimal delimiter is a dot (e.g.,
2.564).

-10-
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E C:\Datenimessdatenind|485-sn20161000009_2007-11-15_stat.csv - PROTON
Datei Bearbeiten Ansicht  Syntaxschema Tools  Shortcuts  Plugins  History 2

Deal@Lt SR s b@ - o e &

2 000009_2007-11-15_stat caw I

1 |# instrument NDL485-3218974759 ~
2 |# measurement 0000039
3 |# pollperiod=1
4 # statperiod=600
5 [# pollexcitate=0
6 [# function="wSonicS51 (w/s)]", {mean, sigmwa,max,min, median} , c2
7 [# function="DirSonic51 (°)", {mean,sigma,mean3 60}, " (c3+20) 3 360"
&G # function="w49 (m/s)",{mean, sigma,wax, min,mediand , "0.04773 * b2 + 0.272 * (bz>x0)"
9 |# function="v30 (m/s)",{mean,sigma,max,min,median},”0.04773 * b4 + 0.268 * (h4>0)"
10 [# function="v10 (m/s)",{mean, sigma,wax, min, mediand , "0.04774 * b6 + 0.254 * (bhe>0)"
11 # function="Dir47 (®)", {mean,sigma,wean3e0}, " (( (358 * (a2-al) / a2) + 20) % 360) — ((((358 * (a2-=al) / a2) + 20) % 360} 3 1]"
12 |# function="Temp50 ([°C)",{mean,max,min},"100 # a4 - 307
13 |# function="TempS (°C)", {mean,max,min},"100 * a5 - 30"
14 # function="pBaro5 (hPaj",wean,did
15 ¥ function="TempShelterbox (°C)",mean,dz0
16 [# function="uSupply (V)",!{mean,max,min},"ad - (a8%0.01)"
17 [# function="DOUTL (Sonic OM/OFF) ", mean, "uSupply > 10.57
18 # function="Dird47Supply (V)", {mean,wmsx,min}, a2
19 |# function="Dir47?8ignal (V) ", {mean,max, min},al
20 |# function="DOUTZ (Modem ON/CFF)",mean,”!((HOUR == 0j % (MINUTE == 45))"
21 [# pollbaudrace=9600
22 |# pollchardelay=20
23 |# pollteledelay=100
24 |# polltimeout=1
25 # pollretry=0
26 § poll=analog
27 # poll=digital
28 # poll=H3',9600
#

poll=g#0lir, 19200

31 |"date”, Ttime”, "period”, "wSonicS1 (m/s)_mesn”, "wSonicSl (m/s]_wedian”, "vSonicSl (m/s)_sigwa’, "vSonicS1 (w/s)_wax", "vSonicS1 (m/s]_min®,
32 (2007-11-15,00:10:00, 600,2.33004,2.4,0.650467,%.6,0.8,350. 696, 14.58823,2.20153,2.17505,0. 618092,3.51452,0.89240, 1. 48491, 1.42736,0.590033
33 [2007-11-15,00:20:00, 600,2.25415,2.3,0.6477689,3.6,0.5,350.242,8.94578,2.17612,2.22082,0.642639,3.99589,0.707775, 1.36549,1.24599,0. 66159
34 (2007-11-15,00:30:00, 600,2.00883,2,0.745324,3.5,0.2,355.042,20.7658, 1.96232, 1.58289,0. 692046, 4.2417,0. 626157, 1.25282, 1. 18919, 0.593721,2
35 [2007-11-15,00:40:00, 600,2.23423,2.4,0.655743,3.6,0.4,18.0246,17.7095,2.02761,1.98646,0.536114,3.38161,0.709664,1.46321,1.366865,0. 56556
36 2007-11-15,00:50:00, 600,3.05668,3,0.672514,5.4,1.3,14.7454,14.4967,2 .85232,2.726866,0.743432,5.08414,1.30822,2.04201, 1. 90418, 0. 657686, 4 +
S | »
17:4 Einfigen  [Smartinder win: C\Daterimessdatenind485-sn2016\000008_2007-11-15_stat.csv

Statistics data file in an ASCII editor

E3 Microsoft Excel - 000D09_2007-11-15_stat.csv

@Qatew Eearbeiten Ansicht Einfligen Format Extras Daten Fenster 7

DS Gy B2 -0 @& A48 E M W0% (3, a6 ~10~ F X
Kz - =
I A [DREa G D I E F
1 |#instrument NDL4BS-321B97 4759
2 [#measurement 000009
3 |[#pollperiod=1
4 |# statperiod=600
5 |#pollexcitate=0
[
7 4
8 4

# function="¥Sonics1 {m/s)" {rmean sigma  max min median} c2

{mean sigma  mean360} (c3+20) % 360
fmean  sigma  max \min median} 0.04773 " b2 +0.272 = (b2=0)
a8 fmean  sigma  max rhin median} 0.04773 " b4 +0.268 * (hd=0)
0 {mean sigma  max min median} 0.04774 * b6 +0.254 * (b6=0)
" Dird? (%" {mean  sigma  mean360} ({358 * (a2-al) / a2) +20) % 360) - ((((355 * (a2-al) / a2) + 200 % 360) % 1)
12 Temps0 (*C)" {rnean max min} 100 * a4 - 30
13 |#function="Temps (*C)" {rmean max min} 100 * a5 - 30
14 |#function="pBaro5 (hPa)" mean d19
15 i TempShelterbox (°C)" mean d20
16 uSupply V)" fmean  max min} |aB - (a8%0.01)
17 | DOUTT (Sanic ON/OFF)" mean uSupply > 10.5
18 Dird7 Supply ()" {rnean rrax rmin} a2
19 Dird7 Signal V)" {rnean rnax rmin} al

_QD [#function="DOUT2 (Modem ON/OFF)" mean  I{(HOUR == 0) * {MINUTE == 45))
21 |# pollbaudrate=2600

| 22 |# polichardelay=20

23 [# politeledelay=100

24 |# polltimeout=1

25 # pollretry=0

26 #polFanalog

27 #poli=digital

28 # pall=MS! 9600

29 # poll=#014r 18200,

30

31 |date time period  vSonich1 (mfs)_mean vSonicS1 (mfs) median  ¥Sonich1 {r/s)_sigma wSonic51 (m/s)_max  ¥Sonich1 {mfs)_min Di
32 15.11.2007 | 00:10:00 500 2,33094 24 0 650467 36 03
33 15.11.2007 | 00:20:00 500 225415 23 0647783 36 05
34 15.11.2007 | 00:30:00 500 200833 2 0745324 35 02
35 15.11.2007 | 00:40:00 500 223423 24 0655743 36 04
B 1 16.11.2007_00:50:00 EO0 3.05668 3 0EB7.

W 4[» [ v 000009_2007-11-15_stat / [«

Bereit

Statistics data file in MS Excel

-11-
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Transmitting Measured Data
via E-Mail

The NDL 485 sends measured data automatically via
e-mail every day at 0:00. The CSV data file of the previ-
ous day is attached to the e-mail. If several files have
been created since last e-mailing (e.g., because of con-
figuration changes or rebooting of the data logger) all
closed files are send. Each file is attached to a separate
e-mail. Please first setup the Internet integration via
GPRS or DSL.

To setup the e-mail data transfer select

Setup > FTP/Mail.
d Data Logger NDL485 - Windows Internet Explorer D@|@
- lfRed) 2 P~
wiotked Data Logger.... | | B8 o - [ Seite v {GF Extras ~ &
HighRes Setup Help

Mail Transfer
Mail Server |smtp.com

From: green\and3@daler_1!ugge| net

Username
Password |
gy Recipient(s) measdata@wilmers cc;mwd@gm':(net
g
4
Test this configuration?
.6 Test Mail transfer now[yes v
]

(List mail recipients here, separated by spaces.)

Testing configuration ... please wait
Sending a test mail to measdata@wilmers.com wd@gmy.net ...

[ &P Intermet H100% -

Setup: E-Mail Data Transmission

Enter the URL of your mail server (SMTP server) in the
field Mail Server. If your mail server requires authoriza-
tion enter the user name and password. Enter the mail
addresses in the field Recipient(s). Separate more than
one mail address by space characters.

Select yes at Test Mail Transfer now.

Click OK to save the settings. If the Test Mail option is
active the NDL485 now sends a test mail to all recipi-
ents. A message displays the result of the test mailing.
Please check whether the mail has been sent without
errors. Otherwise, please check the correctness of your
settings.

Site Description
(Documentation)

The NDL 485 saves information about the measurement.
They are stored in the header of each CSV data file for
proper documentation of the measurement process.

To enter the information about the measurement select
Setup > Site Description.

Wilmers Messtechnik - Networked Data Logger NDL485 =) 3 [x)
Lesezeichen Fenster 7
168.0.31/ Q- Google
HighRes Setup Help
Site Setup

The information given in this setup is included in the archived measurement files.

In the running measurement, this information is first updated when a new file is written (typically at
midnight). You can start a new measurement to include the updated site information immediately.

Description

Name Creenland 3

Description Smooth hill, low trees in the SW sector

Geographical Position
Latitude |72°00'55.06"

[(North v
[West [=]

Longitude 60°47'12.54"

Elevation |275 m as.|

Other Information

Tag Text
MastType Lattice mast, Leutner 100m
VaneOrientation north = 235 deg
Sonic1003dm R.M.Young B5004, sn24542, cal08_67452
Cup998dm THIES 4.3350.10.000, sn1408352, cal08_67455
Cup800dm THIES 4.3350.10.000, sn1408361, cal08_67458
add new:

Setup > Site Description (Documentation of the Measurement)

Documentation of the measurement includes the follow-
ing information:

Name Name of the measurement site

Description Description of the measurement loca-
tion and its environment. Please enter
here orography, roughness, obstacles
and other elements having an impact
on the measurement result.

Geographical Position Enter here latitude, longitude
and elevation of the measurement
site.

-12 -
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Other Information Use these universalinput fields
to enter all supplementary informa-
tion about the measurement:
e.gd., geographical coordinate system,
mast type, mast dimensions, type, se-
rial numbers and calibration numbers
of the sensors, dimensions and align-
ment of sensor mounting booms

-13-
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Measurement Setup

Setting Measurement Parameters

To define measurement parameters or sensor character-
istics select Setup > Measurement:

Measure Period Measure period is the timeintervalin
which the data logger records actual
measured values (samples) from all
sensors.

Statisic Interval Statisticintervalis the time interval
in which the data logger performs a
statistical evaluation of the samples
and stores the results in the memory.
The variables a1..an correspond to
the first to nth value of the data line
sent by the first sensor. The variables
b1..bn correspond to the values sent
by the second sensor and so further.

Selecting always on switches the ex-

citation voltage continuously on. The
blueberry INPUT Module requires this
setting as it needs a warm-up time of
approx. 5 seconds.

Setting Measurement Functions

To add a new measurement function enter a function
name in the field Name, check the required statistical
evaluations and enter the measurement function. Type
<enter> to transmit the settings to the data logger.

Function Names

Variable names may principally contain umlauts (&, 6,
ii) and special characters like comma (,) and period (.).
If function names are used as variables in further meas-
urement functions the first part of the function name
may however only contain the following characters:
A..Z, a..z, 0..9, _. The second part, i.e. the part after the
first space character is used as axis label for realtime
diagrams. We recommend to use the following syntax for
function names: Value (unit).

{TornpiHmrdib 1) % &
(b1/b2*100) % 360

1.225* pDarn/ 101225 * 200.15/(Tam

1005 ~wSoinme:

(dirSonic - [dirSonic % 100) % 360

(seckeas/10) %

Excitation defines how long the sensor excitation
voltage (EXC) is switched on before
the NDL 485 sends a poll command.
_02.06.2006
Date: 50725 Timing
iaital Meagure Penod 13 s
E;%ﬁ?s la243eide Statistic Tnterval 1m0
Digital ] Excitation alweys on w
Oulpuls 1#(2e|3e |49
Temp (°C) 20,47 Function dehnitions
rHumidily {%a 47.79 Name e an FgmA mac mm fum median (vecter) Formula
RH) p—— BO0® 0O |oocwm-a
pBaro (hPa) 1026.18 " o ) X i ez
vSonic (m/s) |4.78383 Humidity (55FH) | [« [« 2] ] [ I« 1 n?
dirSonic (°) |117.948|  pBam (e B @ EO0® 0O
v3upply (V) 12,0942 vSonc i) EOH O
;:‘;\‘illw(::) O [arsonic) W B O0Oo0n @
(ka,/m3) 121732 [supply 04 @ BO08 O
speed (m/s) (95.6766)  Freql (M) P OFM R EOE [ [
sechMeas 110 densiviirbginsd) | O O OO O ]
secstat 11 _ _
s {mfs) O oooo O
secheas [« 1 [ C1o el =]
secHiat B O OOO0OO =B
add new
OO0 Ooooao m]
RLE48E Serup
Default Baudrate [19200 ~
Chimriscter Deday | no detsy v
Poll Delay no delay ¥
Tireout 01z %
Eetry off »
Toll Coromnands
Comanimd Baudrate  Data Format

Yol Command |courier
Fall Commumd [analog
Poll Command [#01y
Poll Command Mal

default

difault

default

9a00

3

w

=

w

decimal
drcamal
decimal

decmal

e

Setup > Measurement: Measurement Parameters and Measurement Functions
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Example:
viWind80om (m/s) = 0.04727 * b10 + 0.264 * (b10>0)

The first part of the function name can be used as
variable viWind80m in further measurement functions.
The diagram title for this function is vWind80om, the y
axis labelis (m/s).

Maximum length of the measurement function including
function name and statistics options is 1023 characters
or 64 elements. Each variable or operator counts as one
element. Please use the following elements to built the
measurement function:

Arithmetic Operators

+ Addition

Subtraction or minus sign. If a - is used to char-
acterize a negative number at the beginning of a
measurement function or after another operator
the number must be put into parenthesis.

Example: Negative Numbers
HumAir (%RF) = (-25) + 62.5 * a5
vSonic (m/s) =e2 else (-9999)

Multiplication
Division
Exponent, real number

Example: Length of a Vector

uSonic (m/s)=d2

vSonic (m/s)=d3

wsHorizontal (m/s)=(uSonic”2 + vSonic"2)"0.5

This function converts the u and v components
of a sonic anemometer to horizontal wind speed.

Modulo division. This operator provides the
positive residue of a division. Unlike the general
modulo operator defined for integer numbers,
the NDL 485 modulo operator is based on real
(floating point) numbers for parameters and for
the result. The second parameter of the % func-
tion must be positive (a % b with b>0).

%

Example: Wind Direction
winddirection (°) = (360 * b1 / bo + 268) % 360

The measured wind direction value with an off-
set correction of 268 degrees is projected into
the range of 0..360°.

sin

cos

ln

Sine function. The angle must be defined in de-
grees.

Example: Vector Component

vWind (m/s) =0.04752 * b8 +0.224 * (b8>0)
dirWind (°) = (360 * (a1-a2)/a1) % 360
vEast (m/s) =vWind * sin (dirWind)

The multiplication of the wind speed with the
sine of the wind direction results in the eastern
component of the total wind speed vector.

Cosine function. The angle must be defined in
degrees.

Example: Vector Component

viWind (m/s) =0.04752 * b8 +0.224 * (b8>0)
dirWind (°) = (360 * (a1-a2)/a1) % 360

vNorth (m/s) = vWind * cos (dirWind)

The multiplication of the wind speed with the

sine of the wind direction results in the north-
ern component of the total wind speed vector.

Natural logarithm

Example: log=Inc7

Boolean Operators

Comparison superior to. The result is 1, if the
condition is true, otherwise itis 0.

>

Example: Calibrated Cup Anemometer
ws30m (m/s)=0.04827 * c2 +0.19 * (c2 > 0)

This function suppresses the wind speed offset
when the frequency is 0. Otherwise, even at to-
tal calm the data logger would indicate a wind
speed of 0.19 m/s.

Comparison inferior to. The result is 1, if the con-
dition is true, otherwise it is 0.

Example: Status from Threshold Value
Temperature (Celsius) = 20 * a4 - 40
Frost = Temperature <0

The comparison with a threshold value creates
the status signal 1 = frost / 0 = no frost.
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Comparison equal. The resultis 1, if the condition
is true, otherwise itis 0.

Example:
identic= (0.2 *a2) == 1.2

This function compares a measured value with a
constant.

Comparison not equal. The result is 1, if the con-
dition is true, otherwise it is 0.

Example:
differentStatus (1=different) = c1 !=c2
with third poll command: DIN

This function compares the status of digital
inputs DIN1 and DIN2.

Comparison superior or equal. The result is 1, if
the condition is true, otherwise itis 0.

Example:
condensation = Humidity >= 100.1

Relative humidity of more than 100 %RH is con-
sidered as condensation.

Comparison inferior or equal. The result is 1, if
the condition is true, otherwise it is 0.

Example:
DOUT1 (Heating) = Temperature <= 10.5

A heating is switched on through switching out-
put DOUT1 at temperatures of or below 10.5 °C.

NOT operator. This operator inverts the logical
level of a boolean value.

Example:
DOUT2=!a1
with first poll command: DIN

Switching output DOUT2 is set active if the sta-
tus signal at digital input DIN1 is low.

valid This operator checks whether a value is a valid

number. The result is 0, if the value is nan, other-
wiseitis 1.

Examples: Validity Check
checkValue (1=0k) =valid (2.45 * a1)
error (1=invalid) ~ =!valid (2.45 * a1)

if

else

This operator checks whether a value is not 0 or
nan. The if operator is typically combined with
the else operator.

Example: Output Limitation
Hum (%RH) = 100*a4 if (100*a4<=100) else 100

In case of condensation, some thermo hy-
gro sensors show measured values above
100 %RH. This function limits the output of
relative humidity to 100 %RH.

Example: Validity Check
vCup (m/s) =0.253 *b8+0.22 * (b8>0)
vWalid (m/s) =vCup if ((vCup>=0)*(vCup<90))

This function defines a range of 0 to 90 m/s for
valid wind speed values. The result of vValid is
vCup if vCup is within this range, otherwise it is
nan.

replaces a value if the value is nan.

Example: Filtering of invalid Samples
uSonic (m/s) = d2 else #uSonic else 0

If the sonic anemometer returns an invalid val-
ue, the data logger will keep the previous value.
If the previous value is also invalid the result is
setto 0.

Example: Marking of invalid Samples
relHum (%RH) = 100*a2 else (-9999)

Invalid samples (nan) are stored as -9999.

Combining boolean Results:

The multiplication operator * corresponds to the logical
AND operator. The addition operator + corresponds to
the non exclusive OR operator.

Example: AND, non exclusive and exclusive OR

AND

OR

XOR

= (a2>=0) * (a2<=100)
= (a2<0) + (a5<0)
= ((a2<0) + (a5<0)) ==
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Rounding Operators

abs  provides the unsigned floating point value of a
signed value.

Example:
alwaysPositive = abs (125 * g7 -75)

int  removes the decimal part of the floating point
value.

Example:
intValue = int (-2.45 * d2 + 100)

round rounds the floating point value to the nearest
integer (up or down).

Example: Display without Decimals
LowResDir (deg) = round((360 * a2/a1) % 360)

This function displays the wind direction with-
out decimals.

Example: Fixed Number of Decimals
Radiation = 0.01 * round (100 * (2.645*a2-25))

The floating point function result is reduced to
2 decimals.

Other Operators

()  Parantheses structure the function elements and
determine the calculation sequence.

# provides the previous value of the measurement
function.

Example: Cumulative Rainfall
actualRain (mm) = 0.1 * b3
cumulRain (mm) =
(#cumulRain+ (actualRain else0))
else actualRain else 0

These two functions record actual and cumula-
tive rainfall. cumulRain adds the actual rainfall
to the previous cumulative rainfall. When the
measurement starts #cumulRain is invalid
because no previous value exists. The result is
then replaced by actualRain. If this value is also
invalid the result is set to 0. The else operator
defines the starting value and prevents the
cumulative value from being reset in case of an
invalid value of actualRain.

actualRain
8.1 T T T

B.ag
.86
@.a4

a.e2

@ L i L n
§9:50 §9:55 18h 18:85 1@:1@

cumulRain

cmm?
EEEn e

oA N R 3 Y

89: 58 B9:55 18h 1@8: @5 1@:1@

Actual and cumulative rainfall

Example: Low Pass Filter
noisy =625 *a6 - 55
damped = (0.1 * noisy + 0.9 * #damped) else noisy

This function implements a low pass filter that
smooths a noisy value. damped provides a
damped value of the actual measurement value
provided by noisy.

as:58 ag: 55 agh ag:as

damped
8.3 r -

I 1
Bg:5a @g: 55 B%h 89: 85

Low pass filtering of noisy data
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Operator Summary

The following table lists examples of results based on
the operators with different parameters.

Results for:a =...

-2.7183 0 +2.7183 nan
aelseb -2.7183 0 2.7183 b
bifa b nan b nan
bifaelsec b c b c
valid a 1 1 1 0
'a 0 1 0 0
a>o0 0 0 1 nan
a<o 1 0 0 nan
a==0 0 1 0 nan
al=o0 1 0 1 nan
a>=0 0 1 1 nan
a<=0 1 1 0 nan
a%1 0.2817 0 0.7183 nan
a % 0.01 0.0017 0 0.0083 nan
a-(a%o0.01) -2.72 0 2.71 nan
absa 2.7183 0 2.7183 nan
inta -2 0 2 nan
round a -3 0 3 nan
lna nan nan 1.0000 nan

Variables
Variables  Thevariables al..an correspond to the
first to nth value inside the data line sent
by the first sensor. The blueberry INPUT
module supplies the voltages of all inputs
in Volt as well as the frequency in Hertz
and the counted pulses. In addition to
the variables, other function names can
be used inside a measurement function.
They must be defined former to the func-
tion in which they are used as a variable.
A # characterin front of a function name
provides the measurement value of the
previous measurement.

Example: Temperature Gradient
Temp (°C) =100 *a3-30
deltaTemp (°C) = (Temp - #Temp) else 0

deltaTemp provides the temperature
gradient.

Function definitions

Name frgan sigma max min sum medan (vector) Formula
il ) H = M 80O O O T4 b v 0243 I
Vb imit) (I
Vil fms] 007 "bh
v mty)

ELOSTR b+ 0288 b )
DUATTA " B10 + 0227 * B0

V10 [t

ackd new;

READS Setup

Defaudt Baudrate %0~
Character Delay | m dday >
Foll Delay 100 e
Teneout 051 1w
Retry ol v

Poll Commands
Command Baudrate Data For

e al..a8
Poll Cammand ssbsa et B[ B

Poll Cormmand Hoid sk v bemd o~ — D1 .. b12 —
Foll Command Al ceimi | el = \Cl

add new:
Foll Command delmi | decanl

CEF 1 s

Setup > Measurement: measurement functions and variables

Predefined Variables (Time Info)

The following predefined variables provide time infor-
mation.
PERIOD provides the actual measurement period
in seconds.

Example: Integration over Time
flow (m3/s) =125 *b2
volume (m3) = flow * PERIOD

The function volume uses PERIOD to
convert actual flow into a volume.

TIME provides the time in seconds since

1.1.1970 00:00:00.

DAYTIME provides the time in

seconds since 00:00:00 of the current day.

Example: Flashing Light
DOUT3 (flash) = ! (DAYTIME % 10)

This function flashes a signal lamp every
10 seconds.
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YEAR provides the actual calendar year as 4

digitinteger (e.g., 2007).
MONTH provides the actual calendar month as
integer (January=1.. December = 12).

Example: Season dependent Factors
factor=0.26*(MONTH<4) +
0.22*(MONTH==4) + 0.25*(MONTH>4)

This function selects a factor depend-
ing on the month. Some algorithms for
determination of potential evaporation
(e.g., HAUDE) use empirical factors that
vary with the season of the year.

DAY provides the actual calender day as
integer (1.. 31).

HOUR provides the actual hour as integer

(0..23).

MINUTE provides the actual minute as integer

(0..59).

SECOND provides the actual second as integer

(0..59).

WEEKDAY  provides the day of the week as integer

(Monday =1 .. Sunday =7).

YEARDAY provides the day of the year as integer

(1stJanuary=1).

Click OK to save the settings into the data logger. As the
measurement functions represent virtual channels they
areindependent of the number of hardware inputs of the
data logging system. The user can define an unlimited
number of measurement functions.

Setting up Data Polling

The NDL 485 sends poll commands through the RS 485
serial port and to the internal measurement interfaces.
Each poll command provides a set of return values that
are used as variables in the measurement functions.
Please set the poll parameters as follows:

Select from the Baudrate list the baud
rate of the serial port. The blueberry
INPUT Module requires a baud rate of
19200.

Baudrate

Character Delay Select from the Character Delay list
the delay between the characters

sent by the NDL 485 to the serial

port. Some sensors (e.g., R.M.Young
sonic anemometers) require character
delays. The blueberry INPUT Module is
polled with a character delay of 0.

RS5485 Setup
Default Baudrate [19200 =

Character Delay |nodelay >

Pall Delay
Timeout
Retry

s3]
s =
[o=]

Poll Commands

Poll Command [analog
Pall Command [counter
Poll Command o1y

add new:

Poll Command |

Baudrate Data Format

|defaull j Ideclmal _'_I

[default =] [decimal

&
|defaull j |de:|ma| LI
H

Command

|dafaull j Ideclmal

OK| Reset

Setup > Measurement: RS485 Data Polling

Poll Pause

Timeout

Poll Command

defines the delay between the last
character of a data line received by the
NDL 485 and the sending of the next
poll command. The blueberry INPUT
Module requires a poll pause of 50 ms.
The poll pause is required because the
RS 485 bus allows only one component
(sensor, INPUT Module or data logger)
atatime to transmit data. All other
components work in receiver mode.
The poll pause allows to switch from
transmitter to receiver mode.

defines the maximum time the

NDL 485 waits for the answer to a poll
command. If the polled component
does not answer the poll command
will be repeated once or several times
depending on the value set for Retry.
If no data was received the meas-
ured values are stored as nan (,nota
number®).

Enter the poll command into the field
Poll Command and click OK to save the
setting into the data logger.
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The following poll commands provide measured values
from the NDL 485 data logger itself:

Command: digital

Results:

Index Value Unit
1 Counter of DIN1 -
2 Frequency of DIN1 Hz
3 Counter of DIN2 -
4 Frequency of DIN2 Hz
5 Counter of DIN3 -
6 Frequency of DIN3 Hz
7 Counter of DIN4 -
8 Frequency of DIN4 Hz
9 Counter of DIN5 -
10 Frequency of DIN5 Hz
11 Counter of DIN6 -
12 Frequency of DIN6 Hz

Command: DIN

Results:

Index Value Unit
1 Status of DIN1 (1 =HI, 0=L0) -
2 Status of DIN2 (1 =HI, 0=L0) -
3 Status of DIN3 (1 =HI, 0=L0) -
4 Status of DIN4 (1 =HI, 0=L0) -
5 Status of DIN5 (1 =HI, 0=L0) -
6 Status of DIN6 (1 =HI, 0=L0) -

Command: analog

Results:

Index Value Unit
1 Voltage of AIN1 v
2 Voltage of AIN2 Vv
3 Voltage of AIN3 v
4 Voltage of AIN4 v
5 Voltage of AIN5 v
6 Voltage of AIN6 V
7 Voltage of EXC v
8 Voltage of power supply V

The following poll command provides measured values
from the blueberry INPUT Module:

Command: #AA\r (with AA=01..99 = poll address)

Results: . )
(serial numbers from 4001, firmware version 4.2)

Index Value Unit
1 Voltage of IN1 Vv
2 Voltage of IN2 Vv
3 Voltage of IN3 Vv
4 Voltage of IN4 Vv
5 Voltage of IN5 Vv
6 Voltage of IN6 v
7 Voltage of IN7 v
8 Voltage of IN8 v
9 Counter of IN1 -
10 Counter of IN2 -
11 Counter of IN3 -
12 Counter of IN4 -
13 Counter of IN5 -
14 Counter of IN6 -
15 Counter of IN7 -
16 Counter of IN8 =
17 Frequency of IN1 Hz
18 Frequency of IN2 Hz
19 Frequency of IN3 Hz
20 Frequency of IN4 Hz
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21 Frequency of IN5 Hz

22 Frequency of IN6 Hz

23 Frequency of IN7 Hz

24 Frequency of IN8 Hz

25 Barometric pressure hPa
(only partNo.0151-P, else 0.00)

26 Onboard temperature °C
(only partNo.0151-P, else 0.0)

27 Voltage of power supply Vv
28 Voltage of CC1 v
(constant current supply)

29 Voltage of CC2 Vv

(constant current supply)

Select the data format from the list:
decimal reads the received data values
as decimal floating point numbers.
hex reads the received data values as
hexadecimal values and converts them
into decimal integer values

(e.g., 8A = 138).

Data Format

Click OK to save all settings into the data logger.

Setting the Digital Outputs

The blueberry NDL485 provides 4 digital outputs. They
are used to control peripheric devices or sensors. Digital
outputs can be triggered depending on measured values
or depending on time.

To set the digital outputs select Setup > Measurement.
Define a measurement function and use DOUT1, DOUT2,
DOUT3 or DOUT4 as function name to switch the respec-
tive output. The output is LO if the result of the meas-
urement function is 0, otherwise it is HI. The DOUTn tag
must not be followed directly by another character. If
you want to add additional text to the function name
pleaseinserta blank character after the DOUTn tag.

Example: Heating Control
DOUT1 (1=Heater ON) = TempAir < 4

DOUT1 activates a heater at ambient air temperatures
below 4 °C.

Example: Reset Timer for GSM Modem
DOUT2 (1=Modem On) = !((HOUR==3) * (MINUTE<1))

DOUT2 switches a GSM modem off for one minute every
day at 3:00a.m.

Example: Timer for GSM Modem
DOUT2 (1=Modem On) = (HOUR>=11) * (HOUR<14)

DOUT2 switches a GSM modem on every day from 11:00
to 14:00.

Example: Timer for GSM Modem
DOUT2 (1=Modem On) = (HOUR==8) + (HOUR==15)

DOUT2 switches a GSM modem on every day from
8:00 to 9:00 and from 15:00 to 16:00.

Example: Flashing Light

DOUT3 (Signal) = SECOND%2

DOUTS3 flashes a lamp every 2 seconds.
Example: Wind Speed from a specific Sector

Ws (m/s) =0.254 *b12+0.213 * (b12>0)
WD (deg) = (360 * b1/b2 + 127) % 360
DOUT4 (Storm) = (WS>15) * (WD>90) * (WD<180)

DOUT4 triggers a storm alarm for wind speeds WS
above 15m/s and wind directions WD from the sector
between east and south. The multiplication operator
* provides the logical AND combination of all three
conditions.

Example: Switching Output with Hysteresis

T(°C) =100 * a4 - 40
DOUT1 (Heating) = (T<0) + (#DOUT1 * (T<4)) else 0

DOUT1 controls a heating with a hysteresis. Tempera-
tures below 0°C switch the heating on. Temperatures
above 4 °C switch the heating off.
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Testing Poll Commands

Poll commands can be entered manually in order to test
the response of the data logger, a sensor or an INPUT
Module.

%) Wilmers Messtechnik - Networked Data Logger NDL485 - Mozilla Firefox

Datei Dearbeiten Ansicht Chronk  Lesszeichen Extras  Hife
@ - Gy L0 hipyfitez.ies0.s s B 5
[B] Meistbesuchte Seitern & Kostenlose Hotmail | ] Links anpassen | ] Windows Media | ] Windows »
|_] Wilmers Messtechnik - Networke... B3 | | ] http:jj192.168.0.31 fegi-bin/blusherry - -
Diagrams Archive HighRes Longterm Setup Help
30.05.2010 18:10:57 UTC ~
RS485 Setup
Digital Inputs _ [12[2[30(4 Default Baudrate [ 13200
Digital Outputs [1&[2@ |3 |49 Character Delay |nodeky %
WppTempGenerator poll Delay 1oams v
degc) e ;
(deg Timeout [
WppTempMotor B
ety 273.1 Retry off ¥
WppCurrentsignal {-)| -273.1 Error Checking  [on %
wppTempContainer
(degC) = Poll Commands (test)
WppUBattery (V) o Command Baudrate Data Format
WppUStarterBatter: Pall -
(VD)D ¥ 13.5 Command e detzul ¥ | | decimal v
wppFuelLevel (1) 721,53 | Fol agial setau ] [deoimal %
command
WppDout (-) 1800 o
o ;
WppDoutStarter din default W | | decimal v
(0=DFff 1=0n) o EDI"'”ma"d
o :
wppDoutStopswitch 8 g |sstoad default % | | decimal »
(0=Closed 1=Open) C PDI"“'“‘”‘
o
WppDoutPowerswitch - d H2SS defsult % | | decimal v
(0=0ff 1=0n) w d“;”m‘"f
WppDoutFuelpump i a g new
(0=0ff 1=0n) L detauk | [decimal
WppDoutPreheater A
0=0ff 1=0
fv e '(')) N Alternative configuration|
ppStatus (-
Load configuration fram file: Upload
WppOn (D=0FF o g Spoac
1=0N)
WppPreheating
(0=No 1=Yes) =
WppStarting (0=No @ hd
1=Yes) LaKs 5
Fertig

Setup > Measurement > Test poll commands

Select Setup > Measurement. Scroll down to RS485
Setup and click on (test) in the Poll Commands section.
This opens a new browser window with a text terminal.
Please set the RS485 interface parameters appropriate
to the device to poll. Enter the poll command into the
Send field and click on OK. The NDL485 will now record
all answers of the polled device during the time period
defined by Timeout and display it in the lower part of the
window.

Manual polling can be used to test whether a sensor
provides proper data. It can also be used to read out the
configuration of a sensor (e.g., a sonic anemometer) or
of the blueberry INPUT Module or to change parameters
in these devices. The following pictures show the test-
ing of the analogue inputs of the data logger NDL485
and the use with the controller of the WindPowerPack
generator system.

) Mozilla Firefox

Ditei Bearbeten Ansicht  Chronk  Lesezeichen  Extras  Hife
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Manual Poll Command Interface

RS485 Setup
Default Baudrate
Character Delay
Poll Delay

19200 W
nodelay ¥
S0ms W
25

Timeout hd

Poll command
Send: [$255 haipy

Date:
2010-0%5-30 18:06:36,915 0.001

RESULT=
Syntax: [C][addr] [cmd] [key] [prm] [prm2] [prm3][CR] {[CR] = "\r'}
(All modules accept [addr] = '255")

#[addr] (poll measured data}

#[addr] clear system (reset configuration)

#[addr] info (display actual configuration)

#[addr] help {display commands)

#[addr] set genbat <0..999> <0..999> <0..999> {generator start, stop, max valtage (V*10))
#[addr] set genstartbat <0..999> (starter batt. generator start voltage (V*10))

#[addr] set genddp <0..9993 <0..999> {consumers start, stop voltage (¥*10))

$[addr] set genmct <0..64800> {generator min. charging time (s

4[addr] genreset (reset the generator in AUTO mode)

$[addr] genstart {start the generator in AUTO mode)

#$[addr] genon {start the generator in MANUAL mode)

#[addr] genoff (switch the generator OFF)

Fertig

Test poll commands for WindPowerPack controller

) Mozilla Firefox E]@E'

Datei EBearbeiten  Ansicht  Chronik  Lesezeichen  Extras  Hilfe
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Manual Poll Command Interface

RS5485 Setup
Default Baudrate

Character Delay
Faoll Delay

13200 W
nodelay W
Sims W

Timeout .

Poll Command

Send: |analog

Date:
2010-05-30 15:49:02.809 0.001

RESULT= 0.0040 0.0030 0.0021 0.0096 0.4183 0.4424 13.4809 13.6357

Ready

Fettig

Test poll commands for analogue inputs of NDL485
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Setting Date and Time

If the NDL 485 is connected to the Internet the data
logger updates its internal realtime clock automatically
from an Internet time server. The NDL 485 adjustes the
clock to the time zone set by the user.

Select Setup > Date & Time to set the parameters for re-
altime clock synchronization. Select the time related to
UTC. Select the region where the data loggeris installed.
The NDL 485 uses the time server the closest to its site
in order to provide maximum accuracy. Optionally, select
a time server. If you do not define a specific time server
the NDL 485 automatically selects a suitable server from
a pool of time servers. Click OK to accept the settings.

vnmiusmdwk mmmwu =) X)

unnn

Wilmers Messtechnik

27.10.2008 20:56:18 UTC+1 2
Manual Clock Control

Click here to adjist the date and time manually: Adjust Clock

chISICanaH 1004.71 ||| Network Time Prokocol {NTP)

(m/=) i
eld ——1 The system dock willl be synchranised with a NTP time server S min befare
vCup988dm (m/s) | 12.753 || .o b

vCups00dm (m/s)  12.562 || 1ime zone T |
vCup598dm (m/s) 9.443 =
3ms| [|| Tme Server Regicn

vCup200dm (m,s) 5.351 Tme Server

mm“m 35128 {Leave empty If unsure)
?:""]"'.”"" 355.48

Tempssm (°c) aas|| @O

TempSm (*C) 2281 5

Setup > Date and Time: automatical synchronization via Internet

If the data logger is not connected to the Internet, se-
lect Adjust Clock to set the realtime clock manually.

L[> ][] © o192 16803

Wilmers Messtachnik

28.10.2008 05:55:24 UTC+1 . Set Time and Date

Tme (057 =) (Fimin 1)
Date (28 [»] [october =] (2008 [+]

|Digital Inputs (1243 4./
Digital Outputs 15 25 30 40
vSonic1003dm
(m/s)

vCup998dm (m/s) 12.753

1005.43

vProp983dm (m/s) 12.644

vCup800dm (m/s) 11.562

vCup598dm (m/s) 9.443 4
e ——— o

Setup > Date and Time: manual adjustment of realtime clock

Select the settings from the Time and Date lists and click
0K.

Network Interface

Setting the Network Parameters

The NDL 485 can be connected locally to a PC via cross-
patch cable and it can be integrated into a PC network
(LAN) by means of a standard Ethernet cable. The IP
address of the data logger has to be adapted to the net-
work.

Select Setup > Network.

Assign an IP address to the data logger.

Wilmers Messtechnik

~|

 Local Area Network (LAN)
1P address
Netmask [ |

| (Leave netmask empty if unsure)
| Gateway  [192168.0.1
| Nemeserver 195155020 |

sl

Setup > Network: LAN and local PC Connection

Enter the subnet mask required for your network type.
If you are unsure about the subnet mask leave this
field empty. In this case, the default subnet mask
255.255.255.0is used.

Enter the gateway and name server (DNS) of your LAN
and click OK. The data logger uses the gateway to built
up a connection to the Internetin order to send data via
e-mail or FTP and to synchronize the internal realtime
clock from the Internet.
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Internet Integration

The NDL 485 is integrated into the Internet by means of
a DSL router orin remote sites by means of the blueberry
GSM Module. The GSM Module offers remote data trans-
mission and realtime access via cellular phone networks
(900 MHz, 1800 MHz and 1900 MHz). Two operation
modes are available:

In GSM mode, the data logger is called from a PC by
means of a telephone modem, similar to the dial-in con-
nection to an Internet provider. This mode offers direct
access to the web server of the NDL 485. In GSM mode,
the telephone costs depend on the connection time.

The GPRS mode offers full integration of the NDL 485
into the Internet. The data logger connects itself au-
tomatically to the Internet providing realtime access
from any Internet access point. Two password levels
protect the data logger against unauthorized access.
As GPRS does not use fixed IP addresses a dynamic DNS
server (e.g., dyndns.org) manages the dynamic IP ad-
dress. It provides access via a named URL. The name of
the server used by the NDL 485 to access the Internet
is called Access Point Name (APN). Private APNs pro-
vide outgoing data transmission from the data logger

to the Internet, e.g., via FTP or e-mail. However, they
block access from outside into the data logger. Public
APNs provide both access types. Dynamic DNS requires
a public APN! Please make sure that your GSM provider
offers a public APN. Public APNs are offered among oth-
ers by T-Mobile (Germany), TIM (Italy), Telenor (Norway),
WARID (Pakistan). In GPRS mode, the telephone costs
depend on the volume of transmitted data.

Please prepare the following information for the GSM/
GPRS setup of the NDL 485:

The data number of the SIM card. Please make sure
that you are really using the data number. Usually,
SIM cards have separate numbers for voice, fax and
asynchronous data transmission. We recommend
to use SIM cards without voice function. Pure data
cards are cheaper than voice cards.

1.

. The PIN of the SIM card. You must disable the PIN
request before use because the NDL 485 is not able
to enter the PIN. Please insert the SIM card into your
mobile phone, enter the PIN and disable the PIN re-
quest.

. The APN. Please make sure that you have got a public
APN.

Setting up the GPRS Connection

Selup

02.06.2006

Date: ) 4:52:08

GERS Interner Coauertion
Activate GFES no v
Digital
Inputs
Digital
Outputs
wiilla (mys)
wBEDD (mysy
Wil (mfe)
w30 (m/s)
w10 (mfs)
Dir78 (%)
DHr26° )
Temp s (“C)
TempOs {°C)
rHum0S %
RH}

pharo (hPa)

126 3a 48

Medem Tre
la 2836 4

1.35714
1.19217
0.73721
0.89419
0.81758
206, 186
210,619
20,825

20,52

windenast 2258 dymdng. crg

accot at dymdng org to use

45,55

1026.43
13.6624
3.03
3.024

uSupply (V)
uCCl (V)
uCCz (V)

&lrein |

B It

Setup > GPRS/Modem: GPRS Internet Connection

Select Setup > GPRS to setup a GPRS connection. Select
yes at Activate GPRS and enter the APN and optionally
the user name and password at GPRS Internet Connec-
tion. Please ask your GSM provider for these data. A list
of international APNs is available in the Internet at
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http://www.quickim.com/support/gprs-settings.html.

When the NDL 485 operates in GPRS mode it will switch
to GSM mode every day between 20:00 and 21:00. During
this time the data logger is accessible via dial-in connec-
tion.

Please enter the host name of the data logger in sec-
tion Dynamic DNS Service. Please enter the access
code to your dyndns.org account in the fields Username
and Password. The host name must be registered at
http://www.dyndns.org before. Please refer to the fol-
lowing chapter for further details.

Click OK to save the settings.

Remote Access via Internet

GPRS networks use dynamic IP addresses. Every time the
NDL 485 connects to the Internetit getsa newIPaddress
from the Internet service provider. If we want to access
the data logger via Internet we need to know this IP ad-
dress. Dynamic DNS manages dynamic IP addresses and
provides access to them. The user defines a host name for
his measurement station (e.g., station-103.dyndns.org).
When the NDL 485 connects to the Internet it sends its
actual IP address to the DynDNS server. The DynDNS
server translates the IP address to the host name of the
data logger. This provides us access to the measurement
station without knowing its IP address.

Creating a DynDNS Access

Please proceed as follows to create your account and a
host at DynDNS:

1. Open your Internet browser and visit the web site
http://www.dyndns.org.

2. Select Create Account.

......

3. Definea user name, a password and enter your e-mail
address.

Scroll down and activate I agree to AUP and I will
only create one (1) free account. Click on Create Ac-
count.

.......

5. You will now receive an e-mail with a confirmation
for the DynDNS account. This takes typically a few
minutes. Open the e-mail and follow the stated link.
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Verschistan nach... [ verschishen )

= welerenen | Tos Umissen O wochen

You have now created your account. The next steps
create a DynDNS host.

6. Select Login.

(' DynDNS s

Account Confirmed o

7. Enteryouraccess code (user name and password) and
click Login.

8. Select My Services.

) DynDNS

Account Summary for windstations

iy St -

9. Select Add New Hostname.

. Account Level Services
- e
.
[T —
L -

Zone Level Services Cin

—— )

Other Services

10. Enter a host name and click Use auto-detected IP
address. Click Create Host.

This host can now be used with the NDL 485 (see Setting
up the GPRS connection). If you want to create further
hosts, please click Add New Hostname and repeat step
10.
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Accessing the NDL485 via Internet

Please proceed as follows to access your NDL 485 from
the Internet:

Start your Internet browser, enter the DyDNS
host name of your measurement station (e.q.,
station-103.dyndns.org) into the address field and hit

7 Weima 7y Mascteehvo - Metwmrkar! Dsta Ligpe NOLARS - Windows intemes Lindses

SR -
WA | e Macrtacrk - Bistwriked Dt Logge

09.02.2008
Date:07;26:36

Dighal
TInguts
Digital
Dutputs

1423045

Lo 2¢ Do de

fromperatme | ) o)
Humidity %rH 06,63
Supply V123557

dala dsplay)

Internet access to an NDL 485 research via DynDNS from a desktop PC

<enter>. Do not add www to the host name!

The remote Internet access provides the same function-
ality as the local access via Ethernet. The user can dis-
play and download data and diagrams and he can change
the configuration.

Accessing the NDL 485 from a Mobile Phone

Internet access via DynDNS from a mobile phone

The NDL 485 provides a special web interface adapted to
small displays of pocket PCs, MDAs and mobile phones.

Please proceed as follows to access your NDL 485 from
an Internet capable mobile device :

1. Connect your mobile device to the Internet and start
the Internet browser.

2. Enter the DynDNS host name of your measurement
stationinto the address field and add /compact to the
host name. (e.g., station-103.dyndns.org/compact).
Do not add www to the host name!

3. Click Connect.

4. Enteruser name and password of the data logger into
the login dialog.

The functionality of the mobile access depends on the
browser of your mobile device. Some mobile browsers
might not be able of downloading measured data files.
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Opera offers a powerful free browser for mobile phones.
Please refer to http://www.operamini.com for further
details.

Remote Access via GSM

GPRS provides the most flexible and powerful remote
access to the NDL 485. It requires a public APN. For GSM
providers that do not offer a public APN, the blueberry
GSM Module provides remote connection to the NDL 485
via PPP. This operation mode is similar to a dial-in con-
nection to an Internet server. It requires a PC with ana-
logue telephone modem.

Setting up the GSM Connection

Please proceed as follows in order to configure your Win-
dows PC for a GSM remote connection:

Assistent fiir neue Verbindungen
Willkommen
Mit diesem Assisterten kinnen Sie:

* Eine Yerbindung mit dem Intemet herstellen

* Eine Verbindung mit sinem privaten Netzwerk herstellen,
vie 2. B. einem Fimennetzmerk

* EinHeim- oder ein kleines Fimennetzwerk einichten

Kiicken Sie auf "wsitsr", um den Vorgang fortzusetzen

abbrechen

1. Select Start > Settings > Network and Dial-In
Connections > New Connection. A wizard will lead

Assistent fiir neue Verbindungen
Netzwerkverbindungstyp
‘wiie: mchien Gie vorgehen?

(&) Verbindung mit dem Internet herstellen
Stelt sire Verbindung rit dem Intermet her, 3o dass Sie den Browser vernenden
und E-Malllesen kinnen
O Verbindung mit dem Netzwerk am Arbeitsplatz herstellen
Stell sine Yerbindung mit sinem Fimennstzweik (uber sine DFU- oder
WPN-AVerbindung) her, so dass Sie von zu Hause oder unteregs arbetten Knren.
() Ein Heim- oder ein kleines Firmennetzwerk einrichten
Stell sine Yerbindung mit sinem bestshenden Heim- oder Klsinem Fimennstzweik
her oder richtet eine neve Verbindung ein
) Eine erweiterte Verbindung einrichten
Stell sine direkts Verbindung mit einsm andsren Computer iiber sinen seriellen,

paralielen oder Infrarctanschluss her oder fichiet diesen Computer o ein, dass
andere Computer darauf zugreifen kéinnen

< Zurick_|[_weiter> | [ Abbrechen

you through the configuration process.

Assistent fiir neue Verbindungen
Vorbereitung
Der dssistent wird zum Einrichten der Intermetverbindung vorbereitet,

‘Wiz soll die Yerbindung mit dem Internet hergestelt werden?
 Einen Internetdienstanbieter aus einer Liste auswahlen

@) Verbindung manuell einrichten

Fiir eine DFU-erbindung ist ein Kantonamen, ein Kennwort und die Rufnummer
i erforderlich. Ein Breit erfordett keine

Rufnummer.

() CD eines Internetdienstanbieters verwenden

< Zuiick _|[_weiter» | [ abbrechen

2. Click Next.

Assistent fiir neue Verbindungen,
Internetverbindung
\Wie sall die Intemetverbindung hergestell werden?

(@ Verbindung mit einem DF0-Modem herstellen
Shell eine Verbindung mit einem Moden und Uber eine hetkammliche T elefonleitung
oder eine [SDN-Telsfonlsitung her.

i uber eine die
Benutzername und Kennwort erfordert

Stell sine Hochgeschwindigksitsverbindung Uber sin D5L- oder Kabslmodem her
Intemetdienstanbister nennen diesen Verbindungstyp héfig PPROE.

(@] i uber eine bestandige aktive Breil hi

Stellt eine Hochgeschwindigk eitsverbindung Liber ein Kabelmodem oder eine DSL-
ader LA Verbindung her. Diese Yerbindung ist immer aktiv und erfordert keine:
Benutzaranmeldung

< Zuiick._|(_ Weter> | [ Abbrechen

3. Select Establish an Internet Connection and click
Next.

Assistent fiir neue Verbindungen
Gerat auswahlen
Dieses Gerdt wird zum Herstellen der Yerbindung venwendst,

Sic haben meht als ein DFU Gerdt am Camputer angeschiossen.
‘W ahlen Sie die Gerte, die flr diese Verbindung verwendet werden sollen:
T3 285 Modem - AWM ISDN Mailbo (< 75) [8YMISDH4) -
[ 455 Modem - A¥M 150N RS [PPP over ISDN) (AVMISDNZ)
[0 &35 Modem - A¥M ISDM SoftCompression X, 75/ 42bis [AWMISDN3)
Madem - Matorala Satelite Series Data Modem #2 [COM1)

9600 bps Mad:

< Zuiick _|[_weiters | [ abbrechen

4. Select Manual Connection and click on Next.

5. Select Modem Connection and click Next.
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Assistent fiir neue Verbindungen

Verbindungsname
wie lautet der Mame des Intemetdienstanbieters?

Geben den Mamen des Intemetdienstanbisters im folgenden Feld ein

Name des Intemetdienstanbieters

| bluebery-ndl485

Der hier eingegebens Name wird ak: Name fill die zu erstellends Verbindung venwendet.

< zuiick | Weters | [ abbrechen

6. A list displays all modems available on your PC. Se-
lect the modem to be used for remote data transmis-
sion and click Next.

Enter a name for the remote connection, e.g., the

Assistent fiir neue Verbindungen

Zu wahlende Rufnummer
“wiie lautet die Rufrummer des Intermetdienstanbieters?

Geben Sie die Rufrurmer unten gin.

Rufrummer
%0049150254 |

Siz miissen eventuell eine 1" baw, eine Yorwshl oder beides einbeziehen.
“w/ahlen Sie die Rufnummer auf lhiem Telefon. wenn Sie sich nicht sicher sind.
ob diese 2ustziichen Nummerm erforderlich sind. Die gewahite Nummer ist
komekt, wenn Sie bei dem Telefonariuf eiven Modemton hdren.

< Zuiick_|[_Weiter> | [ Abbrechen

name of the measurement site and click Next.

8. Enter the telephone number of the GSM modem.

Assistent fiir neue Verbindungen
Geben Sie einen Kontonamen und ein Kennwort fill den Intemetdienstanbister sin.
Schreiben Sie diese Infomationen auf und verwahren Sie sie an einem sicheren Ort.

[Wenden Sie sich an den Intemetdienstanbieter, wenn Sie den Kontonamen oder das
Kennwart eines verhandenen Kantos vergessen haben.)

Internetkantoinformationen
Sie benitigen sinen Kartonamen und sin Kennwort fitdie Armekdung an lhrem
Intemetkanto.

Benutzermame: |

Kernwait bestatiger: | |

Kerrwart |

Diesen Kontanamen und Kennwort fii die Intermetverbindung aller Benutzer dieses
Camputers werwenden

[ Wetbindung als Standardintemetverbindung verenden

< Zuiick_|[_water> | [ Abbrechen

GSM SIM cards have separate numbers for fax and

Assistent fiir neue Verbindungen

Fertigstellen des Assistenten

Die erforderliche Schiitte 2um Erstellen der folgenden
Verbindung wurden ordnungsgemal durchaefh:

blueberry-ndl485

* Fii alle Berutzer dieses Computers heigeben
* Denselben Benutzeinamen und dasselbe Kenrwart fr

Die Verbindung wird im Ordner “Hetewerk verbindunger’”
gespeichert.

[Z]Werkniipfung auf dem Desklop hinzufigen

Klicken Sie auf "Fertig stellen”’, um diese Yerbindung 2u
erstellen und den Yorgang abzuschiislen.

< Zuiick_|[ Ferig stellen | [ bbrechen

data transmission. Please make sure to use the data
number. Click Next.

9. Click Next without entering the access code in the
dialogue.

10. Click Next to finish the configuration.
This chapter describes the configuration process under

MS Windows XP. Similar wizards assist you at the con-
figuration under Windows 2000, Mac 0S or Linux.

Verbindung mit "blueberry-ndl485™ herstellen |E|[z|

Berwtzername: | |

Kernwart: | |

[] Benutzernamen und Kennwart speichern fiir:

[o04g160254

W ahlen:

| wahlen |[ Abbrechen ][Eigenschaften” Hilfe:

Dial-in Connection under Windows XP

Accessing the NDL 485 via GSM

Please proceed as follows in order to establish a remote
connection to the NDL 485 via GSM:

1. Select Start > Settings > Network and Dial-In
Connections > blueberry-ndl485 where blueberry-
ndl485 is the name of your remote connection.
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2. Click on Dial without entering the access code. A dia- °
logue diplays the progress while connecting. When Password Protection

the connection has been established the dialogue

box changes into an icon in the lower right corner of Two password levels protect the NDL 485 against unau-
the task bar. thorized access:

3. Once the connection is established, please start your The user guest is allowed to view actual measured data
Internet browser, enter the IP address 10.1.1.1 into and configuration settings and to download measured
the address field of the browser and hit the <enter> data. He is allowed to set date and time. The user guest
key. Please note that this IP address is the same for is not allowed to delete measured data or to change any
all NDL 485 units. Itis independent of the IP address configuration settings.

set at Local Network Settings.
The user admin has all rights. He is allowed to delete
measured data and to change configuration settings.

sahan 7 ronen €0 (30 1L

Verbindung zu 10.1.1.1 herstellen E|[Z|

1 1.01,2005 hive e
Date: ) 75702 Archive

E .
i

Digital
Inputs

1e2a/3e(de
g'gg:“ 10 2e/30de
vl [i]
W [1}
va 1]
wil o
Direction 45,4691
Temperature 19.4
Baro 1016.96
V_supply 11.484

MNDL485-2551 0295343

Berutzernarne: | 3 quest B |

Kenrort: | Ty |

) [ kenrwort speichern

] ot Pt 1011 g i hamorry s b v [

Web Interface in GSM Mode

[ Ok l [ Abbrechen

4. Enter the user name and password for the NDL 485 Lo Dl
and click OK. ogin Dialogue

5. In GSM mode, the web interface provides all func- .
Setting the User Password

Login as user admin and select Setup > Password. Enter
i the new password for user guest and click OK.

Windaws-Firewalleinstellungen dndern

2 wilmers Messtechnik - Netwarked Data Logger MDL485 - Microsoft bnternen Exgl... [ |[B1]8E]
-

Outel  Doarbeben Amkht Favorken Oidres 7 o«
Windows Task Bar: Disconnect GSM Connection Quaws - € - 8] B € O swhen Srroutm @ (2- L [F -
dreeen ] gl 1680420 v [EY wchosin 7
tions that are available at local or at GPRS connec- Tt TSR b e
tion. TTICAL IO

AINZ mY [
ATNG MV 0 [0k Reset |
AN Y [

6. To disconnect the GSM connection click on the con- e T
nection icon with the right mouse botton and select
Disconnect from the popup menu. Setup > Password: User password

B Ineemet

The password for the user admin cannot be changed.
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Help Function

The help function the NDL 485 provides system informa-
tion about the data logger as well as an online manual.

Select Setup > Help > About. The dialog indicates in-
formation about type and firmware version of the data
logger.

2 hitp://192.168.0.31/htmlfabout. htmL - Microsoft In...

Datei  Bearbeiten  Ansicht  Favoriten

a = A »
= Y A y e
@ Zurick x| |@] g ) suchen 5 ¢ Favorien

advesse ] hitp1jf192,168.0.31 fhemfabout kbl v | B Wechssnzu | Links >

About Network Data Logger NDL 485

Type INDLA485
Version 1.2.1
Date  MiDez 22 15:54:20 CET 2004

&] Fertig & Internet

Help > About: Data Logger System Information

Select Help > Manual to view a short manual of the
NDL 485.

‘T bucberry ML 485 - Marual - Microsoft Intemek Explorer =10 x|
Datsl  Bewbeten  Arsoht  Fawoten Extras 7 ar
Qs - - 1x) 2] (o] s S rweam @] 31,
Ackesse [ @] hro:i/192. 166.0.5 3 manuslfroer sl x| B wechsehzu
a
OMLINE MANUAL FOR DATA LOGGER NDL 485 :I

Web-Tnterface

The user surface of the data logger blusberry NDL 485 is
realized by means of a web Interface. Configuration of the
data logager, display and download of measured data
requires a web browser (e.9., Intermet-Explorer, Opera,
Mozilla). The data logger is connected to the PC locally via
Ethamet or via remote data transmission (DSL, GSM, GPRS).
Start the browser, enter the IP address of the data logger
Into the address fl eld and type <enter>. Enter the access
code into the login dialog.

The NDL 485 provides two user levels: 3

(& Fertig | = @ Iremet el

Help > Manual: Online Manual

Rebooting the NDL 485

The NDL 485 can be rebooted in two ways: by interrup-
tion of the power supply and via the web interface. In
order to reboot the NDL 485 via the web interface please
proceed as follows:

1. Start the web browser and login to the NDL 485 as
user admin.

2. Select Help > About > Maintenance.

3. Click on Reboot in order to start the update process.

3 Mazilla Firefox

Datel  Dewbwster: Aokt Chronk  [esereidwn  Exbras  Hife

@ - - 2 [0 mpyniszasa.0aicen = ] K

L Kooterdose Hobmal || Links anpassen || Windows Media || Windows
) Wil s Mosstinchnk: - Natworad o bt/ /192,16, =mainbenance L3 =1

System Maintenance

Reboot -~ restart the NOL4BS

Durng & reboot, all network conmections to the NOL4ES are temporarly
unavailable, Afterwards, the measurement index 15 Incremented and a new

b & barted.
< Chent] ehatt.

Upﬂﬂﬂ’. upnare the firmware

This performs a firmware update on the NDL4ES. You need a file (*.install)
containing the new Armware, and an FTP dient to copy this onto the
NOL485. You will get further instructions after dicking on the
Update-button

TIPS — update,

4. Wait 2 minutes until the data logger is up again.
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FTP Access

Some operations, like deleting measured data and ap-
plying a firmware update require an FTP access to the
NDL 485. The following describes the establishment of
an FTP access by means of the free FTP client FileZilla.

Installing FileZilla

The FTP client FileZilla can be downloaded free of charge
from the Internet at the following site:

http://sourceforge.net/projects/filezilla

In order to install FileZilla and to configure it for the
NDL 485 please proceed as follows:

Download the software from the above stated web-
site and installit according to the instructions of the
supplier.

1.

. Start FileZilla.

Tee Dernchings.

Stann

Seren Verwatung ofien

3. Select File > Server Mangement.

Servermanager
Diated

Server Detals

Host:
192.168.0.31

3 Figeem FTD-Sarver
B ndsUs-enausT

Servertyp:
FTP
Legantyp
Oanomm (3 Mol
] Py [P eovessl sk esbsrgean sragpetaers
Aetsunt:

) ot

Fassweort
[CPatsrrast necht spaichern
[

|esee Sewver | [nesser Orcroee | | Ensferen |

[ ropueren | [umbenerren] [erweses... | SRS

\-\er:mden‘ Abbrachan | Spekharn |

Select New Server and enter a name for the data
logger.

Enter the IP address of the NDL 485 into the Host
field.

Select the logon type normal.

Enter the user name admin and the admin password
of your NDL 485 .

Click on Save to save the settings.

Click on Connect to built up the connection to the
NDL 485. The right part of the screen displays the
file system of the NDL 485. You can use the FTP client
like a file explorer to delete measured data files from
the NDL 485 and to move files from the NDL 485 to
your local computer or from your computer to the
NDL 485.

Dutey...  Dutetyn

Cotercher  25.012.. 000

Coteercher  39.013.. O7:8

Dobsrcher  25.112.. O7:30
e

Berost Schiange: 0 Byle: @

Deleting Measured Data

The NDL 485 saves measured data in a ring buffer. The
oldest data lines are automatically overwritten when the
data memoryis full. Usually, deleting of measured data is
only necessary at the beginning of a new measurement,
e.g., if the data logger is moved to another site. In order
to delete measured data please proceed as follows:

1. Establish an FTP connection to the NDL 485.

P2 PilaZills - Verbunden mis ndH485-mn 044 |172.168,0.31

v v e | L
@e G
o =]
A Siarhee
“or Lokser Duteron e 12 -
. = - -

Cakoteiursd

Dlterime iy, CWbayT

320080617 patchea. Dateorcres
E2006-06 17 patchv. Catworcrer
2 G el 3 Dot it Z95EH Iyt

[Erpee—— e Rl

Schiargn: DBvtm 88|

[
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2. Double click on archive to change to the archive
directory.

et
Ee

deaty, Waticieg e Hf

OBR T e [ [ o Cemmls
Te— =
S

Lok e Sei | O Do scame'sbi sty w | Servmicie | ol fachra -
= 0 coniuee: Dotiy.. Citsby  futen D WA
= Datmon
¥ arbmiticlats s Tk
o Liesier Diterriger 1:) MOECDate 07122
& ety "
-
Plenirrs: Dateacy... Cabatyn Fuitrt grein fres—,
] Mersioh
(20060617 patchia. . Catesorcres 26.11.2007 1. ¥ Merenh
(200606 1T patcheu. Datosorcres 6112007 1.
9 Credrwn el 3 Distmiry £t OGR4 Bt
Luksher Dot v e Aibtey  Aswls Delones
[ Barest. Scharge: 0Byt & &

3. Markallfiles to be deleted and press <Del>.
If only data files (*.csv) are deleted the measurement

index continues with the actual value. In order to reset
theindex please delete the file index.

[] (]
Updating the Firmware
The firmware of the NDL 485 can be updated via local
Ethernet connection or remotely via GSM, GPRS or DSL.
In order to update the firmware of the NDL 485 please
proceed as follows:
1. Establish an FTP connection to the NDL 485.

2. Double click on .. to change to the root directory.

3. Open the folder /tmp.

4. Change on the local computer to the folder that con-
tains the firmware update file.

7 File2itla - Verbunden mit ndH8%-5n 1057 (192, 108.0.37)
Dutel Bewbertin Trwhe Anicht Wartmichangs Server  HEw
Baruioer Pzt Prst [iltradon |+
Lokae St | £\0) abar'scetoy' b sty w1 w | Servmnte |/ -
O ~ [ caterarms Cutisgr...  Datetyp Catun  Det A
3 Pk 4.0 &.
Q) PlasthFo (FTP Chert) e Coporchee Z1113.. 1751
cholica i O # | Sty Doteorches 22.112.. 14118
. (=™ Cateerchee 01013
= = e Dubecrcher  OLOLL...
Oyterde 251220070 o st il g NI
a2 0116 et ME PETALOatS 14092007 L., jl"_:_ I““‘“‘WM": s
200 Teatchlumant 170020083 = o b
lbensc Dabeorcher 23122
e Dutgerchee 04573,
S Dabeorcher L1
e Datgerchee CHO8.2
(=t Dbeorcher 23122
Qm Doowerchee 010132,
Stmo Dotsrchsr 75117, 0742
=1 Dateorcher  19.012.
= Dobperchee 24012, (841 &
< »
1 ncier und 2 Diatoien mé, 1506574 Bytos. 17 Crches und 2 Datsen mit £5 Bytes.
Lok Cutiarieres Gribe_Fking  Reerestn Datename ot Stat
Bt Schiange: 0 Byt &

5. Click with the right mouse button on the firmware
update file (e.g., Ndl485-2-0-11.install) and select
Upload. Now, FTP transfers this file to your NDL 485.

[ Fileitla - Verbunden mit ndi0%-sn 1057 192, 168.0.37)
Oated Dowbestirs Tresfer  Anicht  Wirtinchlrge  Servie i
- hEQE RLOER T A Borvtos: [ Fuet [t )
buwre PLSTO -
Jecima 60 Restatng ot ) Gt STORE o0 FETRIEVE 1s kst sl
s Vg geerr.
Boert  COLE Al 2 0116 mutsd
et 250 DELE.
= [Sorvmete [rmer -
O e ~ [ Cotwrarm - Categr...  Dutwtp  Dabam et
2 Friwirkd 4.0 B..
2 AashxP (FTP Chart) i krgpem 0 WOHGTER.., H.01a. S0
b et # | Bjcurortc.coe 54 Moowoft.. 212 07SL
= o0 Mercsoft .. Ma12. 00
& &)wrortmonth.cov 15 Moveoft.. L2 O7SL
2 P P 0 195 Mercecft .. M2 S
P L D SN Blarenkstat.cov 6 Mooeoft .. 12 0750
s R, N 19 Moesh .. MI1E. 0750
ROATE.TXT To0s 3. e
Bir Wiarshiangs rnutign e st W04 DrORN  SALE. W
Upioad ak = s Lastpiot 97 LASTRLO.. 25.012. 0753
i tpker 4 LASTRLO., 2.012. 0750
Veroechne erstellen
Offnen
Areshen [ bearteten
Loscher
Liksrserse
[————
« »
1 Cortid it SO0 Byt ssgewihit. 10 Diatoten mit LSS3S Bytos.
Lok sk Cugtiarurey e Fhhang  Rarmots Datename it Seatu
[Borest Schiange: O Byte: &

6. Please wait until the transfer is sucessfully complet-
ed. The uploaded file is now visible in the /tmp folder
of the NDL 485.

17 Filelila - Verbunden mit ndH8%-mn 1057 (192.188.0.31)
Oated Dowbestirs Tresfer  Anicht  Wirtinchlrge  Servie i
Barwize Patwwst Pt \wiv
1anre Bt des Vitmichrisnhabs sfelgeich -
T = [Fornte [t -
O e S | cwscare - Catig.. Dty Dot Dex
3 Fraworks 4.0 -
2 st TP Gl b 0 LNGTBR. 312 0750
Qe % | Byrortm.co 54 Wcosoft.. 25012, 071
CiY o Mcroscft .. M013. 0SS
Cubename < Cubeiy... Duberyp Zulett -
B L Rlcurork month.coe 3% Moceoft . 12 0L
= 195 Meroscft .. M3, 0SS
b iefiries Cumedw 1120070 3 o
FnmEs20 1L VB PETALDMN  IAR0TL. —— v e
LPOATE. Pt 260 Tencblumnt  17.00.70083.. i RN T
- o 9% LASTRLO.. 25.012. 0755
EI—Er— BETAL-. HJlE. 0S8
36 LSTRO.. ZHILZ. 0750
¢ »
1 Ordrer und 2 Datosen mit 1506574 Bytes. 11 Dutoten mit L0600 Eytes.
Lk i Dot e Fxhhang et Datename ot St
| Bor st Schiange: O Bytes &

Start the web browser and login to the NDL 485 as
user admin.

Select Help > About > Maintenance.

Click on Update in order to start the update process.

3 Mazilka Firefox =13
Datei Qeabwten guchl Chonk  (merechen Eatis  Hite
4a - - /3 [0 muwnisz.as.03uco0 |+ b Gl

L) Korteriose Hotmal || Links anpassen || Windows Meda || Windows

| Vel Miosstached: - Networkad | ity 19216, =mainbenance L)

System Maintenance

Reboot -~ restart the NODL4AAS

During & reboot, all network conmections to the NDL4ES are temporarly
unavailsble, Afterwards, the measurement index is incremented and a new
measurement is started

(heoa] Perfarm a reboot.

Update -- update the firmware
This performs a firmware update on the NDL4ES. vou need a file (% install)
containing the new Rrmwars, and an FTP disnt t copy iz onte the

HIDOL4AS. You will get Further ingtructions after dicking on the
[
< (lpdse |, rrrware up-date.
Farty s - |
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10. Please follow the instructions displayed on the
screen. The update process will take approx. 5
minutes. The NDL 485 will restart automatically
after the update is completed. Regular flashing of
the BUSY LED at the data logger indicates that the
NDL 485 is up again.

IMPORTANT NOTE:

The NDL 485 must never be disconnected from the power
supply during update process! Interruption of the update
process can block the operation of the NDL 485.

Please restart the web browser and login to the
NDL 485.

In order to check whether the update was successfull
please select Help > About. Check whether the indicated
firmware version corresponds to the update you went to

apply.

3 Mozilla Firefox |:||E|[z|
Datei  Beatbeiten  Ansicht  Chronk  Leseseichen  Extras  Hife
€ P € U @ 0 rwlep] Do

|| Kosterlose Hotrmal || Links anpassen || Windows Media 23

|| Wilmers Messtechnik - .. | [ | http://19...0w=about 3 |-

About Network Data Logger NDL 485

Serial Number
Model

Version
Date v
Archive Memory 1Z8MBE

NDL485-2517243522

Maintenance Ferform System Maintenance

Fertig

Adapting the PC Network
Settings

When the NDL 485 is connected to a PC or a LAN the
network settings of the PC must comply to those of the
data logger.

In order to change the network settings of the PC please
proceed as follows:

Windows-Firewalleinstellungen dndern

Netzwerkverbindungen offnen

Right click on the network icon in the task bar and
select Open Network Settings.

s, Hetzwerkverbindungen

Datel  Beabeiten Amsicht Favorten Extras  Erwetert 7

€] > N Ael To oudoer  [TE1]-

24 W) Hetowinkvirbrdhagin | B3 wechsoin u
. 1594 VB

| =]

| Netzwerkauigaben

! g
[ Heuns Verbindung erstelien

B Enbein- odes o
Fimereatzwerk sreichien

@ Windowss-Frowalleinstrelungen
Brudern

Siehe such

1) etswsrkpachisnbehandung

Andere Orte

B Svsterstevenng
W Nerzwedumgebung
L) Expmne Dateern

) Aebetagintz

Double click on LAN Connection.

i Eipenschaften von LAN-Verbindung

Allgemnein I.érwe-\ier-l-i

Yerbindung herstellen Liber:

i HJ Broadeom Netxtreme 57xx Gigabit Co |

Dieze Verbindung verwendet folgende Elemente:

S NwiLink IPH/S P /MetBI0S-kampatibles Transportpro A |
T

|

| 2

Installieren Deit

Beschreibung

Symbol bei Yerbindung im Infobereich anzeigen

Benachrichtigen, wenn diese Yerbindung eingeschrankte oder
keine Konnektivitat besitzt
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3. Select Internet Protocol (TCP/IP) from the list and
click on Properties.

2%

Eigenschaften von Internetprotokoll [TCP/IP)

| Allgernein |

|IP-Einstellungen kinnen automatisch zugewiesen werden, wenn das
Netzwerk diese Funktion unterstiitzt, Wenden Sie sich andemfall: an
den Metzwerkadministrator, um die gesigneten IP-Einstellungen 2u
beziehen

(%) Folgende |P-Adresse vanwenden:

=
5 3l
£l

192 . 168 .

Subnetzmaske: [T255 25

Standardgateway | 192.188. 0 . 1 |

(%) Folgends DNS-Serveradressen venwenden:

Bevorzugter DNS-Server: 213.191 . 74 . 18

Alternativer DNS-Server 2319 .74 19 |

4. Activate Use the following IP Address. Enter the IP
address, subnet mask and gateway according to the
settings in the NDL 485. The NDL 485 has two IP
addresses: one is the fixed IP adress 192.168.111.1.
This IP address cannot be changed. The second IP
address can be changed by the user. Please refer to
the label on the data logger for its default settings.
The last entry of the IP address must be different
from the setting of the data logger. All other settings
must be setidentical to the data logger.

Example:
Data logger: 192.168.0.31
PC: 192.168.0.104

5. Click Ok to accept the settings.

EXTENDED FUNCTIONALITY
(RESEARCH MODEL)

The following chapters describe the extended function-
ality provided by the data logger blueberry NDL 485
research. Please refer also to the part Technical Data
for differences between the models basic (partNo. 0102)
and research (partNo. 0103).

The main features of the blueberry NDL 485 research
are:

* Higher sampling rate (10 Hz)
e Median function for statistics

* Larger data memory (128 MB standard, expandable
to up to 1 GB)

* Generation of realtime diagrams

e Automatical data transfer via FTP

Displaying Diagrams

The NDL 485 research generates time series plots of ac-
tual measured values and displays them as diagrams. The
user defines which measurement channels are plottet
and in which order the diagrams are displayed. The texts
for title and y label of the diagram axes are taken from
the name of the measurement function: the first part of
the function name is used as diagram title, the second
partis used asy axis label. Firstand second part must be
separated by a space character. We recommend to write
function names as Value (unit).

Example:
relFeuchte (%rF) = 100 * a4

The diagram titel for this function is relFeuchte, the y
axis labelis (%rF).

Select Diagrams to display the diagrams.

To define the diagram options select Setup > Diagrams.
Enter the index of the channels to be plottet. The index
corresponds to the line number in the table of measured

values. Separate more than one entry by space charac-
ters. Click OK to save the settings.
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1) Wilmers Messtechnik - Networked Data Logger NDL485 - Opera

Datei Bearbeiten  Ansicht Lesezeichen ‘Widgets Extras  Hife
]"‘_-']Neuer Tab

NDL 485
Date: %gééiglﬁ Temperatur
Digital Tnputs [14]24|34|4» A
gg:ﬂts 1e[26(30/48| ~
;I'Eg;peratur 2.9 Ton —
! ES,JD.EFG;JChte —— = ¥‘m.rmm >
Luftdruck (hPa)|1019.79
l(J\\:;ersorgung 13.761
pDisplay 69.79

28h

Luftdruck

¢hFa)

Realtime Data Diagrams

Diagrams are displayed in alphabetical order. Please add
the appropriate number of 0 characters in order to deter-
mine the display order.

Example:

entered items: 1520 12
=>displayorder: 1 12 20 5
Example:

entered items: 001 005 020 12

=> display order:

]‘j Neuer Tab

1520 12

14 Wilmers Messtechnik - Networked Data Logger NDL485 - Opera

Datei Bearbeiten Ansicht Lesezsichen Widgets Extras  Hilfe

26.11.2007
Date:
al€iso50:25 Plot Setup | —
Function selection  ooaos12
Digital Inputs |1.2535/45 (List fl4ctjon ifdexes 1 2 ..,
gigtitalt 1420|3544 Shorttime Diagrams
I FRED Diagram Width 400 pivglfr|
Temp (°C) 22.74 st ;
Hum (%RH) 56.33| Bttt A6t pimEt
uSupply (V) 13.68| ~Fme Farge LEVE =
load 0.46
period (s) 0.2
: OK | Reset

Setup for Realtime Data Diagrams

Shorttime Diagrams

Shorttime diagrams display a time series of the samples.
Please enter the width of the diagrams in pixels or enter
disabled if you do not want to display shortime diagrams.

Statistics Diagrams

Statistics diagrams display a time series of the statistics.
Please enter the width of the diagrams in pixels or enter
disabled if you do not want to display statistics diagrams.

Please enter the length of the time axis of the statistics
diagrams in the field Time Range.

&

Shorttime and Statistics Diagrams
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Transmitting Measured
Data via FTP

The NDL 485 (only partNo. 0103) sends measured data
automatically via FTP to a website or to a data file server.
Please first setup the Internet integration via DSL or
GPRS.

Select Setup > FTP/Mail.

fList mail recipients here, Separated by spaces.)

¥ou can Not activate mall sending, if an archive Folder 15 speafied

Setup: FTP Data Transmission (only partNo. 0103)

Enter the URL of your FTP server in the field FTP Server.
Enter the destination folder and access code and click 0K
to save the settings.
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ANNEX

Technical Specifications

Model NDL 485 basic NDL 485 research
PartNo. 0102 0103
Measuring Inputs
Digitalinputs
Analogue inputs
Additionalinputs via INPUT modules

(8 x AIN/DIN per module)
Serialinputs RS485, half-duplex, optional RS232
Digital Measuring Inputs (DIN1 .. DIN6)
Measuring range frequency 0 .. 2,000 Hz

counter0..2,000 Hz
status HI / LO
Resolution 0.01 Hz
Accuracy frequency +0.1%
counter + 1 pulse
Signal level HI=>2.5V
LO=<0.7V
or potential free switch closure
Inputimpedance >20 kQ
Analogue Measuring Inputs (AIN1 .. AIN6)
Measuring range 0..10V
Resolution 16 Bit (0.2 mV)
Accuracy +0.1% of reading + 1 mV
Inputimpedance >1 MQ
Measuring Functions NDL 485 basic NDL 485 research
Measuring interval 1s..24h 0.1s..24h
Statisticinterval 1s..24h 0.1s..24h
Statistic funcions mean value mean value
(arithmetic + vector), (arithmetic + vector),
standard deviation standard deviation
(arithmetic + vector), (arithmetic + vector),
minimum, maximum, sum minimum, maximum, sum, median

Data memory for 32 MB 128 MB, expandable to up to 1 GB,
statistic time series non-volatile ring buffer non-volatile ring buffer
Data memory for 32 MB
samples non-volatile ring buffer
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Communication
Data interface

Remote data transfer

Automatical data
transmission

Internetintegration
Userinterface
Graphical data
display

Display

Power Supply

External
power supply

Internal
power supply

Power consumption
Sensor excitation EXC

Switching outputs
DOUT1 .. DOUT4

Mechanic and Operation Conditions

Casing

Connections
Temperature range

NDL 485 basic NDL 485 research

RS232interface,
1,200 .. 115,200 baud,

RS485 interface, half-duplex,
1,200 .. 115,200 baud,
Ethernetinterface (LAN), 10 MBit/s,
optional MODBUS-TCP protocol

GSM, GPRS, DSL, ISDN router

via eMail via eMailand FTP

via GPRS or DSL
web interface, Internet browser

- realtime diagrams of measured values,
optional custom specific graphical display

5..24VDC

typ. 600 mW (50 mA @ 12 V)
5..24 VDC switched, max. 500 mA

4 switching outputs, max. 300 mA,
HI = supply voltage, LO=0V,
time or event triggered

65 x 105 x 127 mm, IP20
top-hat rail housing, anodized aluminium

screw terminals, connectors
-40..470 °C
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] (]
CE Compliancy Declaration
Based on test report no. EMV-08/8117-1 of 22.07.2008
Manufacturer: Wilmers Messtechnik GmbH
Hammer Steindamm 35
D-22089 Hamburg / Germany
Product: Data logger blueberry NDL 485

Part numbers: 0102 (basic)
0103 (research)

Applied standards:
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Index C
calibration 13
Symbols Casing 38
CC1 21
=16 CC2 21
! (NOT operator) 16 Character Delay 19
#AA\r (poll command) 20 column headers 10
# (last value operator) 17 comma separated ASCII files 10
% (modulo operator) 15 compact 26
() 17 Comparison 15, 16
<15 comparison 15, 16
<= 16 Connections 38
== 16 constant current supply 21
> 15 coordinate system 13
>= 16 cos 15
~ 15 Cosine function 15
0102 (NDL485 version) 37 counted pulses 18
0103 (NDL485 version) 37 counter 20
10.1.1.1 (IP address) 29 crosspatch cable 6, 22
192.168.111.1 (fixed IP address) 34 crosspatch Ethernet cable 5
CSV data file 12
CSVfile 10
A
abs 17 D
Accuracy 37
actual measured values 8 damped value 17
addition 15 data format 10, 21
address 20 data memories 10
admin 29 Data memory 37
AIN1 20 Date 22
alignment 13 DAY 19
analogue measurementinputs 20 DAYTIME 18
analog (poll command) 20 decimal 21
AND (operator) 16, 21 Decimal delimiter 10
APN (GPRS Access Point Name) 23 delete measured data 29

Deleting Measured Data 31
diagrams 34

B diagram titel 15
dial-in 27
Barometric pressure 21 dial-in connection 23
basic (NDL485 version) 37 digital (poll command) 20
Baudrate 19 digital measurementinputs 20
baud rate 19 digital outputs 21
blueberry GSM Module 27 DIN1 20
blueberry INPUT Module 5, 20 disconnect 29
Boolean Operators 15 division 15
boolean operators 15, 21 Documentation 12
browse 27 documentation 12
browser 29 DOUT1..DOUT4 21
BUSY indicator 5 download of measured data 10, 35
BUSY LED 6, 33 DSL 12

Dynamic DNS 23
Dynamic DNS Service 24
dynamic IP address 23, 24
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dyndns.org 23, 24
DynDNS Account 24
DynDNS host 25

E

e-mail 12

e-mail address 12
elevation 12
else 16

Ethernet 22

EXC 5, 14, 20
Excitation 14
excitation voltage 14
EXCindicator 5
Exponent 15
exponent 15

F

FileZilla 31

Filtering of Invalid Samples 16
firmware update 32
firmware version 30, 33
fixed IP adress 34
flashing light 18, 21
floating point numbers 8
frequency 18, 20
FTP/Mail 12

FTP client 31

FTP data transfer 36

FTP Server 36

function name 14

G

gateway 34

geographical coordinate system 13
Geographical Position 12
GPRS 23

GPRS connection 29

GPRS Internet Connection 23
GPRS mode 23

gradient 18

GSM mode 23, 29

GSM Module 23, 27

GSM provider 23

guest 29

H

half-duplex 37
Help 30
Help > About 33

Help > About > Maintenance 32
Help > Manual 30

help function 30

hex 21

hexadecimal values 21

HOUR 19

hysteresis 21

I

if 16

IN1 20

index 32

Inputimpedance 37
inputimpedance 37

INPUT Module 5, 18, 19, 20
int 17

integration 18

Internet 22, 23, 26
Internet access 26
Internetintegration 12, 36
Internet server 27

IP address 22, 23, 29, 34

L

LAN 22
latitude 12

n 15
logarithm 15
login 6, 8
login dialog 26
longitude 12

M

M12x1 connector 5

mail addresses 12

Mail Server 12
Maintenance 32

Manual 30

manual 30

Marking of Invalid Samples 16
mast type 13

MDA 26

measurement function 14
measurement functions 19
measurementinputs 20
measurement process 12
measurement site 12
measure period 14
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MINUTE 19

mobile access 26
mobile browser 26
mobile device 26
Mobile Phone 26
mobile phone 26, 27
MODBUS 38
modem 27

modulo division 15
MONTH 19
mounting booms 13
multiplication 15

N

Name of the measurement site 12
nan (nota number) 16, 19
Natural logarithm 15

NDL 485 basic 37

NDL 485 research 37

Network 22

network 22

network settings 33

NOT operator 16

0

obstacles 12

Onboard temperature 21
online manual 30

Opera 27

operamini 27
orography 12

OR (operator) 16

P

Password 24

password 23, 29

PC network (LAN) 22
PC Network Settings 33
PERIOD 18

period 10

pocket PC 26

poll address 20

Poll Command 19

poll command 19

poll pause 19

Power consumption 38
Power Supply 38
power supply 20, 21
PPP 27

pressure sensor 21
previous measurement 18

previous value 17
public APN 23
pulses 18

R

realtime access 23

realtime clock 22

realtime diagrams 14
Rebooting 30

Remote Access 24

Remote Access via Internet 24
remote connection 27, 28
remote data transmission 23
research (NDL485 version) 37
Resolution 37

Retry 19

ring buffer 37

roughness 12

round 17

Rounding Operators 17
RS232 5

RS485 37

RS485, half-duplex 37

RS485 bus 19

RS485 bus wiring 6

S

SECOND 19

sensors 13

sensor characteristics 14
sensor mounting booms 13
Serialinputs 37

serial number 10

serial numbers 13
Shorttime Diagrams 35
Signal level 37

sin 15

Sine function 15

Site Description 12
sonicanemometers 5, 19
statistical evaluations 14
Statistics Diagrams 35
statistics files 10
statisticinterval 14
status HI/ LO 37

subnet mask 34
subtraction 15
switching output 16
Switching outputs 38
synchronization 22
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T

TCP/IP 34

Technical Data 32
Temperature range 38
TIME 18

Time 22

timer 21

Time Info 18

time series plots 34
time server 22

time zone 22

U

Update 32

Updating the Firmware 32
Username 24

user admin 29

user guest 29

User Password 29

UTC 22

v

valid 16

Validity Check 16
validity check 16
variables 14, 18
vector 15

virtual channels 19
Voltage 20

w

web interface 8, 26, 29
web server 23
WEEKDAY 19

wind speed vector 15
wiring of RS485 bus 6

Y

YEAR 19
YEARDAY 19
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