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Introduction
The blueberry COMPACT is an all-in-one data logger 
system. It features digital and analogue measure-
ment inputs for the connection of sensors providing 
pulses, voltage or current signals. A serial RS485 
bus interface allows the connection of sonic an-
emometers and other sensors with RS485 interface. 
The blueberry COMPACT is integrated into the Inter-
net via GSM/GPRS or DSL. It sends measured data 
automatically via E-Mail and FTP. The Ethernet port 
and the integrated web interface provide fast data 
transmission to a PC or a LAN and easy access via a 
web browser. 

Getting Started

Scope of Delivery

The following components are supplied with the 
data logger blueberry COMPACT:

• Data logger in a rugged weatherproof enclosure

• Crosspatch Ethernet cable for local data connec-
tion

BUSY indicator
flashes every 2 seconds 
in normal operation

RS232
serial port for connection 
to the integrated GSM/
GPRS modem or to an 
external modemry GSM 
module

LAN
Ethernet port for connec-
tion to a PC, a router or a 
PC network

POW + GND
solar power supply 

connection 
POW = (+), GND = (–)

DIN1 .. DIN10
digital measure-

ment inputs for TTL 
or small AC signals

AIN1 .. AIN6
analogue measurement 
inputs for 0..10V signals, 
potentiometric wind vanes, 
Pt100 temperature sensors, 
thermopile pyranometers

RS485 port + excitation
pin 1 = n.c.
pin 2 = EXC (+)
pin 3 = GND
pin 4 = RS485+
pin 5 = RS485–

� �

��
�

QR code
Scan the QR code with a 
smartphone to get fur-
ther information about 
the 
blueberry COMPACT 
(manual, data sheet, bro-
chures, wiring diagrams, 
firmware updates)

Display button
press the but-
ton to activate 
the LED display 
for 3 minutes

LED display
indicate the status of the 
measurement inputs and 
of the power supply
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5. Plug the crosspatch cable into the LAN connec-
tion at the front plate of the blueberry COMPACT. 
Connect the crosspatch cable to the Ethernet in-
terface of a PC or notebook.

6. Adapt the network settings of the PC to the IP 
address of the blueberry COMPACT. The network 
parameters are indicated on a label at the bot-
tom of the housing of the data logger.

7. Start your Internet browser, enter the IP address 
of the data logger into the address field and type 
<enter>. Enter the access code into the login 
dialog:

 user:   admin
password: ****   (=admin password)

8. You should now see a screen similar to the image 
below.

9. Connect sensors or test signals to the terminals 
at DIN1 .. DIN10 and AIN1 .. AIN6. Enter the 
measurement functions according to chapter 
Measurement Setup of this manual.

Delivered within a complete measurement system 
the blueberry COMPACT usually provides a wiring 
diagram attached to the lid of the shelter box. The 
blueberry COMPACT includes built-in overvoltage 
protection for all terminals. The following image 
shows the blueberry COMPACT data logger with 
backup batteries connected, the GSM module that 
integrates the data logger into the Internet via 
GPRS.

Installation

Please proceed as follows to install and to test the  
blueberry COMPACT data logger:

1. Install the blueberry COMPACT to the mast. 

2. Remove the battery cover plate and insert the 
two sealed lead batteries and connect them 
to BAT1 and BAT2. Please use only the battery 
types stated on the label in the data logger shel-
ter box. 

3. Insert the battery cover plate and tighten the 
fixing screw.

NOTE: Never disconnect the backup batteries from 
the data logger when a solar module is connect-
ed. This may damage the data logger.

4. Connect a 12V solar module (60 Wp) to the POW 
(+) and GND (–) terminals of the terminal strip. 
The BUSY indicator LED is steadily alight. The 
boot process takes approx. 2 minutes. The data 
logger is fully operating when the BUSY LED 
flashes in regular intervals of 2 seconds.

NOTE: Never connect a solar module to the data 
logger before batteries are connected. This may 
damage the data logger.

 Optionally, a 24 VDC (15..30 VDC / max. 5A) pow-
er supply can be connected instead of the solar 
module. The integrated charge controller will 
charge the backup batteries working as a UPS.
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QR Code (Infos + Manual)
Scan the QR code with your smartphone in order 
to get further information about the blueberry 
COMPACT. The QR code links to a website that pro-
vides technical data, manual, wiring schemes, bro-
chure, application notes and firmware updates for 
the data logger. The website is also available under 
the following link:

http://wilmers.com/blueberry-compact

LED Display
The blueberry COMPACT provides an array of LEDs 
that indicate the status of the measurement inputs 
and of the power supply. Press the DISPLAY button 
to activate the LEDs for 3 minutes.

Significance of the LEDs

LED Off Red Green

POW Supply 
Voltage 

<11 V

Supply 
Voltage 
11..16 V

Supply 
Voltage 

>16 V

BUSY - Received 
an invalid 
telegram

Received 
a valid 

telegram

AIN (top) - Analogue 
Excitation 

On

Analogue 
Excitation 

Off

CC (top) - Constant 
Current On

Constant 
Current Off

DIN (top) - Digital 
Excitation 

On

Digital 
Excitation 

Off

AIN1..6 <0.05 V 0.05..0.5 V >0.5 V

CC1..6 <0.1 mA 0.1..0.9 mA >0.9 mA

DIN1..10 - High Low

BAT1 <11 V 11..13 V >13 V

BAT2 <11 V 11..13 V >13 V

POUT - On Off
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Web Interface

Introduction

The user surface of the data logger 
blueberry COMPACT is a web interface. Configura-
tion of the data logger, display and download of 
measured data requires a web browser (e.g., Firefox, 
Opera, Internet Explorer, Safari). The data logger is 
connected to the PC via local Ethernet connection 
or via remote data transmission (GSM, GPRS, UMTS, 
CDMA, DSL, Satellite).

Start the browser, enter the IP address of the data 
logger into the address field and type <enter>. 
Enter the access code into the login dialog. The 
blueberry COMPACT provides two user levels: 

The user guest is allowed to display actual measured 
values and configuration settings and to down-
load measured data. He cannot delete any data or 
change configuration settings. He is only allowed to 
set date and time. 

The user admin has all rights. In addition to the 
guest rights he is allowed to delete measured data 
and to change the configuration.

Data Display

Displaying Actual Measured Values

The left part of the screen displays in a table all 
actual measured values. When the data logger is 
connected locally these values are automatically 
updated. At remote connections, please click on 

Refresh Data View below the data table in order to 
update the display. Measured values are displayed 
as floating point numbers with the significant 
number of characters after the decimal point.
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Data Transfer

Downloading Measured Data

The blueberry COMPACT contains two ring buffer 
data memories; one for the statistics, one for the 
samples. Actual data overwrite the oldest data lines 
which makes the deletion of the memory unneces-
sary. 

Select Archive in order to display a list of all stored 
statistics files. The blueberry COMPACT creates 
one statistics file per day. These files contain time 
series of the statistical evaluations of the samples. 
The file name contains the index of the actual meas-
urement, the date and the tag stat for ‚statistics‘. 
The data logger increments the index every time 
the configuration is changed or the data logger 
reboots. 

Example:  000024_2004-03-19_stat.csv

Select HighRes in order to display a list of all stored 
samples files. The blueberry COMPACT creates one 
CSV file per hour. These files contain time series of 
all measured samples. The file name contains the in-
dex of the actual measurement, date and time, and 
the tag meas for ‚measurement‘.

Example:  000024_2004-03-19_15_meas.csv

Downloading measured data works like a download 
from an Internet site: click with the right mouse 
button on a file, select Save file as... from the pull-
down menu, enter the destination path and click 
OK. 

CSV files can be imported into data analysis soft-
ware like WAsP or WindPRO. Double-clicking on the 
CSV file opens it directly in MS-Excel.

Data Format

The blueberry COMPACT stores measured data as 
comma separated ASCII files (CSV). Each data file 
contains a header which indicates information 
about the data logger and the measurement config-
uration: serial number of the data logger, index of 
the measurement, site info, measurement functions 
and parameter settings. The header is followed by 
an empty line and a line with column headers. The 
measured data lines have the format: date, time, 
period, measured values. Decimal delimiter is a dot 
(e.g., 2.564), columns are separated by a comma.
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Transmitting Measured Data 
via E-Mail

The blueberry COMPACT sends measured data auto-
matically via e-mail every day at 0:00. The CSV data 
file of the previous day is attached to the e-mail. If 
several files have been created since last e-mailing 
(e.g., because of configuration changes or reboot-
ing of the data logger) all closed files are send. Each 
file is attached to a separate e-mail. Please first 
setup the Internet integration via GPRS or DSL.

To setup the e-mail data transfer select  
Setup > FTP/Mail. 

Enter the URL of your mail server (SMTP server) in 
the field Mail Server. If your mail server requires 
authorization enter the user name and password. 
Enter the mail addresses in the field Recipient(s). 
Separate more than one mail address by space char-
acters. 

Select yes at Test Mail Transfer now.

Click OK to save the settings. If the Test Mail option 
is active the blueberry COMPACT now sends a test 
mail to all recipients. A message displays the result 
of the test mailing. Please check whether the mail 
has been sent without errors. Otherwise, please 
check the correctness of your mail settings.

Site Description
The blueberry COMPACT saves information about 
the measurement. They are stored in the header of 
each CSV data file for proper documentation of the 
measurement process.

To enter the information about the measurement 
select Setup > Site Description.

Documentation of the measurement includes the 
following information:

Name    Name of the measurement site

Description  Description of the measurement lo-
cation and its environment. Please 
enter here orography, roughness, 
obstacles and other elements hav-
ing an impact on the measurement 
result.

Geographical Position Enter here latitude, lon-
gitude and elevation of the meas-
urement site.

Other Information  Use these universal input 
fields to enter all supplementary 
information about the measure-
ment: 
e.g., geographical coordinate 
system, mast type, mast dimen-



Data Logger  blueberry COMPACT Wilmers Messtechnik GmbH 

- 12 -

Data Logger  blueberry COMPACT Wilmers Messtechnik GmbH 

- 13 -

sions, type, serial numbers and 
calibration numbers of the sensors, 
dimensions and alignment of sen-
sor mounting booms

Measurement Setup

Measurement Parameters

To define measurement parameters or sensor char-
acteristics select Setup > Measurement.

Measure Period Measure period is the time interval 
in which the data logger records actual measu-
red values (samples) from all sensors. 

Statistic Interval Statistic interval is the time 
interval in which the data logger performs a 
statistical evaluation of the samples and stores 
the results in the memory. The variables a1..an 
correspond to the first to nth value of the data 
line sent by the first sensor. The variables b1..bn 
correspond to the values sent by the second sen-
sor and so further.

Excitation  defines how long the sensor constant 
current source (CC) is switched on before the 
blueberry COMPACT sends a poll command. Se-
lecting always on switches the excitation voltage 
continuously on. The blueberry INPUT Module 
requires this setting as it needs a warm-up time 
of approx. 5 seconds.

Measurement Functions (Standard 
Setup)

To add a new measurement function enter a func-
tion name in the field Name, check the required 
statistical evaluations and enter the measurement 
function. Type <enter> to transmit the settings to 
the data logger. 

Function Names

Variable names may principally contain umlauts 
(ä, ö, ü) and special characters like comma (,) and 
period (.). If function names are used as variables 
in further measurement functions the first part of 
the function name may however only contain the 
following characters: A..Z, a..z, 0..9, _. The second 
part, i.e. the part after the first space character is 
used as axis label for realtime diagrams. We rec-
ommend to use the following syntax for function 
names: Value (unit).
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Frequency AC for small AC frequency signals 
[Hz], from wind sensors like R.M.Young Wind 
Monitor

Counter if you want to count pulses, e.g., from a 
tipping bucket rain gauge.

Select the Slope and Offset for the transfer func-
tion of the respective input. Take these values from 
the sensor data sheet or from the calibration certi-
ficate for individually calibrated sensors.

Select the option from the Option list:

--- if no option required.

no offset when zero suppresses the offset for 
0 Hz frequency signals. Select this option for 
anemometers because otherwise wind speed 
will record the anemometer offset value at 
zero wind speed.

Example:
vWind80m (m/s) = 0.04727 * b10 + 0.264 * (b10>0)

The first part of the function name can be used as 
variable vWind80m in further measurement func-
tions. 

The diagram title for this function is vWind80m, the y 
axis label is (m/s).

Digital Measurement Inputs (DIN1..10)

The table Digital Inputs provides one line for each 
of the 10 digital measurement inputs DIN1..10. 

Enter the function name into the field Name.

Select the signal type from the Type list:

--- if the input is not used.

Frequency TTL for TTL pulse frequency signals  
[Hz], from anemometers like Thies First Class, 
Vector A100, Heval ECONOMY or RISØ reed 
switch anemometer with external pullup re-
sistor.
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Analogue Measurement Inputs (AIN1..6)

The table Analog Inputs provides one line for each 
of the 6 analogue measurement inputs AIN1..6. 

Enter the function name into the field Name.

Select the signal type from the Type list:

--- if the input is not used.

Voltage provides the voltage between AIN+ and 
AIN– of the respective analogue input. If the 
sensor does not provide a reference for the 
measurement signal AIN– must be connected 
to GND.

Temperature (Pt100) for passive Pt100 temper-
ature sensors connected in 4-wire technique. 
The blueberry COMPACT automatically con-
verts the voltage into temperature according 
to IEC751.

Potentiometer 0..1 provides the dimensionsless 
value of a potentiometer.

Direction 0..360° provides the 0..360° wind 
direction of a potentiometric wind vane con-
nected in 4-wire technique. Direction value 
increases when the vane rotates clockwise. 

Direction 360..0° provides the 0..360° wind 
direction of a potentiometric wind vane con-
nected in 4-wire technique. Direction value 
increases when the vane rotates anti-clock-
wise. 

Resistance provides the electrical resistance 
[Ω] of a resistor connected in 4-wire tech-
nique. Use this option for PTC or NTC tem-
perature sensors.

Select the Slope and Offset for the transfer func-
tion of the respective input. Take these values from 
the sensor data sheet or from the calibration certi-
ficate for individually calibrated sensors.

Measurement Functions (Expert 
Setup)

The Expert Setup allows input of virtual measure-
ment functions similar to the data logger blue-
berry NDL485.

To add a new measurement function enter a func-
tion name in the field Name, check the required 
statistical evaluations and enter the measurement 
function. Type <enter> to transmit the settings to 
the data logger. 

Maximum length of the measurement function 
including function name and statistics options is 
1023 characters or 64 elements. Each variable or 
operator counts as one element. Please use the 
following elements to built the measurement func-
tion:

Arithmetic Operators

+ Addition
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Example: Vector Component

vWind (m/s)  = 0.04752 * b8 + 0.224 * (b8>0)
dirWind (°)  = (360 * (a1-a2)/a1) % 360
vEast (m/s)  = vWind * sin (dirWind)

The multiplication of the wind speed with 
the sine of the wind direction results in 
the eastern component of the total wind 
speed vector.

cos Cosine function. The angle must be defined in 
degrees. 

Example: Vector Component

vWind (m/s)  = 0.04752 * b8 + 0.224 * (b8>0)
dirWind (°)  = (360 * (a1-a2)/a1) % 360
vNorth (m/s)  = vWind * cos (dirWind)

The multiplication of the wind speed with the 
sine of the wind direction results in the north-
ern component of the total wind speed vector.

ln Natural logarithm 

Example: log = ln c7

  

 Boolean Operators

> Comparison superior to. The result is 1, if the 
condition is true, otherwise it is 0.  

Example: Calibrated Cup Anemometer

ws30m (m/s)= 0.04827 * c2 + 0.19 * (c2 > 0)

This function suppresses the wind speed offset 
when the frequency is 0. Otherwise, even at to-
tal calm the data logger would indicate a wind 
speed of 0.19 m/s.

< Comparison inferior to. The result is 1, if the 
condition is true, otherwise it is 0.  

– Subtraction or minus sign. If a – is used to 
characterize a negative number at the begin-
ning of a measurement function or after an-
other operator the number must be put into 
parenthesis.

Example: Negative Numbers

HumAir (%RF)  = (–25) + 62.5 * a5
vSonic (m/s)   = e2 else (–9999)

* Multiplication

/ Division

^ Exponent, real number

Example: Length of a Vector

uSonic (m/s)= d2
vSonic (m/s)= d3
wsHorizontal (m/s)=(uSonic^2 + vSonic^2)^0.5

This function converts the u and v components 
of a sonic anemometer to horizontal wind 
speed.

 % Modulo division. This operator provides 
the positive residue of a division. Unlike 
the general modulo operator defined for 
integer numbers, the blueberry COMPACT 
modulo operator is based on real (floating 
point) numbers for parameters and for the 
result. The second parameter of the % func-
tion must be positive (a % b with b>0).

Example: Wind Direction 

Dir (°) = (360 * b1 / b0 + 126) % 360

The measured wind direction value with an 
offset correction of 126 degrees is projected 
into the range of 0..360°.

 
sin Sine function. The angle must be defined in 

degrees. 
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Example: Status from Threshold Value 

Temperature (Celsius) = 20 * a4 - 40
Frost = Temperature < 0

The comparison with a threshold value creates 
the status signal 1 = frost / 0 = no frost.

== Comparison equal. The result is 1, if the con-
dition is true, otherwise it is 0.

Example: 

identic (1=equal)  = (0.2 * a2) == 1.2

This function compares a measured value with 
a constant. 

!= Comparison not equal. The result is 1, if the 
condition is true, otherwise it is 0.

Example: 

differentStatus (1=different) = c1 != c2 
with third poll command:  DIN

This function compares the status of digital 
inputs DIN1 and DIN2.

>= Comparison superior or equal. The result is 1, 
if the condition is true, otherwise it is 0.

Example: 

condensation = Humidity >= 100.1

Relative humidity of more than 100 %RH is con-
sidered as condensation.

<= Comparison inferior or equal. The result is 1, 
if the condition is true, otherwise it is 0.

  ! NOT operator. This operator inverts the logi-
cal level of a boolean value.

Example: 

DOUT2 = ! a1 
with first poll command:  DIN

Switching output DOUT2 is set active if the sta-
tus signal at digital input DIN1 is low.

valid This operator checks whether a value is a 
valid number. The result is 0, if the value is 
nan, otherwise it is 1.

Examples: Validity Check

checkValue (1=Ok) = valid (2.45 * a1)  
error (1=invalid)   = ! valid (2.45 * a1)

  if This operator checks whether a value is not 0 
or nan. The if operator is typically combined 
with the else operator.

Example: Output Limitation

Hum (%RH) = 100*a4 if (100*a4<=100) else 100

In case of condensation, some thermo 
hygro sensors show measured values above 
100 %RH. This function limits the output of 
relative humidity to 100 %RH.

Example: Validity Check

vCup (m/s)  = 0.253 * b8 + 0.22 * (b8>0) 
vValid (m/s)  = vCup if ((vCup>=0)*(vCup<90))

This function defines a range of 0 to 90 m/s for 
valid wind speed values. The result of vValid is 
vCup if vCup is within this range, otherwise it 
is nan.
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else replaces a value if the value is nan.

Example: Filtering of invalid Samples

uSonic (m/s) = d2 else #uSonic else 0

If the sonic anemometer returns an invalid 
value, the data logger will keep the previous 
value. If the previous value is also invalid the 
result is set to 0.

Example: Marking of invalid Samples

relHum (%RH) = 100*a2 else (–9999)

Invalid samples (nan) are stored as –9999.

Combining boolean Results:

The multiplication operator * corresponds to the logical 

AND operator. The addition operator + corresponds to 

the non exclusive OR operator.

Example: AND, non exclusive OR and exclusive OR

AND = (a2>=0) * (a2<=100)  

OR  = (a2<0) + (a5<0) 

XOR = ((a2<0) + (a5<0)) == 1

Rounding Operators

abs provides the unsigned floating point value of 

a signed value.

Example: 

alwaysPositive = abs (125 * g7 –75)

int removes the decimal part of the floating 
point value.

Example: 

intValue = int (–2.45 * d2 + 100)

round rounds the floating point value to the nearest 
integer (up or down).

Example: Display without Decimals 

LowResDir (deg) = round((360 * a2/a1) % 360)

This function displays the wind direction with-
out decimals.

Example: Fixed Number of Decimals

Radiation = 0.01 * round(100 * (2.645*a2–25))

The floating point function result is reduced to 
2 decimals.

Other Operators

( ) Parantheses structure the function elements 
and determine the calculation sequence. 

# provides the previous value of the measure-
ment function.
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Example: Cumulated Rainfall

actualRain (mm) = 0.1 * b3 
cumulRain (mm) =  
(#cumulRain + (actualRain   else   0))
else actualRain else 0

These two functions record actual and cumu-
lated rainfall. cumulRain adds the actual rain-
fall to the previous cumulated rainfall. When 
the measurement starts #cumulRain is invalid 
because no previous value exists. The result 
is then replaced by actualRain. If this value is 
also invalid the result is set to 0. The else op-
erator defines the starting value and prevents 
the cumulative value from being reset in case 
of an invalid value of actualRain.

Example: Low Pass Filter

noisy  = 62.5 * a6 – 55
damped  = (0.1 * noisy + 0.9 * #damped) else noisy

This function implements a low pass filter that 
smooths a noisy value. damped provides a 
damped value of the actual measurement value 
provided by noisy.

Operator Summary

The following table lists examples of results based 
on the operators with different parameters.

Results for: a = ...

   –2.7183 0 +2.7183 nan

a else b –2.7183 0 2.7183 b

b if a b nan b nan

b if a else c b c b c

valid a 1 1 1 0

! a 0 1 0 0

a > 0 0 0 1 nan

a < 0 1 0 0 nan

a == 0 0 1 0 nan

a != 0 1 0 1 nan

a >= 0 0 1 1 nan

a <= 0 1 1 0 nan

a % 1 0.2817 0 0.7183 nan

a % 0.01 0.0017 0 0.0083 nan

a–(a%0.01) –2.72 0 2.71 nan

abs a 2.7183 0 2.7183 nan

int a –2 0 2 nan

round a –3 0 3 nan

ln a nan nan 1.0000 nan

Variables

Variables  The variables a1..an correspond to the 
first to nth value inside the data line 
sent by the first sensor. The blueberry 
INPUT module supplies the voltages 
of all inputs in Volt as well as the fre-
quency in Hertz and the counted puls-
es. In addition to the variables, oth-
er function names can be used inside 
a measurement function. They must 
be defined former to the function in 
which they are used as a variable. A # 
character in front of a function name 
provides the measurement value of the 
previous measurement.
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Example: Temperature Gradient

Temp (°C)  = 100 * a3 – 30
deltaTemp (K/s)  = (Temp – #Temp) else 0

deltaTemp provides the temperature 
gradient between 2 samples.

 

Predefined Variables (internal Sensors)

The following predefined variables provide val-
ues from the senors that are integrated into the 
blueberry COMPACT.

PAIR1..2 provides the barometric pressure and 
internal temperature measured by the 
integrated pressure sensor.

Example: Barometric Pressure

pBaro (hPa) = PAIR1 
TempShelterbox (°C) = PAIR2

POWER1..4 provides infos about the power supply.

Example: Power Supply

uSolar (V) = POWER1 
uBattery1 (V) = POWER2 
uBattery2 (V) = POWER3 
iSolar (A) = POWER4
PSolar (W) = POWER1 * POWER4  

This functions provide voltages of the 
solar module and the two backup bat-
teries. Multiplication of voltage and 
current calculates the charging power of 
the solar module. 

Predefined Variables (Time Info)

The following predefined variables provide time 
information.

PERIOD provides the actual measurement pe-
riod in seconds.

Example: Integration over Time

flow (m3/s)  = 125 * b2 
volume (m3)  = flow * PERIOD

The function volume uses PERIOD to 
intergrate actual flow into a volume.

 

TIME provides the time in seconds since 
1.1.1970 00:00:00. 

DAYTIME provides the time in 
seconds since 00:00:00 of the current 
day.

Example: Flashing Light

DOUT3 (flash) = ! (DAYTIME % 10)  

This function flashes a signal lamp every 
10 seconds.

YEAR provides the actual calendar year as 4 
digit integer (e.g., 2007). 

MONTH provides the actual calendar month as 
integer (January = 1 .. December = 12). 

Example: Season dependent Factors

factor = 0.26*(MONTH<4) + 
0.22*(MONTH==4) + 0.25*(MONTH>4)

This function selects a factor depend-
ing on the month. Some algorithms for 
determination of potential evaporation 
(e.g., HAUDE) use empirical factors that 
vary with the season.
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nent (sensor, INPUT Module or data 
logger) at a time to transmit data. 
All other components work in re-
ceiver mode. The poll pause allows 
to switch from transmitter to re-
ceiver mode.

Timeout  defines the maximum time the 
blueberry COMPACT waits for the 
answer to a poll command. If the 
polled component does not answer 
the poll command will be repeated 
once or several times depending on 
the value set for Retry. If no data 
was received the measured values 
are stored as nan („not a number“).

Poll Command Enter the poll command into the 
field Poll Command and click OK to 
save the setting into the data log-
ger. 

The following poll commands provide measured val-
ues from the blueberry COMPACT data logger itself:

Command: #100 f1f2f3f4f5f6f7f8f9f10\r

or                 #100 F\r 

Results:

Index Value Unit

1 Frequency of DIN1 Hz

2 Frequency of DIN2 Hz

3 Frequency of DIN3 Hz

4 Frequency of DIN4 Hz

5 Frequency of DIN5 Hz

6 Frequency of DIN6 Hz

7 Frequency of DIN7 Hz

8 Frequency of DIN8 Hz

9 Frequency of DIN9 Hz

10 Frequency of DIN10 Hz

DAY provides the actual calender day as 
integer (1 .. 31). 

HOUR provides the actual hour as integer 
(0 .. 23). 

MINUTE provides the actual minute as integer 
(0 .. 59).

SECOND provides the actual second as integer 
(0 .. 59). 

WEEKDAY provides the day of the week as integer 
(Monday = 1 .. Sunday = 7).

YEARDAY provides the day of the year as integer 
(1st January = 1).

Click OK to save the settings into the data logger. 
As the measurement functions represent virtual 
channels they are independent of the number of 
hardware inputs of the data logging system. The 
user can define an unlimited number of measure-
ment functions.

Data Polling

The  blueberry COMPACT sends poll commands 
through the RS 485 serial port and to the internal 
measurement interfaces. Each poll command pro-
vides a set of return values that are used as vari-
ables in the measurement functions. Please set the 
poll parameters as follows:

Baudrate  Select from the Baudrate list the 
baud rate of the serial port. The 
blueberry INPUT Module requires a 
baud rate of 19200.

Character Delay Select from the Character Delay list 
the delay between the characters 
sent by the blueberry COMPACT to 
the serial port. Some sensors (e.g., 
R.M.Young sonic anemometers) re-
quire character delays. The blue-
berry INPUT Module is polled with 
a character delay of 0.

Poll Pause  defines the delay between the last 
character of a data line received 
by the blueberry COMPACT and the 
sending of the next poll command. 
The blueberry INPUT Module re-
quires a poll pause of 50 ms. The 
poll pause is required because the 
RS 485 bus allows only one compo-
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Command: #100 v1v2v3v4v5v6\r

or                 #100 V\r 

Results:

Index Value Unit

1 Differential voltage at AIN1 V

2 Differential voltage at AIN2 V

3 Differential voltage at AIN3 V

4 Differential voltage at AIN4 V

5 Differential voltage at AIN5 V

6 Differential voltage at AIN6 V

Command: #100 s1...s12\r
or                 #100 S\r 
Results:

Index Value Unit

1 Single-ended Voltage at AIN1+ V

2...5 AIN2+...AIN5+ V

6 Single-ended Voltage at AIN6+ V

7 Single-ended Voltage at AIN1– V

8...11 AIN2–...AIN5– V

12 Single-ended Voltage at AIN6– V

The following poll command provides temperatures 
from Pt100 sensors connected as 4-wire circuit to 
the blueberry COMPACT: 

Command: #100 t1...t6\r
or                 #100 T\r 
Results:

Index Value Unit

1 Pt100 Temperature at AIN1 °C

2...5 ... °C

6 Pt100 Temperature at AIN6 °C

The following poll command provides the voltage 

ratio data from potentiometric wind vanes con-
nected as 4-wire circuit to the blueberry COMPACT: 

Command: #100 p1...p6\r
or                 #100 P\r 
Results:

Index Value Unit

1 Potentiometer ratio at AIN1 V/V

2...5 ... V/V

6 Potentiometer ratio  at AIN6 V/V

The following poll command provides absolute 
pressure (QFE) and internal temperature of the 
built-in barometric pressure sensor of the blueberry 
COMPACT:

Command: #100 m1m2\r
or                 #100 M\r  
Results:

Index Value Unit

1 Barometric pressure hPa

2 Internal temperature °C

The following poll command provides supply voltag-
es and charging current of the blueberry COMPACT: 

Command: #100 b1b2b3\r
or                 #100 B\r 
Results:

Index Value Unit

1 Voltage of the solar module at POW V

2 Voltage of the backup battery at BAT1 V

3 Voltage of the backup battery at BAT1 V

4 Charging current at POW V

Data Format Select the data format from the 
list: decimal reads the received 
data values as decimal floating 
point numbers. hex reads the re-
ceived data values as hexadecimal 
values and converts them into dec-
imal integer values 
(e.g., 8A ð 138).

Click OK to save all settings into the data logger.
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Digital Outputs (DOUT1..4)

The blueberry COMPACT provides 4 digital outputs. 
They represent switched power supplies that can be 
used to activate peripheric devices, like modems, 
sensor heatings, shelter box heating, beacon lights 
and alarm devices. Please refer to the technical data 
section for maximum load of the digital outputs.

The status of the digital outputs are defined as 
measurement functions. The name of the measure-
ment function must be DOUT1..DOUT4 for digital 
output 1..4. The respective digital output is set to 
HI if the result of the measurement function is 1 or 
higher. Otherwise it is set to LO. The status of the 
digital outputs are logged like normal measurement 
functions. Digital outputs can be switched depend-
ing on time or depending on measurement values.

Example: Time scheduled Switching

DOUT1 (0=Off 1=On) = (HOUR>=6) + (HOUR<18)

Switching output DOUT1 is set active from 6:00 to 
18:00 every day.

Alarm E-Mails

The blueberry COMPACT sends alarm e-mails at con-
ditions defined by the user.

The alarm conditions are defined as measurement 
functions. The name of the measurement function 
must be ALARMi where i is the index of the alarm. 
The number of alarms is not limited. The text of the 
function name is sent as e-mail when the result of 
the measurement function is 1 or higher. 

Example: Battery Monitoring

uBat1 (V) = POWER2
uBat2 (V) = POWER3
ALARM1 Battery Low = (uBat1 < 11.4) + (uBat2 < 11.4)

The data logger sends an alarm e-mail with the text 
Battery Low when the voltage of at least one of the 
backup batteries is below 11.4 V.

To set the e-mail alarm transfer select  
Setup > FTP/Mail. 

Enter the URL of your mail server (SMTP server) in 
the field Mail Server. If your mail server requires 

authorization enter the user name and password. 
Enter the mail addresses in the field Send Alarms 
to. Separate more than one mail address by space 
characters. 

Select yes at Test Mail Transfer now.

Click OK to save the settings. If the Test Mail option 
is active the blueberry COMPACT now sends a test 
mail to all data and alarm recipients. A message 
displays the result of the test mailing. Please check 
whether the mail has been sent without errors. Oth-
erwise, please check the correctness of your mail 
settings.
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Network Interface

Network Parameters

The blueberry COMPACT can be connected locally to 
a PC via crosspatch cable and it can be integrated 
into a PC network (LAN) by means of a standard Eth-
ernet cable. The IP address of the data logger has to 
be adapted to the network.

Select Setup > Network. 

Assign an IP address to the data logger. 

Enter the subnet mask required for your network 
type. If you are unsure about the subnet mask leave 
this field empty. In this case, the default subnet 
mask 255.255.255.0 is used. 

Enter the gateway and name server (DNS) of your 
LAN and click OK. The data logger uses the gateway 
to built up a connection to the Internet in order to 
send data via e-mail or FTP and to synchronize the 
internal realtime clock from the Internet.

Date and Time
If the blueberry COMPACT is connected to the In-
ternet the data logger updates its internal realtime 
clock automatically from an Internet time server. 
The blueberry COMPACT adjustes the clock to the 
time zone set by the user. 

Select Setup > Date & Time to set the parameters 
for realtime clock synchronization. Select the time 
related to UTC. Select the region where the data 
logger is installed. The blueberry COMPACT uses the 
time server the closest to its site in order to provide 
maximum accuracy. Optionally, select a time server. 
If you do not define a specific time server the blue-
berry COMPACT automatically selects a suitable 
server from a pool of time servers. Click OK to ac-
cept the settings.

If the data logger is not connected to the Internet, 
select Adjust Clock to set the realtime clock manu-
ally. 

Select the settings from the Time and Date lists and 
click OK. 
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Internet Integration
The blueberry COMPACT is integrated into the In-
ternet by means of a DSL router or in remote sites 
by means of the blueberry GSM Module. The GSM 
Module offers remote data transmission and real-
time access via cellular phone networks (900 MHz, 
1800 MHz and 1900 MHz). Two operation modes are 
available:

In GSM mode, the data logger is called from a PC by 
means of a telephone modem, similar to the dial-in 
connection to an Internet provider. This mode of-
fers direct access to the web server of the blueberry 
COMPACT. In GSM mode, the telephone costs depend 
on the connection time.

The GPRS mode offers full integration of the blue-
berry COMPACT into the Internet. The data logger 
connects itself automatically to the Internet provid-
ing realtime access from any Internet access point. 
Two password levels protect the data logger against 
unauthorized access. As GPRS does not use fixed IP 
addresses a dynamic DNS  server (e.g., dyndns.org) 
manages the dynamic IP address. It provides access 
via a named URL. The name of the server used by the 
blueberry COMPACT to access the Internet is called 
Access Point Name (APN). Private APNs provide 
outgoing data transmission from the data logger to 
the Internet, e.g., via FTP or e-mail. However, they 
block access from outside into the data logger. Pub-
lic APNs provide both access types. Dynamic DNS 
requires a public APN! Please make sure that your 
GSM provider offers a public APN. Public APNs are 
offered among others by T-Mobile (Germany), TIM 
(Italy), Telenor (Norway, Sweden), WARID (Paki-
stan). In GPRS mode, the telephone costs depend 
on the volume of transmitted data.

Please prepare the following information for the 
GSM/GPRS setup of the blueberry COMPACT:

1. The data number of the SIM card. Please make 
sure that you are really using the data number. 
Usually, SIM cards have separate numbers for 
voice, fax and asynchronous data transmission. 
We recommend to use SIM cards without voice 
function. Pure data cards are cheaper than voice 
cards.

2. The PIN of the SIM card. You must disable the PIN 
request before use because the blueberry COM-
PACT is not able to enter the PIN. Please insert 
the SIM card into your mobile phone, enter the 
PIN and disable the PIN request. 

3. The APN. Please make sure that you have got a 
public APN.

GPRS Connection

Select Setup > GPRS to setup a GPRS connection. 
Select yes at Activate GPRS and enter the APN and 
optionally the user name and password at GPRS In-
ternet Connection. Please ask your GSM provider for 
these data. A list of international APNs is available 
in the Internet at

http://www.quickim.com/support/gprs-
settings.html.

When the blueberry COMPACT operates in GPRS 
mode it will switch to GSM mode every day between 
20:00 and 21:00. During this time the data logger is 
accessible via dial-in connection.

Please enter the host name of the data logger in 
section Dynamic DNS Service. Please enter the ac-
cess code to your dyndns.org account in the fields 
Username and Password. The host name must 
be registered at http://www.dyndns.org before. 
Please refer to the following chapter for further 
details.

Click OK to save the settings.
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  Remote Access via Internet

GPRS networks use  dynamic IP addresses. Every time 
the blueberry COMPACT connects to the Internet it 
gets a new IP address from the Internet service pro-
vider. If we want to access the data logger via Inter-
net we need to know this IP address. Dynamic DNS 
manages dynamic IP addresses and provides access 
to them. The user defines a host name for his meas-
urement station (e.g., station-103.dyndns.org). 
When the blueberry COMPACT connects to the In-
ternet it sends its actual IP address to the DynDNS 
server. The DynDNS server translates the IP address 
to the host name of the data logger. This provides us 
access to the measurement station without know-
ing its IP address.

Creating a  DynDNS Access

Please proceed as follows to create your account 
and a host at DynDNS:

1. Open your Internet browser and visit the web 
site http://www.dyndns.org.

2. Select Create Account.

3. Define a user name, a password and enter your 
e-mail address.

 Scroll down and activate I agree to AUP and I 
will only create one (1) free account. Click on 
Create Account.

4. A message confirms the creation of your ac-
count.

5. You will now receive an e-mail with a confirma-
tion for the DynDNS account. This takes typically 
a few minutes. Open the e-mail and follow the 
stated link.
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9. Select Add New Hostname.

10. Enter a host name and click Use auto-detected 
IP address. Click Create Host.

11. A message confirms the creation of the new 
host.

This host can now be used with the 
blueberry COMPACT (see Setting up the GPRS con-
nection). If you want to create further hosts, please 
click Add New Hostname and repeat step 10.

 You have now created your account. The next 
steps create a DynDNS host.

6. Select Login.

7. Enter your access code (user name and password) 
and click Login.

8. Select My Services.
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4. Enter user name and password of the data logger 
into the  login dialog.

The functionality of the  mobile access depends 
on the browser of your  mobile device. Some  mo-
bile browsers might not be able of downloading 
measured data files.  Opera offers a powerful 
free  browser for  mobile phones. Please refer to 
http://www. operamini.com for further details.

Accessing the blueberry COMPACT via 
 Internet

Please proceed as follows to access your blueberry 
COMPACT from the Internet:

Start your Internet browser, enter the DyDNS 
host name of your measurement station (e.g., 
station-103.dyndns.org) into the address field and 
hit <enter>. Do not add www to the host name!

The remote  Internet access provides the same func-
tionality as the local access via Ethernet. The user 
can display and download data and diagrams and he 
can change the configuration.

Accessing the blueberry COMPACT from a 
 Mobile Phone

The blueberry COMPACT provides a special  web 
interface adapted to small displays of  pocket PCs, 
 MDAs and  mobile phones. 

Please proceed as follows to access your blueberry 
COMPACT from an Internet capable  mobile device :

1. Connect your mobile device to the Internet and 
start the Internet browser. 

2. Enter the DynDNS host name of your meas-
urement station into the address field 
and add / compact to the host name. (e.g., 
station-123.dyndns.org/compact). Do not add 
www to the host name!

3. Click Connect.
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4. Select Manual Connection and click on Next.

5. Select Modem Connection and click Next.

6. A list displays all modems available on your PC. 
Select the modem to be used for remote data 
transmission and click Next.

Remote Access via GSM

GPRS provides the most flexible and powerful re-
mote access to the blueberry COMPACT. It requires 
a public APN. For GSM providers that do not offer 
a public APN, the blueberry GSM Module provides 
remote connection to the blueberry COMPACT via 
PPP. This operation mode is similar to a dial-in con-
nection to an Internet server. It requires a PC with 
analogue telephone modem. 

Setting up the GSM Connection

Please proceed as follows in order to configure your 
Windows PC for a GSM remote connection:

1. Select Start > Settings > Network and Dial-In 
Connections > New Connection.  A wizard will 
lead you through the configuration process.

2. Click Next.

3. Select Establish an Internet Connection and 
click Next.
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9. Click Next without entering the access code in 
the dialogue.

10. Click Next to finish the configuration.

This chapter describes the configuration process 
under MS Windows XP. Similar wizards assist you at 
the configuration under Windows 2000, Mac OS or 
Linux.

7. Enter a name for the remote connection, e.g., 
the name of the measurement site and click 
Next.

8. Enter the telephone number of the GSM modem. 
GSM SIM cards have separate numbers for fax 
and data transmission. Please make sure to use 
the data number. Click Next.
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6. To disconnect the GSM connection click on the 
connection icon with the right mouse botton 
and select Disconnect from the popup menu.

Password Protection
Two password levels protect the blueberry COMPACT 
against unauthorized access:

The user guest is allowed to view actual measured 
data and configuration settings and to download 
measured data. He is allowed to set date and time. 
The user guest is not allowed to delete measured 
data or to change any configuration settings.

The user admin has all rights. He is allowed to de-
lete measured data and to change configuration 
settings.

Accessing the blueberry COMPACT via GSM

Please proceed as follows in order to establish a 
remote connection to the blueberry COMPACT via 
GSM:

1. Select Start > Settings > Network and Dial-In 
Connections > blueberry-ndl485 where blue-
berry-ndl485 is the name of your remote con-
nection.

2. Click on Dial without entering the access code. A 
dialogue diplays the progress while connecting. 
When the connection has been established the 
dialogue box changes into an icon in the lower 
right corner of the task bar.  

3. Once the connection is established, please start 
your Internet browser, enter the IP address 
10.1.1.1 into the address field of the browser 
and hit the <enter> key. Please note that this 
IP address is the same for all blueberry COMPACT 
units. It is independent of the IP address set at 
Local Network Settings.

4. Enter the user name and password for the 
blueberry COMPACT and click OK.

5. In GSM mode, the web interface provides all 
functions that are available at local or at GPRS 
connection.
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 Rebooting the blueberry 
COMPACT
The blueberry COMPACT can be rebooted in two 
ways: by interruption of the power supply and 
via the web interface. In order to reboot the 
blueberry COMPACT via the web interface please 
proceed as follows:

1. Start the web browser and login to the 
blueberry COMPACT as user admin.

2. Select Help > About > Maintenance.

3. Click on Reboot. 

4. Wait 2 minutes until the data logger is up again.

User Password

Login as user admin with the original admin pass-
word and select Setup > Password. Enter the new 
password for user guest and click OK. 

The original password for the user admin cannot be 
changed. You can however define a second admin 
password. The second admin user has all rights ex-
cept the one to change his own password.

 Help Function
The  help function the blueberry COMPACT provides 
system information about the data logger as well as 
an  online  manual.

Select Setup > Help > About. The dialog indicates 
information about type and  fi rmware version of the 
data logger.
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4. Select New Server and enter a name for the data 
logger.

5. Enter the IP address of the blueberry COMPACT  
into the Host field.

6. Select the logon type normal.

7. Enter the user name admin and the admin pass-
word of your blueberry COMPACT .

8. Click on Save to save the settings.

9. Click on Connect to built up the connection 
to the blueberry COMPACT. The right part 
of the screen displays the file system of the 
blueberry COMPACT. You can use the FTP cli-
ent like a file explorer to delete measured 
data files from the blueberry COMPACT and to 
move files from the blueberry COMPACT to your 
local computer or from your computer to the 
blueberry COMPACT.

FTP Access
Some operations, like deleting measured data and 
applying a firmware update require FTP access to 
the blueberry COMPACT. The following describes 
the establishment of an FTP access by means of the 
free FTP client FileZilla. 

Installing FileZilla

The FTP client FileZilla can be downloaded free of 
charge from the Internet at the following site:

 http://sourceforge.net/projects/filezilla

In order to install FileZilla and to configure it for 
the blueberry COMPACT please proceed as follows:

1. Download the software from the above stated 
website and install it according to the instruc-
tions of the supplier.

2. Start FileZilla.

3. Select File > Server Mangement.
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4. Change on the local computer to the folder that 
contains the firmware update file.

5. Click with the right mouse button on the 
firmware update file (e.g., Ndl485-2-0-11.in-
stall) and select Upload. Now, FTP transfers this 
file to your blueberry COMPACT. 

6. Please wait until the transfer is sucessfully com-
pleted. The uploaded file is now visible in the 
/tmp folder of the blueberry COMPACT.

7. Start the web browser and login to the 
blueberry COMPACT as user admin.

8. Select Help > About > Maintenance.

9. Click on Update in order to start the update 
process. 

Deleting Measured Data
The blueberry COMPACT saves measured data in a 
ring buffer. The oldest data lines are automatically 
overwritten when the data memory is full. Usually, 
deleting of measured data is only necessary at the 
beginning of a new measurement, e.g., if the data 
logger is moved to another site. In order to delete 
measured data please proceed as follows:

1. Establish an FTP connection to the 
blueberry COMPACT.

2. Double click on archive to change to the archive 
directory. 

3. Mark all files to be deleted and press <Del>.

If only data files (*.csv) are deleted the measure-
ment index continues with the actual value. In or-
der to reset the index please delete the file index.

Updating the Firmware
The firmware of the blueberry COMPACT can be up-
dated via local Ethernet connection or remotely via 
GSM, GPRS or DSL. In order to update the firmware 
of the blueberry COMPACT please proceed as fol-
lows:

1. Establish an FTP connection to the 
blueberry COMPACT.

2. Double click on .. to change to the root direc-
tory. 

3. Open the folder /tmp.
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Adapting the PC Network Set-
tings
When the  blueberry COMPACT is connected to a PC 
or a LAN the network settings of the PC must comply 
to those of the data logger.  

In order to change the network settings of the PC 
please proceed as follows:

1. Right click on the network icon in the task bar 
and select Open Network Settings.

2. Double click on LAN Connection.

3. Select Internet Protocol (TCP/IP) from the list 
and click on Properties.

10. Please follow the instructions displayed on the 
screen. The update process will take approx. 5 
minutes. The blueberry COMPACT will restart 
automatically after the update is completed. 
Regular flashing of the BUSY LED at the data log-
ger indicates that the blueberry COMPACT is up 
again. 

IMPORTANT NOTE: 
The blueberry COMPACT must never be disconnect-
ed from the power supply during update process! 
Interruption of the update process can block the 
operation of the blueberry COMPACT.

Please restart the web browser and login to the 
blueberry COMPACT.

In order to check whether the update was suc-
cessfull please select Help > About. Check whether 
the indicated firmware version corresponds to the 
update you went to apply.
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4. Activate Use the following IP Address. Enter the 
IP address, subnet mask and gateway according 
to the settings in the blueberry COMPACT. The 
blueberry COMPACT has two IP addresses: one 
is the fixed IP adress 192.168.111.1. This IP ad-
dress cannot be changed. The second IP address 
can be changed by the user. Please refer to the 
label on the data logger for its default settings.
The last entry of the IP address must be different 
from the setting of the data logger. All other set-
tings must be set identical to the data logger.

 Example:
Data logger:  192.168.0.31 
PC:     192.168.0.104 

5. Click Ok to accept the settings.

Displaying Diagrams
The blueberry COMPACT generates time series plots 
of all measured values and displays them as dia-
grams. The texts for title and y label of the diagram 
axes are taken from the name of the measurement 
function: the first part of the function name is used 
as diagram title, the second part is used as y axis 
label. First and second part must be separated by a 
space character. We recommend to write function 
names as Value (unit).

Example: 
relFeuchte (%rF) = 100 * a4

The diagram titel for this function is relFeuchte, 
the y axis label is (%rF).

Shorttime diagrams display a time series of the 
samples. Statistics diagrams display a time series of 
the statistics.
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Transmitting Measured Data 
via FTP
The blueberry COMPACT sends measured data au-
tomatically via FTP to a website or to a data file 
server. Please first setup the Internet integration 
via DSL or GPRS. 

Select Setup > FTP/Mail. 

Enter the URL of your FTP server in the field FTP 
Server. Enter the destination folder and access code 
and click OK to save the settings.
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Technical Specifications (compared to NDL 485)

Model blueberry COMPACT NDL 485 research
PartNo. 0141 0103

Measuring Inputs
Digital inputs 10 6

Analogue inputs 6 differential or 12 single ended 6 single ended

Additional inputs via RS485 and INPUT modules
(8 x AIN/DIN per module)

Serial inputs RS485, half-duplex, RS232 for Modem

Digital Measuring Inputs (DIN1 .. DIN6 / DIN10)
Measuring range frequency 0 .. 2,000 Hz

counter 0 .. 2,000 Hz
status HI / LO

Resolution 0.01 Hz

Accuracy frequency ± 0.1%
counter ± 1 pulse

Signal level HI = >2.5 V
LO = <0.7 V

or potential free switch closure

Input impedance >20 kΩ

Analogue Measuring Inputs (AIN1 .. AIN6)
Measuring range 0 .. 10 V

Resolution 16 Bit (0.2 .. 0.01 mV depending on measurement range)            //          16 Bit (0.2 mV)

Accuracy depending on measurement range      //      ± 0.1% of reading ± 1 mV

Input impedance >1 MΩ

Barometric Pressure Sensor
Type integrated baro sensor -

Measuring range 400 .. 1,100 hPa -

Resolution 0.1 hPa -

Accuracy ±0.2 hPa @ 700 .. 1,100 hPa -

Longterm stability ±0.5 hPa/a -

Measuring 
Functions

blueberry COMPACT NDL 485 research

Measuring interval 1 s .. 24 h 0.1 s .. 24 h

Statistic interval 1 s .. 24 h 0.1 s .. 24 h

Statistic funcions mean value 
(arithmetic + vector),

standard deviation
(arithmetic + vector),

minimum, maximum, sum

mean value 
(arithmetic + vector),

standard deviation
(arithmetic + vector),

minimum, maximum, sum, median

ANNEX
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Data memory for 
statistic time 
series

32 MB
non-volatile ring buffer

128 MB, expandable to up to 512 MB,
non-volatile ring buffer

Data memory for 
samples

32 MB
non-volatile ring buffer

Communication blueberry COMPACT NDL 485 research
Data interface RS232 interface,

1,200 .. 115,200 baud,
RS485 interface, half-duplex, 

1,200 .. 115,200 baud,
Ethernet interface (LAN), 10 MBit/s,

optional MODBUS-TCP protocol

Remote data 
transfer

GSM, GPRS, DSL, ISDN router

Automatical data 
transmission

via eMail via eMail and FTP

Internet integra-
tion

via GPRS or DSL

User interface web interface, Internet browser

Graphical data 
display

- realtime diagrams of measured values, 
optional custom specific graphical display

Display -

Power Supply
External 
power supply

5 .. 24 VDC

Internal 
power supply

-

Power consumption typ. 600 mW (50 mA @ 12 V)

Sensor excitation 
EXC

5..24 VDC switched, max. 500 mA

Switching outputs
DOUT1 .. DOUT4

4 switching outputs, max. 300 mA,
HI = supply voltage, LO = 0 V, 

time or event triggered

Mechanic and Operation Conditions
Casing 65 x 105 x 127 mm, IP20

top-hat rail housing, anodized aluminium

Connections screw terminals, connectors

Temperature range –40..+70 °C
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CE Compliancy Declaration
Based on test report no. EMV-08/8117-1 of 22.07.2008

Manufacturer:  Wilmers Messtechnik GmbH
Hammer Steindamm 35
D-22089 Hamburg / Germany

Product:    Data logger blueberry COMPACT

Part number:  0141 
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beacon lights  23
blueberry GSM Module  29
blueberry INPUT Module  22
blueberry NDL485  15
Boolean Operators  16
boolean operators  16
browse  28
browser  31
BUSY indicator  5
BUSY LED  6, 35

C

calibration  13
Casing  39
Character Delay  21
column headers  10
comma separated ASCII files  10
compact  28
Comparison  16, 17
comparison  16, 17
Connections  39
coordinate system  12
cos  16
Cosine function  16
counted pulses  19
crosspatch cable  6, 24
CSV data file  12
CSV file  10
Cumulated Rainfall  19

D

damped value  19
data format  10, 22
data memories  10
Data memory  39
Date  24
DAY  21
DAYTIME  20
decimal  22
Decimal delimiter  10
delete measured data  31
Deleting Measured Data  34
diagrams  36
diagram titel  14
dial-in  29
dial-in connection  25
digital measurement inputs  21
digital outputs  23
DIN1  21
DIN1..10  14
DIN1 .. DIN10  5
Direction 0..360°  15
Direction 360..0°  15

Index

Symbole

!=  17
! (NOT operator)  17
# (last value operator)  18
% (modulo operator)  16
( )  18
<  16
<=  17
==  17
>  16
>=  17
^  16
0102  (NDL485 version)  38
0103  (NDL485 version)  38
10.1.1.1 (IP address)  31
192.168.111.1 (fixed IP address)  36
4-wire technique  15

A

abs  18
Accuracy  38
actual measured values  9
AC frequency  14
AC Signal  14
addition  15
admin  31
AIN1  22
AIN1..6  15
AIN1 .. AIN6  5
alarm  23
ALARMi  23
alarm conditions  23
alarm devices  23
alarm e-mail  23
Alarm E-Mails  23
alignment  13
analogue measurement inputs  22
Analog Inputs  15
AND (operator)  18
Anemometers  14
APN (GPRS Access Point Name)  25

B

backup batteries  23
Barometric Pressure Sensor  38
Battery Monitoring  23
Baudrate  21
baud rate  21
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disconnect  31
DISPLAY  8
DISPLAY button  8
Display button  5
division  16
documentation  12
DOUT1..DOUT4  23
download of measured data  10
DSL  12
Dynamic DNS  25
Dynamic DNS Service  25
dynamic IP address  25, 26
dyndns.org  25
DynDNS Account  26
DynDNS host  27

E

e-mail  12, 23
e-mail address  12, 23
elevation  12
else  18
Ethernet  24
EXC  13
Excitation  13
Exponent  16
exponent  16

F

FileZilla  33
Filtering of Invalid Samples  18
firmware update  34
firmware updates  8
firmware version  32, 35
fixed IP adress  36
flashing light  20
floating point numbers  9
frequency  19, 21
Frequency AC  14
frequency signals  14
Frequency TTL  14
FTP/Mail  12, 23
FTP client  33
FTP data transfer  37
FTP Server  37
function name  13, 15

G

gateway  36
geographical coordinate system  12
Geographical Position  12
GND  5
GPRS connection  31
GPRS Internet Connection  25
GPRS mode  25
gradient  20

GSM mode  25, 31
GSM Module  25, 29
GSM provider  25
guest  31

H

half-duplex  38
Help  32
Help > About  35
Help > About > Maintenance  34
help function  32
Heval ECONOMY  14
hex  22
hexadecimal values  22
HOUR  21

I

if  17
index  34
Input impedance  38
input impedance  38
INPUT Module  19, 21
int  18
integration  20
Internet  24, 25, 28
Internet access  28
Internet integration  12, 37
Internet server  29
IP address  24, 25, 31, 36

L

LAN  24
latitude  12
LED  5, 8
LED Display  5, 8
ln  16
logarithm  16
login  6, 9
login dialog  28
longitude  12
low pass filter  19

M

mail address  23
mail addresses  12, 23
Mail Server  12, 23
mail settings  23
Maintenance  34
manual  32
Marking of Invalid Samples  18
mast type  12
MDA  28
measurement function  13, 15
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measurement functions  21
measurement process  12
measurement site  12
measure period  13
MINUTE  21
mobile access  28
mobile browser  28
mobile device  28
Mobile Phone  28
mobile phone  28
MODBUS  39
modem  29
modulo division  16
MONTH  20
mounting booms  13
multiplication  16

N

Name of the measurement site  12
nan (not a number)  18, 21
Natural logarithm  16
NDL 485 basic  38
NDL 485 research  38
Network  24
network  24
network settings  35
NOT operator  17

O

obstacles  12
Offset  14
online manual  32
Opera  28
operamini  28
orography  12
OR (operator)  18

P

Password  25
password  23, 25, 31
PC network (LAN)  24
PC Network Settings  35
PERIOD  20
period  10
pocket PC  28
Poll Command  21
poll command  21
poll pause  21
Potentiometer  15
Power consumption  39
Power Supply  39
POW + GND  5
PPP  29
previous measurement  19

previous value  18
Pt100  15
public APN  25
pullup resistor  14
pulses  19

Q

QR Code  5, 8

R

rainfall  19
rain gauge  14
realtime access  25
realtime clock  24
realtime diagrams  13
Rebooting  32
Remote Access  26
Remote Access via Internet  26
remote connection  29, 31
remote data transmission  25
research  (NDL485 version)  38
Resistance  15
Resolution  38
Retry  21
ring buffer  39
RISØ anemometer  14
roughness  12
round  18
Rounding Operators  18
RS232  5
RS485  5, 38
RS485, half-duplex  38
RS485 bus  21

S

SECOND  21
Send Alarms to  23
sensors  13
sensor characteristics  13
sensor heating  23
sensor mounting booms  13
Serial inputs  38
serial number  10
serial numbers  13
Signal level  38
sin  16
Sine function  16
Site Description  12
Slope  14
smartphone  8
sonic anemometers  5, 21
statistical evaluations  13, 15
statistics files  10
status HI / LO  38
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subnet mask  36
subtraction  16
switched power supplies  23
Switching outputs  39
synchronization  24

T

TCP/IP  35
Technical Data  34
Temperature  15
Temperature range  39
Test Mail Transfer  23
Thies First Class  14
TIME  20
Time  24
Time Info  20
time series plots  36
time server  24
time zone  24
tipping bucket  14
transfer function  14
TTL  14

U

Update  34
Updating the Firmware  34
Username  25
user admin  31
user guest  31
user name  23
UTC  24

V

valid  17
Validity Check  17
validity check  17
variables  13, 19
vector  16
Vector A100  14
virtual channels  21
Voltage  15, 22

W

web interface  9, 28, 31
web server  25
WEEKDAY  21
wind speed vector  16

Y

N O T E S
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